aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/openvpn/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index d19f2b43ba19..d6c2b8b47167 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openvpn
DISTVERSION= 2.3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net
MASTER_SITES= http://swupdate.openvpn.net/community/releases/ \
http://build.openvpn.net/downloads/releases/
@@ -25,7 +25,7 @@ SHEBANG_FILES= sample/sample-scripts/verify-cn \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= PW_SAVE PKCS11 EASYRSA DOCS EXAMPLES
+OPTIONS_DEFINE= PW_SAVE PKCS11 EASYRSA DOCS EXAMPLES X509ALTUSERNAME
OPTIONS_DEFAULT= EASYRSA OPENSSL
OPTIONS_SINGLE= SSL
OPTIONS_SINGLE_SSL= OPENSSL POLARSSL
@@ -33,6 +33,7 @@ PW_SAVE_DESC= Interactive passwords may be read from a file
PKCS11_DESC= Use security/pkcs11-helper
EASYRSA_DESC= Install security/easy-rsa RSA helper package
POLARSSL_DESC= SSL/TLS support via PolarSSL
+X509ALTUSERNAME_DESC= Enable --x509-username-field (only with OpenSSL)
EASYRSA_RUN_DEPENDS= easy-rsa>=0:${PORTSDIR}/security/easy-rsa
@@ -41,11 +42,17 @@ PKCS11_CONFIGURE_ENABLE= pkcs11
PW_SAVE_CONFIGURE_ENABLE= password-save
+X509ALTUSERNAME_CONFIGURE_ENABLE= x509-alt-username
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPOLARSSL}
+. if ${PORT_OPTIONS:MX509ALTUSERNAME}
+BROKEN= OpenVPN ${DISTVERSION} cannot use --x509-username-field with PolarSSL. Disable X509ALTUSERNAME, or use OpenSSL instead
+. else
LIB_DEPENDS+= libpolarssl.so:${PORTSDIR}/security/polarssl
CONFIGURE_ARGS+= --with-crypto-library=polarssl
+. endif
.else
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-crypto-library=openssl