aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/ttyd/Makefile26
-rw-r--r--sysutils/ttyd/distinfo3
-rw-r--r--sysutils/ttyd/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 36fea7f22148..802f91efeeff 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1116,6 +1116,7 @@
SUBDIR += tren
SUBDIR += ts
SUBDIR += tss
+ SUBDIR += ttyd
SUBDIR += tty-clock
SUBDIR += ttyload
SUBDIR += tuptime
diff --git a/sysutils/ttyd/Makefile b/sysutils/ttyd/Makefile
new file mode 100644
index 000000000000..dd880197f8fc
--- /dev/null
+++ b/sysutils/ttyd/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= ttyd
+PORTVERSION= 1.2.0
+CATEGORIES= sysutils
+
+MAINTAINER= neel@neelc.org
+COMMENT= Program to share your terminal over the web
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= xxd:editors/vim-lite
+LIB_DEPENDS= libjson-c.so:devel/json-c \
+ libwebsockets.so:net/libwebsockets
+
+USE_GITHUB= yes
+GH_ACCOUNT= tsl0922
+
+USES= cmake pkgconfig ssl
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ttyd ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/ttyd/distinfo b/sysutils/ttyd/distinfo
new file mode 100644
index 000000000000..bb425db1b47b
--- /dev/null
+++ b/sysutils/ttyd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479470581
+SHA256 (tsl0922-ttyd-1.2.0_GH0.tar.gz) = 00f8399a1045057a55a5a5dd2540bfbf39df972ad0c1c2a9e3bc94574514c9bd
+SIZE (tsl0922-ttyd-1.2.0_GH0.tar.gz) = 177550
diff --git a/sysutils/ttyd/pkg-descr b/sysutils/ttyd/pkg-descr
new file mode 100644
index 000000000000..5ec406c3fa67
--- /dev/null
+++ b/sysutils/ttyd/pkg-descr
@@ -0,0 +1,4 @@
+ttyd is a simple command-line tool for sharing terminal over the web, inspired
+by GoTTY.
+
+WWW: https://www.github.com/tsl0922/ttyd