aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/qelectrotech/Makefile2
-rw-r--r--devel/atlas-devel/Makefile2
-rw-r--r--devel/eris/Makefile2
-rw-r--r--devel/mercator/Makefile1
-rw-r--r--devel/varconf/Makefile2
-rw-r--r--games/ember/Makefile2
-rw-r--r--graphics/ogre3d/Makefile2
-rw-r--r--net/cyphesis/Makefile2
-rw-r--r--net/skstream/Makefile2
-rw-r--r--textproc/irstlm/Makefile2
10 files changed, 9 insertions, 10 deletions
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
index 643dba82932d..a37e51ff1bb0 100644
--- a/cad/qelectrotech/Makefile
+++ b/cad/qelectrotech/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= qmake
USE_QT4= gui moc_build network rcc_build \
sql-sqlite3_run svg uic_build xml designer
-USE_GCC= 4.7+
+USE_GCC= yes
INSTALLS_ICONS= yes
CXXFLAGS+= "-fno-ipa-sra"
diff --git a/devel/atlas-devel/Makefile b/devel/atlas-devel/Makefile
index 31d7a3fcaef9..2357de317faf 100644
--- a/devel/atlas-devel/Makefile
+++ b/devel/atlas-devel/Makefile
@@ -19,7 +19,7 @@ USES= pathfix compiler:c++11-lang
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
USE_BZIP2= YES
-USE_GCC= 4.7+
+USE_GCC= yes
MAKE_ARGS= docdir=${DOCSDIR}
CONFIGURE_ARGS+=--program-transform-name=
diff --git a/devel/eris/Makefile b/devel/eris/Makefile
index 231231137a0e..23cd1ea421ce 100644
--- a/devel/eris/Makefile
+++ b/devel/eris/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ARGS= --disable-silent-rules
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= pathfix pkgconfig
-USE_GCC= 4.7+
+USE_GCC= yes
CXXFLAGS+= -include wchar.h
diff --git a/devel/mercator/Makefile b/devel/mercator/Makefile
index 7ee68f18a15e..abd622d4cc3b 100644
--- a/devel/mercator/Makefile
+++ b/devel/mercator/Makefile
@@ -18,7 +18,6 @@ USES= pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GCC= yes
-USE_GCC= 4.7+
CXXFLAGS+= -include wchar.h
diff --git a/devel/varconf/Makefile b/devel/varconf/Makefile
index 46570cfc456c..80c09c1dc4c9 100644
--- a/devel/varconf/Makefile
+++ b/devel/varconf/Makefile
@@ -19,7 +19,7 @@ USE_BZIP2= yes
USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-USE_GCC= 4.7+
+USE_GCC= yes
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/ember/Makefile b/games/ember/Makefile
index f082819baba8..c53f9a03c341 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -38,7 +38,7 @@ LUA_COMPS= toluaxx
USES= openal:al,alut pathfix pkgconfig
USE_BZIP2= YES
CPPFLAGS+= -DBR_NO_MACROS -std=c++11
-USE_GCC= 4.7+
+USE_GCC= yes
NO_STAGE= yes
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index c02c37114fe7..e0e4e8a88e6b 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= YES
USES= cmake
USE_SDL= sdl
USE_XORG= xaw xrandr
-USE_GCC= 4.7+
+USE_GCC= yes
NO_STAGE= yes
.include <bsd.port.options.mk>
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index 3fe664062f57..13aabe11078b 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -26,7 +26,7 @@ USES= gmake pathfix pkgconfig
USE_LDCONFIG= yes
USE_PGSQL= yes
USE_PYTHON= 2
-USE_GCC= 4.7+
+USE_GCC= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/net/skstream/Makefile b/net/skstream/Makefile
index eaa4b5645ce9..2fd9af176680 100644
--- a/net/skstream/Makefile
+++ b/net/skstream/Makefile
@@ -13,7 +13,7 @@ USE_GMAKE= yes
USES= pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GCC= 4.7+
+USE_GCC= yes
OPTIONS_DEFINE= DOCS
diff --git a/textproc/irstlm/Makefile b/textproc/irstlm/Makefile
index d52177a06c0c..edd4ccb4b5b4 100644
--- a/textproc/irstlm/Makefile
+++ b/textproc/irstlm/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
USE_PERL5= run
-USE_GCC= 4.7+
+USE_GCC= yes
USE_AUTOTOOLS= libtoolize aclocal autoconf automake
AUTOMAKE_ARGS= --add-missing
USES= shebangfix