aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/shaaft/Makefile5
-rw-r--r--games/shaaft/files/patch-utilsgl_gl++.hpp15
2 files changed, 16 insertions, 4 deletions
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index 34a5495377ea..44002e6ab735 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -15,12 +15,9 @@ LIB_DEPENDS= libpng.so:graphics/png
CONFLICTS= criticalmass-*
-BROKEN_aarch64= fails to compile: error: conflicting declaration typedef int GLintptrARB
-BROKEN_sparc64= does not compile
-
USES= tar:bzip2
USE_SDL= mixer image sdl
-USE_GL= yes
+USE_GL= gl
USE_GCC= any
USE_CXXSTD= gnu++98
GNU_CONFIGURE= yes
diff --git a/games/shaaft/files/patch-utilsgl_gl++.hpp b/games/shaaft/files/patch-utilsgl_gl++.hpp
new file mode 100644
index 000000000000..aae454102b59
--- /dev/null
+++ b/games/shaaft/files/patch-utilsgl_gl++.hpp
@@ -0,0 +1,15 @@
+--- utilsgl/gl++.hpp.orig 2004-01-01 04:32:28 UTC
++++ utilsgl/gl++.hpp
+@@ -27,12 +27,6 @@
+ # if defined(_WIN64)
+ typedef __int64 GLintptrARB;
+ typedef __int64 GLsizeiptrARB;
+-# elif defined(__ia64__) || defined(__x86_64__)
+- typedef long int GLintptrARB;
+- typedef long int GLsizeiptrARB;
+-# else
+- typedef int GLintptrARB;
+- typedef int GLsizeiptrARB;
+ # endif
+ #endif
+