aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/metis-edf/Makefile8
-rw-r--r--science/cdf/Makefile6
2 files changed, 12 insertions, 2 deletions
diff --git a/math/metis-edf/Makefile b/math/metis-edf/Makefile
index 329199862787..be4ebe312cef 100644
--- a/math/metis-edf/Makefile
+++ b/math/metis-edf/Makefile
@@ -29,6 +29,12 @@ PROGS= kmetis onmetis.exe pmetis
MACHINEARCH= ${ARCH}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700000
+WITH_FORTRAN= yes
+.endif
+
pre-configure:
.if ${MACHINEARCH} != "i386"
@${FIND} ${WRKSRC} -type f -name "*.c" -o -name "*.h" | ${XARGS} \
@@ -56,4 +62,4 @@ post-install:
@${ECHO_MSG} "===> Test file installed in ${EXAMPLESDIR}."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/cdf/Makefile b/science/cdf/Makefile
index 81fc0dd08ccd..4ed760d44ba3 100644
--- a/science/cdf/Makefile
+++ b/science/cdf/Makefile
@@ -19,7 +19,7 @@ COMMENT= Device independent view of the CDF data model
MAKE_FLAGS= INSTALLDIR=${PREFIX} OS=${OPSYS:L} ENV=gnu \
FORTRAN=yes F77=${F77}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
VER= ${PORTVERSION:S/.//}
@@ -38,6 +38,10 @@ PORTDOCS= CDF_copyright.txt CHANGES.txt Release.notes Welcome.txt
BROKEN= Does not compile on ${ARCH}
.endif
+.if ${OSVERSION} >= 700000
+WITH_FORTRAN= yes
+.endif
+
pre-configure:
.for def in ${DEFS}
${REINPLACE_CMD} -e 's|<path>|${PREFIX}|' \