aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/bk2site/Makefile1
-rw-r--r--www/bk2site/files/patch-bk2site.C16
-rw-r--r--www/bk2site/files/patch-reference.C11
3 files changed, 28 insertions, 0 deletions
diff --git a/www/bk2site/Makefile b/www/bk2site/Makefile
index baeefcfa1173..387dc2031362 100644
--- a/www/bk2site/Makefile
+++ b/www/bk2site/Makefile
@@ -8,6 +8,7 @@
PORTNAME= bk2site
PORTVERSION= 1.1.9
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/www/bk2site/files/patch-bk2site.C b/www/bk2site/files/patch-bk2site.C
new file mode 100644
index 000000000000..00bf14e0de9c
--- /dev/null
+++ b/www/bk2site/files/patch-bk2site.C
@@ -0,0 +1,16 @@
+--- bk2site.C.orig Fri Feb 18 21:54:52 2005
++++ bk2site.C Fri Feb 18 21:57:13 2005
+@@ -448,10 +448,11 @@
+ cout << "Reading " << varValues[URLLOGFILE] << endl;
+ time_t curTime;
+ time_t cutoffTime = time(0) - atoi(varValues[HITSTIMECUTOFF].c_str());
+- string currentURL = "";
++ string currentURL = "", scurTime = "";
+ while (!(istream.eof())){
+- istream >> curTime;
++ istream >> scurTime;
+ istream >> currentURL;
++ curTime = atoi(scurTime.c_str());
+ //if url starts with a number (its a time) or url is null
+ // keep trying to read a time/url pair.
+ while (((currentURL[0] >= '0' && currentURL[0] <= '9') || currentURL == "") && !istream.eof()){
diff --git a/www/bk2site/files/patch-reference.C b/www/bk2site/files/patch-reference.C
new file mode 100644
index 000000000000..061d00f291d6
--- /dev/null
+++ b/www/bk2site/files/patch-reference.C
@@ -0,0 +1,11 @@
+--- reference.C.orig Fri Feb 18 21:11:01 2005
++++ reference.C Fri Feb 18 21:17:18 2005
+@@ -305,7 +305,7 @@
+ string getRFC822Time (long int time){
+ time_t li = time;
+ struct tm * t = localtime(&li);
+- char formatedTime[100];
++ static char formatedTime[100];
+ strftime(formatedTime, 100, "%a, %d %b %Y %T %Z", t);
+ return formatedTime;
+ }