aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/cl-babel-clisp/Makefile3
-rw-r--r--devel/cl-alexandria-clisp/Makefile3
-rw-r--r--devel/cl-asdf-clisp/Makefile3
-rw-r--r--devel/cl-cffi-clisp/Makefile3
-rw-r--r--devel/cl-infix-clisp/Makefile3
-rw-r--r--devel/cl-port-clisp/Makefile3
-rw-r--r--devel/cl-split-sequence-clisp/Makefile3
-rw-r--r--devel/cl-trivial-features-clisp/Makefile3
-rw-r--r--devel/cl-trivial-gray-streams-clisp/Makefile3
-rw-r--r--devel/meta-cvs/Makefile3
-rw-r--r--security/cl-md5-clisp/Makefile3
-rw-r--r--textproc/cl-meta-clisp/Makefile3
-rw-r--r--textproc/cl-ppcre-clisp/Makefile3
-rw-r--r--www/cl-lml-clisp/Makefile3
14 files changed, 42 insertions, 0 deletions
diff --git a/converters/cl-babel-clisp/Makefile b/converters/cl-babel-clisp/Makefile
index 6cad8f1f6f60..e9d81a85bec1 100644
--- a/converters/cl-babel-clisp/Makefile
+++ b/converters/cl-babel-clisp/Makefile
@@ -10,6 +10,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A charset encoding/decoding library written in Common Lisp
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/babel/babel.asd:${PORTSDIR}/converters/cl-babel \
${LOCALBASE}/${CL_LIBDIR_REL}/alexandria/clispfasl/arrays.fasl:${PORTSDIR}/devel/cl-alexandria-clisp \
${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/clispfasl/src/tf-clisp.fasl:${PORTSDIR}/devel/cl-trivial-features-clisp \
diff --git a/devel/cl-alexandria-clisp/Makefile b/devel/cl-alexandria-clisp/Makefile
index dbd1a88af9e9..f75cc4368af3 100644
--- a/devel/cl-alexandria-clisp/Makefile
+++ b/devel/cl-alexandria-clisp/Makefile
@@ -10,6 +10,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A collection of portable public domain utilities for Common Lisp
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/alexandria/alexandria.asd:${PORTSDIR}/devel/cl-alexandria
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/alexandria/alexandria.asd:${PORTSDIR}/devel/cl-alexandria
diff --git a/devel/cl-asdf-clisp/Makefile b/devel/cl-asdf-clisp/Makefile
index b8ccd26a2d4c..d8f8731bd55a 100644
--- a/devel/cl-asdf-clisp/Makefile
+++ b/devel/cl-asdf-clisp/Makefile
@@ -11,6 +11,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A system definition facility for Common Lisp
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
# Even if this port builds FASL files, it is slightly different from
# other FASL ports because it uses USE_ASDF rather than USE_ASDF_FASL.
diff --git a/devel/cl-cffi-clisp/Makefile b/devel/cl-cffi-clisp/Makefile
index e240d1acaddd..d7d8b4b169f0 100644
--- a/devel/cl-cffi-clisp/Makefile
+++ b/devel/cl-cffi-clisp/Makefile
@@ -9,6 +9,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A portable foreign function interface for Common Lisp
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/cffi/cffi.asd:${PORTSDIR}/devel/cl-cffi \
${LOCALBASE}/${CL_LIBDIR_REL}/alexandria/clispfasl/arrays.fasl:${PORTSDIR}/devel/cl-alexandria-clisp \
${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/clispfasl/src/tf-clisp.fasl:${PORTSDIR}/devel/cl-trivial-features-clisp \
diff --git a/devel/cl-infix-clisp/Makefile b/devel/cl-infix-clisp/Makefile
index a58c5d5071b6..feff72bbf42f 100644
--- a/devel/cl-infix-clisp/Makefile
+++ b/devel/cl-infix-clisp/Makefile
@@ -10,6 +10,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A lisp macro to read math statements in infix notation
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/infix/infix.asd:${PORTSDIR}/devel/cl-infix
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/infix/infix.asd:${PORTSDIR}/devel/cl-infix
diff --git a/devel/cl-port-clisp/Makefile b/devel/cl-port-clisp/Makefile
index e32e1a07b902..06ec52f0543c 100644
--- a/devel/cl-port-clisp/Makefile
+++ b/devel/cl-port-clisp/Makefile
@@ -11,6 +11,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Cross-Lisp portability package
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/port/port.asd:${PORTSDIR}/devel/cl-port
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/port/port.asd:${PORTSDIR}/devel/cl-port
diff --git a/devel/cl-split-sequence-clisp/Makefile b/devel/cl-split-sequence-clisp/Makefile
index 43ff01fd9620..72000a9d0e7c 100644
--- a/devel/cl-split-sequence-clisp/Makefile
+++ b/devel/cl-split-sequence-clisp/Makefile
@@ -11,6 +11,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Partitioning Common Lisp sequences
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence
diff --git a/devel/cl-trivial-features-clisp/Makefile b/devel/cl-trivial-features-clisp/Makefile
index cfa9c80ab78e..e83bca1dd93c 100644
--- a/devel/cl-trivial-features-clisp/Makefile
+++ b/devel/cl-trivial-features-clisp/Makefile
@@ -10,6 +10,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Ensures consistent *FEATURES* in Common Lisp
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/trivial-features.asd:${PORTSDIR}/devel/cl-trivial-features
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/trivial-features.asd:${PORTSDIR}/devel/cl-trivial-features
diff --git a/devel/cl-trivial-gray-streams-clisp/Makefile b/devel/cl-trivial-gray-streams-clisp/Makefile
index 172920f788d0..58d5d9647da1 100644
--- a/devel/cl-trivial-gray-streams-clisp/Makefile
+++ b/devel/cl-trivial-gray-streams-clisp/Makefile
@@ -10,6 +10,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A thin compatibility layer for Gray streams
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-gray-streams/trivial-gray-streams.asd:${PORTSDIR}/devel/cl-trivial-gray-streams
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-gray-streams/trivial-gray-streams.asd:${PORTSDIR}/devel/cl-trivial-gray-streams
diff --git a/devel/meta-cvs/Makefile b/devel/meta-cvs/Makefile
index 8ecdb6d7a7b0..631777e56262 100644
--- a/devel/meta-cvs/Makefile
+++ b/devel/meta-cvs/Makefile
@@ -11,6 +11,9 @@ COMMENT= A more capable version control system than CVS, built around CVS
LICENSE= GPLv2
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= clisp:${PORTSDIR}/lang/clisp \
lndir:${PORTSDIR}/devel/lndir
RUN_DEPENDS= clisp:${PORTSDIR}/lang/clisp
diff --git a/security/cl-md5-clisp/Makefile b/security/cl-md5-clisp/Makefile
index b53c4f58e1d6..5427972e0a68 100644
--- a/security/cl-md5-clisp/Makefile
+++ b/security/cl-md5-clisp/Makefile
@@ -10,6 +10,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Native MD5 implementation in Common Lisp
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/md5/md5.asd:${PORTSDIR}/security/cl-md5
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/md5/md5.asd:${PORTSDIR}/security/cl-md5
diff --git a/textproc/cl-meta-clisp/Makefile b/textproc/cl-meta-clisp/Makefile
index f3ecdcf3adef..28e610ff5c5b 100644
--- a/textproc/cl-meta-clisp/Makefile
+++ b/textproc/cl-meta-clisp/Makefile
@@ -12,6 +12,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A parser generator for Common Lisp
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/meta/meta.asd:${PORTSDIR}/textproc/cl-meta
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/meta/meta.asd:${PORTSDIR}/textproc/cl-meta
diff --git a/textproc/cl-ppcre-clisp/Makefile b/textproc/cl-ppcre-clisp/Makefile
index ebcc3908382c..f9ffd9b69431 100644
--- a/textproc/cl-ppcre-clisp/Makefile
+++ b/textproc/cl-ppcre-clisp/Makefile
@@ -10,6 +10,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Portable Perl-Compatible Regular Expression for Common Lisp
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/cl-ppcre/cl-ppcre.asd:${PORTSDIR}/textproc/cl-ppcre
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/cl-ppcre/cl-ppcre.asd:${PORTSDIR}/textproc/cl-ppcre
diff --git a/www/cl-lml-clisp/Makefile b/www/cl-lml-clisp/Makefile
index aa924427cbb6..fc0e302080e2 100644
--- a/www/cl-lml-clisp/Makefile
+++ b/www/cl-lml-clisp/Makefile
@@ -11,6 +11,9 @@ DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Lisp Markup Language
+DEPRECATED= Depends on deprecated lang/clisp
+EXIPIRATION_DATE= 2014-07-28
+
BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/system-registry/lml.asd:${PORTSDIR}/www/cl-lml
RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/system-registry/lml.asd:${PORTSDIR}/www/cl-lml