aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/p5-DBIx-SearchBuilder/Makefile18
-rw-r--r--devel/p5-Module-Info/Makefile2
-rw-r--r--devel/p5-Test-More-UTF8/Makefile4
-rw-r--r--devel/p5-capitalization/Makefile4
-rw-r--r--mail/p5-Mail-MboxParser/Makefile4
-rw-r--r--net-mgmt/nagios-check_netsnmp/Makefile2
-rw-r--r--net/p5-Net-Whois/Makefile2
-rw-r--r--textproc/p5-MARC-Lint/Makefile2
-rw-r--r--www/p5-HTML-Summary/Makefile2
-rw-r--r--www/p5-HTTP-Server-Simple-Mason/Makefile6
10 files changed, 23 insertions, 23 deletions
diff --git a/databases/p5-DBIx-SearchBuilder/Makefile b/databases/p5-DBIx-SearchBuilder/Makefile
index 6ddcdd36d06d..fe2e8d39398b 100644
--- a/databases/p5-DBIx-SearchBuilder/Makefile
+++ b/databases/p5-DBIx-SearchBuilder/Makefile
@@ -14,15 +14,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Perl extension for easy SQL SELECT Statement generation
-BUILD_DEPENDS= ${SITE_PERL}/Class/ReturnValue.pm:${PORTSDIR}/devel/p5-Class-ReturnValue \
- ${SITE_PERL}/Cache/Simple/TimedExpiry.pm:${PORTSDIR}/devel/p5-Cache-Simple-TimedExpiry \
- ${SITE_PERL}/${PERL_ARCH}/Want.pm:${PORTSDIR}/devel/p5-Want \
- ${SITE_PERL}/capitalization.pm:${PORTSDIR}/devel/p5-capitalization \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/DBIx/DBSchema.pm:${PORTSDIR}/databases/p5-DBIx-DBSchema \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
- ${SITE_PERL}/${PERL_ARCH}/Encode.pm:${PORTSDIR}/converters/p5-Encode
+BUILD_DEPENDS= p5-Class-ReturnValue>=0:${PORTSDIR}/devel/p5-Class-ReturnValue \
+ p5-Cache-Simple-TimedExpiry>=0:${PORTSDIR}/devel/p5-Cache-Simple-TimedExpiry \
+ p5-Want>=0:${PORTSDIR}/devel/p5-Want \
+ p5-capitalization>=0:${PORTSDIR}/devel/p5-capitalization \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-DBIx-DBSchema>=0:${PORTSDIR}/databases/p5-DBIx-DBSchema \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
+ p5-Encode>=0:${PORTSDIR}/converters/p5-Encode
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
diff --git a/devel/p5-Module-Info/Makefile b/devel/p5-Module-Info/Makefile
index 69e60683795a..51aadc0f69e8 100644
--- a/devel/p5-Module-Info/Makefile
+++ b/devel/p5-Module-Info/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Provides information about Perl modules
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
+BUILD_DEPENDS= p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-More-UTF8/Makefile b/devel/p5-Test-More-UTF8/Makefile
index cb9070e18f13..e805dbcd659a 100644
--- a/devel/p5-Test-More-UTF8/Makefile
+++ b/devel/p5-Test-More-UTF8/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Enhancing Test::More for UTF8-based projects
-BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/ex/lib.pm:${PORTSDIR}/devel/p5-ex-lib
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-ex-lib>=0:${PORTSDIR}/devel/p5-ex-lib
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-capitalization/Makefile b/devel/p5-capitalization/Makefile
index 06577f724e1a..78d16dc5546b 100644
--- a/devel/p5-capitalization/Makefile
+++ b/devel/p5-capitalization/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Perl module which allows you to use familiar style on method naming
-BUILD_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= p5-Devel-Symdump>=0:${PORTSDIR}/devel/p5-Devel-Symdump \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-Mail-MboxParser/Makefile b/mail/p5-Mail-MboxParser/Makefile
index a79f722d6642..962979390e21 100644
--- a/mail/p5-Mail-MboxParser/Makefile
+++ b/mail/p5-Mail-MboxParser/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= A module for working with UNIX-flavoured mailboxes
-BUILD_DEPENDS= ${SITE_PERL}/MIME/Tools.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/Mail/Mbox/MessageParser.pm:${PORTSDIR}/mail/p5-Mail-Mbox-MessageParser
+BUILD_DEPENDS= p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
+ p5-Mail-Mbox-MessageParser>=0:${PORTSDIR}/mail/p5-Mail-Mbox-MessageParser
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net-mgmt/nagios-check_netsnmp/Makefile b/net-mgmt/nagios-check_netsnmp/Makefile
index 3a45d16ace4f..162fef5a3a4d 100644
--- a/net-mgmt/nagios-check_netsnmp/Makefile
+++ b/net-mgmt/nagios-check_netsnmp/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Nagios plug-in to get some common NetSNMP-exported information
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/utils.pm:${PORTSDIR}/net-mgmt/nagios-plugins \
- ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP
+ p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP
USE_PERL5_RUN= yes
NO_BUILD= yes
diff --git a/net/p5-Net-Whois/Makefile b/net/p5-Net-Whois/Makefile
index 2cee72446579..706b9640a251 100644
--- a/net/p5-Net-Whois/Makefile
+++ b/net/p5-Net-Whois/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= A perl5 module to get information using the Whois protocol
-RUN_DEPENDS= ${SITE_PERL}/Locale/Country.pm:${PORTSDIR}/misc/p5-Locale-Codes
+RUN_DEPENDS= p5-Locale-Codes>=0:${PORTSDIR}/misc/p5-Locale-Codes
PERL_CONFIGURE= YES
diff --git a/textproc/p5-MARC-Lint/Makefile b/textproc/p5-MARC-Lint/Makefile
index 7dc2b355e210..b4800d9ba1b4 100644
--- a/textproc/p5-MARC-Lint/Makefile
+++ b/textproc/p5-MARC-Lint/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= A mechanism for validating MARC records
-BUILD_DEPENDS= ${SITE_PERL}/MARC/Record.pm:${PORTSDIR}/textproc/p5-MARC-Record \
+BUILD_DEPENDS= p5-MARC-Record>=0:${PORTSDIR}/textproc/p5-MARC-Record \
p5-Business-ISBN>=2.03:${PORTSDIR}/misc/p5-Business-ISBN
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/www/p5-HTML-Summary/Makefile b/www/p5-HTML-Summary/Makefile
index 047b7ccc9aef..c87f9ece03af 100644
--- a/www/p5-HTML-Summary/Makefile
+++ b/www/p5-HTML-Summary/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Produces summaries from the textual content of web pages
-BUILD_DEPENDS= ${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree
+BUILD_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree
PERL_CONFIGURE= yes
diff --git a/www/p5-HTTP-Server-Simple-Mason/Makefile b/www/p5-HTTP-Server-Simple-Mason/Makefile
index 1f17757dc6aa..b9007d528f63 100644
--- a/www/p5-HTTP-Server-Simple-Mason/Makefile
+++ b/www/p5-HTTP-Server-Simple-Mason/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= An abstract baseclass for a standalone mason server
-BUILD_DEPENDS= ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
- ${SITE_PERL}/Apache/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
- ${SITE_PERL}/Hook/LexWrap.pm:${PORTSDIR}/devel/p5-Hook-LexWrap
+BUILD_DEPENDS= p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ p5-HTML-Mason>=0:${PORTSDIR}/www/p5-HTML-Mason \
+ p5-Hook-LexWrap>=0:${PORTSDIR}/devel/p5-Hook-LexWrap
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE=yes