aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/calligra/Makefile6
-rw-r--r--editors/koffice-kde3/Makefile6
-rw-r--r--editors/koffice-kde4/Makefile6
3 files changed, 12 insertions, 6 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 73e3c58ea121..d27cbfd2dede 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -33,7 +33,9 @@ LIB_DEPENDS= GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick \
xslt:${PORTSDIR}/textproc/libxslt
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-USE_AUTOTOOLS= libtool:15
+BROKEN= does not build with GraphicsMagick v.1.2.3 and newer
+
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
@@ -54,7 +56,7 @@ CONFIGURE_ARGS+=--with-pgsqlincdir=${LOCALBASE}/include \
.if ${OSVERSION} < 500035
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-kexi-main-keximainwindowimpl.cpp
-CONFIGURE_ARGS+= --disable-final
+CONFIGURE_ARGS+=--disable-final
.endif
post-configure:
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index 73e3c58ea121..d27cbfd2dede 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -33,7 +33,9 @@ LIB_DEPENDS= GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick \
xslt:${PORTSDIR}/textproc/libxslt
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-USE_AUTOTOOLS= libtool:15
+BROKEN= does not build with GraphicsMagick v.1.2.3 and newer
+
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
@@ -54,7 +56,7 @@ CONFIGURE_ARGS+=--with-pgsqlincdir=${LOCALBASE}/include \
.if ${OSVERSION} < 500035
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-kexi-main-keximainwindowimpl.cpp
-CONFIGURE_ARGS+= --disable-final
+CONFIGURE_ARGS+=--disable-final
.endif
post-configure:
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 73e3c58ea121..d27cbfd2dede 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -33,7 +33,9 @@ LIB_DEPENDS= GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick \
xslt:${PORTSDIR}/textproc/libxslt
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-USE_AUTOTOOLS= libtool:15
+BROKEN= does not build with GraphicsMagick v.1.2.3 and newer
+
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
@@ -54,7 +56,7 @@ CONFIGURE_ARGS+=--with-pgsqlincdir=${LOCALBASE}/include \
.if ${OSVERSION} < 500035
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-kexi-main-keximainwindowimpl.cpp
-CONFIGURE_ARGS+= --disable-final
+CONFIGURE_ARGS+=--disable-final
.endif
post-configure: