aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/roundcube-umich/Makefile38
-rw-r--r--mail/roundcube-umich/distinfo3
-rw-r--r--mail/roundcube-umich/files/patch-default-preview29
-rw-r--r--mail/roundcube-umich/pkg-descr7
-rw-r--r--mail/roundcube-umich/pkg-plist262
6 files changed, 340 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index a8613c5e0f01..a06741cb3d70 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -571,6 +571,7 @@
SUBDIR += roundcube-air
SUBDIR += roundcube-groupvice
SUBDIR += roundcube-mvision2
+ SUBDIR += roundcube-umich
SUBDIR += rss2email
SUBDIR += ruby-rfilter
SUBDIR += ruby-rmail
diff --git a/mail/roundcube-umich/Makefile b/mail/roundcube-umich/Makefile
new file mode 100644
index 000000000000..233c9b5398bf
--- /dev/null
+++ b/mail/roundcube-umich/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: umich
+# Date created: Thu 13 Aug 2009
+# Whom: Alexey V. Degtyarev
+#
+# $FreeBSD$
+#
+
+PORTNAME= umich
+PORTVERSION= 20090813
+CATEGORIES= mail
+MASTER_SITES= ftp://renatasystems.org/pub/FreeBSD/ports/distfiles/
+PKGNAMEPREFIX= roundcube-
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Theme for RoundCube Web Mail
+
+RUN_DEPENDS= roundcube>=0.2:${PORTSDIR}/mail/roundcube
+
+NO_BUILD= yes
+
+WWWDIR?= ${PREFIX}/www/roundcube/skins/umich
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist: build
+ cd ${WRKSRC}; \
+ ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
+ ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
+ -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
+post-patch:
+ ${FIND} ${WRKSRC} -type f -name '*.orig' -delete
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ cd ${WRKSRC} && ${PAX} -r -w . ${WWWDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-umich/distinfo b/mail/roundcube-umich/distinfo
new file mode 100644
index 000000000000..efbf610eba09
--- /dev/null
+++ b/mail/roundcube-umich/distinfo
@@ -0,0 +1,3 @@
+MD5 (umich-20090813.tar.gz) = 0dca054840faf9ca02293630e135bf8b
+SHA256 (umich-20090813.tar.gz) = a47bb08c7b7448c0b92edcef2e7c5059a37deff6ad90e8e6431b56d112773764
+SIZE (umich-20090813.tar.gz) = 202930
diff --git a/mail/roundcube-umich/files/patch-default-preview b/mail/roundcube-umich/files/patch-default-preview
new file mode 100644
index 000000000000..31e77bd9a091
--- /dev/null
+++ b/mail/roundcube-umich/files/patch-default-preview
@@ -0,0 +1,29 @@
+--- watermark.html.orig 2009-08-25 11:17:44.000000000 +0400
++++ watermark.html 2009-08-25 11:17:48.000000000 +0400
+@@ -1,11 +1,12 @@
+ <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
+ <html xmlns="http://www.w3.org/1999/xhtml">
+ <head>
++ <title></title>
+ </head>
+-<body style="background-color:#ffffff;">
+-
+-<div style="margin:10px auto; text-align:center">
++<body style="background-color:#F2F2F2; width: expression((parseInt(document.documentElement.clientWidth)-20)+'px');">
+
++<div style="margin:20px auto; text-align:center">
++<img src="/skins/default/images/watermark.gif" width="260" height="228" alt="" />
+ </div>
+
+ </body>
+--- templates/mail.html.orig 2008-11-13 21:54:14.000000000 +0300
++++ templates/mail.html 2009-08-25 11:20:52.000000000 +0400
+@@ -122,7 +122,7 @@
+ rcmail.add_onload('mailviewsplit.init()');
+ </script>
+ <div id="mailpreviewframe">
+-<roundcube:object name="messagecontentframe" id="messagecontframe" width="100%" height="100%" frameborder="0" src="/templates/mailhints.html" />
++<roundcube:object name="messagecontentframe" id="messagecontframe" width="100%" height="100%" frameborder="0" src="/watermark.html" />
+ </div>
+
+ <style type="text/css">
diff --git a/mail/roundcube-umich/pkg-descr b/mail/roundcube-umich/pkg-descr
new file mode 100644
index 000000000000..a71dd534e265
--- /dev/null
+++ b/mail/roundcube-umich/pkg-descr
@@ -0,0 +1,7 @@
+While deploying RoundCube at the University of Michigan was developed a new
+skin. It is a modern, open interface with tools and actions arranged with
+optimal usability in mind. Light color blocks and borders delineate application
+areas without drawing too much attention or drawing focus away from the
+content.
+
+WWW: http://www.roundcubeforum.net
diff --git a/mail/roundcube-umich/pkg-plist b/mail/roundcube-umich/pkg-plist
new file mode 100644
index 000000000000..a4028bc6d60e
--- /dev/null
+++ b/mail/roundcube-umich/pkg-plist
@@ -0,0 +1,262 @@
+%%WWWDIR%%/COPYING
+%%WWWDIR%%/abookdefault.html
+%%WWWDIR%%/addresses.css
+%%WWWDIR%%/colorpicker.css
+%%WWWDIR%%/common.css
+%%WWWDIR%%/editor_content.css
+%%WWWDIR%%/formhint.js
+%%WWWDIR%%/googiespell.css
+%%WWWDIR%%/images/add_folder.gif
+%%WWWDIR%%/images/adr_resizer.gif
+%%WWWDIR%%/images/blank.gif
+%%WWWDIR%%/images/blank_btn.gif
+%%WWWDIR%%/images/buttons/add_act.png
+%%WWWDIR%%/images/buttons/add_contact_act.png
+%%WWWDIR%%/images/buttons/add_contact_pas.png
+%%WWWDIR%%/images/buttons/add_contact_sel.png
+%%WWWDIR%%/images/buttons/add_pas.png
+%%WWWDIR%%/images/buttons/add_sel.png
+%%WWWDIR%%/images/buttons/addressbook.gif
+%%WWWDIR%%/images/buttons/addressbook.png
+%%WWWDIR%%/images/buttons/attach_act.gif
+%%WWWDIR%%/images/buttons/attach_act.png
+%%WWWDIR%%/images/buttons/attach_btn.gif
+%%WWWDIR%%/images/buttons/attach_pas.gif
+%%WWWDIR%%/images/buttons/attach_pas.png
+%%WWWDIR%%/images/buttons/attach_sel.gif
+%%WWWDIR%%/images/buttons/attach_sel.png
+%%WWWDIR%%/images/buttons/back_act.gif
+%%WWWDIR%%/images/buttons/back_act.png
+%%WWWDIR%%/images/buttons/back_pas.gif
+%%WWWDIR%%/images/buttons/back_pas.png
+%%WWWDIR%%/images/buttons/back_sel.gif
+%%WWWDIR%%/images/buttons/back_sel.png
+%%WWWDIR%%/images/buttons/bg.gif
+%%WWWDIR%%/images/buttons/btn_bg.gif
+%%WWWDIR%%/images/buttons/checkMail_btn-off.gif
+%%WWWDIR%%/images/buttons/checkMail_btn-on.gif
+%%WWWDIR%%/images/buttons/checkMail_btn.gif
+%%WWWDIR%%/images/buttons/compose_act.gif
+%%WWWDIR%%/images/buttons/compose_act.png
+%%WWWDIR%%/images/buttons/compose_bg.gif
+%%WWWDIR%%/images/buttons/compose_pas.gif
+%%WWWDIR%%/images/buttons/compose_pas.png
+%%WWWDIR%%/images/buttons/compose_sel.gif
+%%WWWDIR%%/images/buttons/compose_sel.png
+%%WWWDIR%%/images/buttons/contact_act.gif
+%%WWWDIR%%/images/buttons/contact_btn.gif
+%%WWWDIR%%/images/buttons/contact_dis.gif
+%%WWWDIR%%/images/buttons/contact_pas.gif
+%%WWWDIR%%/images/buttons/contact_sel.gif
+%%WWWDIR%%/images/buttons/contacts_act.png
+%%WWWDIR%%/images/buttons/contacts_pas.png
+%%WWWDIR%%/images/buttons/contacts_sel.png
+%%WWWDIR%%/images/buttons/delete_act.gif
+%%WWWDIR%%/images/buttons/delete_act.png
+%%WWWDIR%%/images/buttons/delete_btn.gif
+%%WWWDIR%%/images/buttons/delete_pas.gif
+%%WWWDIR%%/images/buttons/delete_pas.png
+%%WWWDIR%%/images/buttons/delete_sel.gif
+%%WWWDIR%%/images/buttons/delete_sel.png
+%%WWWDIR%%/images/buttons/down_arrow.png
+%%WWWDIR%%/images/buttons/download_act.png
+%%WWWDIR%%/images/buttons/download_pas.png
+%%WWWDIR%%/images/buttons/download_sel.png
+%%WWWDIR%%/images/buttons/drafts_act.png
+%%WWWDIR%%/images/buttons/drafts_pas.png
+%%WWWDIR%%/images/buttons/drafts_sel.png
+%%WWWDIR%%/images/buttons/edit_contact_act.png
+%%WWWDIR%%/images/buttons/edit_contact_pas.png
+%%WWWDIR%%/images/buttons/edit_contact_sel.png
+%%WWWDIR%%/images/buttons/export_btn.gif
+%%WWWDIR%%/images/buttons/first_act.png
+%%WWWDIR%%/images/buttons/first_pas.png
+%%WWWDIR%%/images/buttons/first_sel.png
+%%WWWDIR%%/images/buttons/forward_act.png
+%%WWWDIR%%/images/buttons/forward_pas.png
+%%WWWDIR%%/images/buttons/forward_sel.png
+%%WWWDIR%%/images/buttons/fwd_act.gif
+%%WWWDIR%%/images/buttons/fwd_pas.gif
+%%WWWDIR%%/images/buttons/fwd_sel.gif
+%%WWWDIR%%/images/buttons/inbox_act.png
+%%WWWDIR%%/images/buttons/inbox_pas.png
+%%WWWDIR%%/images/buttons/inbox_sel.png
+%%WWWDIR%%/images/buttons/junk_act.gif
+%%WWWDIR%%/images/buttons/junk_btn.gif
+%%WWWDIR%%/images/buttons/junk_pas.gif
+%%WWWDIR%%/images/buttons/junk_sel.gif
+%%WWWDIR%%/images/buttons/last_act.png
+%%WWWDIR%%/images/buttons/last_pas.png
+%%WWWDIR%%/images/buttons/last_sel.png
+%%WWWDIR%%/images/buttons/ldap_act.png
+%%WWWDIR%%/images/buttons/ldap_pas.png
+%%WWWDIR%%/images/buttons/logout.gif
+%%WWWDIR%%/images/buttons/logout.png
+%%WWWDIR%%/images/buttons/mail.gif
+%%WWWDIR%%/images/buttons/mail.png
+%%WWWDIR%%/images/buttons/markread_act.png
+%%WWWDIR%%/images/buttons/next_act.png
+%%WWWDIR%%/images/buttons/next_pas.png
+%%WWWDIR%%/images/buttons/next_sel.png
+%%WWWDIR%%/images/buttons/not_junk_act.gif
+%%WWWDIR%%/images/buttons/not_junk_pas.gif
+%%WWWDIR%%/images/buttons/not_junk_sel.gif
+%%WWWDIR%%/images/buttons/previous_act.png
+%%WWWDIR%%/images/buttons/previous_pas.png
+%%WWWDIR%%/images/buttons/previous_sel.png
+%%WWWDIR%%/images/buttons/print_act.gif
+%%WWWDIR%%/images/buttons/print_act.png
+%%WWWDIR%%/images/buttons/print_btn.gif
+%%WWWDIR%%/images/buttons/print_pas.gif
+%%WWWDIR%%/images/buttons/print_pas.png
+%%WWWDIR%%/images/buttons/print_sel.gif
+%%WWWDIR%%/images/buttons/print_sel.png
+%%WWWDIR%%/images/buttons/reply_act.gif
+%%WWWDIR%%/images/buttons/reply_act.png
+%%WWWDIR%%/images/buttons/reply_pas.gif
+%%WWWDIR%%/images/buttons/reply_pas.png
+%%WWWDIR%%/images/buttons/reply_sel.gif
+%%WWWDIR%%/images/buttons/reply_sel.png
+%%WWWDIR%%/images/buttons/replyall_act.gif
+%%WWWDIR%%/images/buttons/replyall_act.png
+%%WWWDIR%%/images/buttons/replyall_pas.gif
+%%WWWDIR%%/images/buttons/replyall_pas.png
+%%WWWDIR%%/images/buttons/replyall_sel.gif
+%%WWWDIR%%/images/buttons/replyall_sel.png
+%%WWWDIR%%/images/buttons/save_act.gif
+%%WWWDIR%%/images/buttons/save_btn.gif
+%%WWWDIR%%/images/buttons/save_pas.gif
+%%WWWDIR%%/images/buttons/save_sel.gif
+%%WWWDIR%%/images/buttons/send_act.gif
+%%WWWDIR%%/images/buttons/send_act.png
+%%WWWDIR%%/images/buttons/send_pas.gif
+%%WWWDIR%%/images/buttons/send_pas.png
+%%WWWDIR%%/images/buttons/send_sel.gif
+%%WWWDIR%%/images/buttons/send_sel.png
+%%WWWDIR%%/images/buttons/settings.gif
+%%WWWDIR%%/images/buttons/settings.png
+%%WWWDIR%%/images/buttons/source_act.png
+%%WWWDIR%%/images/buttons/source_pas.png
+%%WWWDIR%%/images/buttons/source_sel.png
+%%WWWDIR%%/images/buttons/spacer.gif
+%%WWWDIR%%/images/buttons/spell_act.gif
+%%WWWDIR%%/images/buttons/spell_pas.gif
+%%WWWDIR%%/images/buttons/spell_sel.gif
+%%WWWDIR%%/images/buttons/spellcheck_act.png
+%%WWWDIR%%/images/buttons/spellcheck_pas.png
+%%WWWDIR%%/images/buttons/spellcheck_sel.png
+%%WWWDIR%%/images/buttons/up_arrow.png
+%%WWWDIR%%/images/checkMailTop.gif
+%%WWWDIR%%/images/cleardot.png
+%%WWWDIR%%/images/corner-ll.gif
+%%WWWDIR%%/images/corner-logo.gif
+%%WWWDIR%%/images/corner-lr.gif
+%%WWWDIR%%/images/dimple.png
+%%WWWDIR%%/images/display/confirm.png
+%%WWWDIR%%/images/display/info.png
+%%WWWDIR%%/images/display/loading.gif
+%%WWWDIR%%/images/display/warning.png
+%%WWWDIR%%/images/expunge_folder.gif
+%%WWWDIR%%/images/favicon.ico
+%%WWWDIR%%/images/googiespell/change_lang.gif
+%%WWWDIR%%/images/googiespell/indicator.gif
+%%WWWDIR%%/images/googiespell/ok.gif
+%%WWWDIR%%/images/googiespell/spellc.gif
+%%WWWDIR%%/images/grayPixel.gif
+%%WWWDIR%%/images/header-bg.gif
+%%WWWDIR%%/images/icons/abcard.png
+%%WWWDIR%%/images/icons/add-icon.gif
+%%WWWDIR%%/images/icons/attachment.png
+%%WWWDIR%%/images/icons/collapsed.png
+%%WWWDIR%%/images/icons/deleted.png
+%%WWWDIR%%/images/icons/dot.png
+%%WWWDIR%%/images/icons/down_small.gif
+%%WWWDIR%%/images/icons/expanded.png
+%%WWWDIR%%/images/icons/extwin.png
+%%WWWDIR%%/images/icons/flagged.png
+%%WWWDIR%%/images/icons/folder-closed.png
+%%WWWDIR%%/images/icons/folder-drafts.png
+%%WWWDIR%%/images/icons/folder-inbox.png
+%%WWWDIR%%/images/icons/folder-junk.gif
+%%WWWDIR%%/images/icons/folder-junk.png
+%%WWWDIR%%/images/icons/folder-open.png
+%%WWWDIR%%/images/icons/folder-sent.png
+%%WWWDIR%%/images/icons/folder-trash.png
+%%WWWDIR%%/images/icons/forwarded.png
+%%WWWDIR%%/images/icons/plus.gif
+%%WWWDIR%%/images/icons/remove-attachment.png
+%%WWWDIR%%/images/icons/rename.png
+%%WWWDIR%%/images/icons/replied.png
+%%WWWDIR%%/images/icons/reset.gif
+%%WWWDIR%%/images/icons/silhouette.png
+%%WWWDIR%%/images/icons/unflagged.png
+%%WWWDIR%%/images/icons/unread.png
+%%WWWDIR%%/images/icons/up_small.gif
+%%WWWDIR%%/images/listheader_aqua.gif
+%%WWWDIR%%/images/listheader_dark.gif
+%%WWWDIR%%/images/listheader_light.gif
+%%WWWDIR%%/images/logo.gif
+%%WWWDIR%%/images/logo2.gif
+%%WWWDIR%%/images/logo3.gif
+%%WWWDIR%%/images/mailbox_list.gif
+%%WWWDIR%%/images/mailbox_selected.gif
+%%WWWDIR%%/images/maize_webmail_logo.jpg
+%%WWWDIR%%/images/manage_folder.gif
+%%WWWDIR%%/images/menu_arrow.gif
+%%WWWDIR%%/images/resizer.gif
+%%WWWDIR%%/images/roundcube_logo.gif
+%%WWWDIR%%/images/roundcube_logo.png
+%%WWWDIR%%/images/roundcube_logo_print.gif
+%%WWWDIR%%/images/sch_bg.gif
+%%WWWDIR%%/images/searchfield.gif
+%%WWWDIR%%/images/sort_asc.gif
+%%WWWDIR%%/images/sort_desc.gif
+%%WWWDIR%%/images/tab_act.gif
+%%WWWDIR%%/images/tab_pas.gif
+%%WWWDIR%%/images/taskbar.gif
+%%WWWDIR%%/images/toolbarTopL.gif
+%%WWWDIR%%/images/toolbarTopR.gif
+%%WWWDIR%%/images/toolbarTop_bg.gif
+%%WWWDIR%%/images/um-searchfield.gif
+%%WWWDIR%%/images/webmail_logo.jpg
+%%WWWDIR%%/includes/header.html
+%%WWWDIR%%/includes/header_popup.html
+%%WWWDIR%%/includes/ldapscripts.html
+%%WWWDIR%%/includes/links.html
+%%WWWDIR%%/includes/settingscripts.html
+%%WWWDIR%%/includes/settingstabs.html
+%%WWWDIR%%/includes/taskbar.html
+%%WWWDIR%%/mail.css
+%%WWWDIR%%/pngbehavior.htc
+%%WWWDIR%%/popup.css
+%%WWWDIR%%/print.css
+%%WWWDIR%%/settings.css
+%%WWWDIR%%/splitter.js
+%%WWWDIR%%/templates/addcontact.html
+%%WWWDIR%%/templates/addidentity.html
+%%WWWDIR%%/templates/addressbook.html
+%%WWWDIR%%/templates/compose.html
+%%WWWDIR%%/templates/compose_popup.html
+%%WWWDIR%%/templates/editcontact.html
+%%WWWDIR%%/templates/editidentity.html
+%%WWWDIR%%/templates/error.html
+%%WWWDIR%%/templates/identities.html
+%%WWWDIR%%/templates/login.html
+%%WWWDIR%%/templates/mail.html
+%%WWWDIR%%/templates/mailhints.html
+%%WWWDIR%%/templates/managefolders.html
+%%WWWDIR%%/templates/message.html
+%%WWWDIR%%/templates/messagepart.html
+%%WWWDIR%%/templates/messagepreview.html
+%%WWWDIR%%/templates/printmessage.html
+%%WWWDIR%%/templates/settings.html
+%%WWWDIR%%/templates/showcontact.html
+%%WWWDIR%%/watermark.html
+@dirrm %%WWWDIR%%/templates
+@dirrm %%WWWDIR%%/includes
+@dirrm %%WWWDIR%%/images/icons
+@dirrm %%WWWDIR%%/images/googiespell
+@dirrm %%WWWDIR%%/images/display
+@dirrm %%WWWDIR%%/images/buttons
+@dirrm %%WWWDIR%%/images
+@dirrmtry %%WWWDIR%%