aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/togl/Makefile2
-rw-r--r--graphics/togl/pkg-plist13
2 files changed, 8 insertions, 7 deletions
diff --git a/graphics/togl/Makefile b/graphics/togl/Makefile
index b77e4d2769f8..7851a6234e73 100644
--- a/graphics/togl/Makefile
+++ b/graphics/togl/Makefile
@@ -32,6 +32,8 @@ PLIST_SUB= TOGL_INSTDIR="${TOGL_INSTDIR:S,^${PREFIX}/,,}"
CPPFLAGS+= -I${TK_INCLUDEDIR}
LDFLAGS+= -L${TK_LIBDIR}
+PLIST_SUB+= TK_VER=${TK_VER}
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/graphics/togl/pkg-plist b/graphics/togl/pkg-plist
index 0138d1f000f3..986d7f9aa838 100644
--- a/graphics/togl/pkg-plist
+++ b/graphics/togl/pkg-plist
@@ -1,10 +1,10 @@
lib/libtogl.so
lib/libtogl.so.1
-lib/tk8.5/Togl-1.7/togl.h
-lib/tk8.5/Togl-1.7/togl_ws.h
-lib/tk8.5/Togl-1.7/libTogl1.7.so
-lib/tk8.5/Togl-1.7/pkgIndex.tcl
-lib/tk8.5/Togl-1.7/libtogl.so.1
+lib/tk%%TK_VER%%/Togl-1.7/togl.h
+lib/tk%%TK_VER%%/Togl-1.7/togl_ws.h
+lib/tk%%TK_VER%%/Togl-1.7/libTogl1.7.so
+lib/tk%%TK_VER%%/Togl-1.7/pkgIndex.tcl
+lib/tk%%TK_VER%%/Togl-1.7/libtogl.so.1
%%PORTDOCS%%%%DOCSDIR%%/Togl.html
%%EXAMPLESDIR%%/Makefile
%%EXAMPLESDIR%%/ben.rgb
@@ -27,5 +27,4 @@ lib/tk8.5/Togl-1.7/libtogl.so.1
%%EXAMPLESDIR%%/tree2.rgba
@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm lib/tk8.5/Togl-1.7
-@dirrmtry lib/tk8.5
+@dirrm lib/tk%%TK_VER%%/Togl-1.7