aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/glabels/Makefile8
-rw-r--r--deskutils/glabels/distinfo4
-rw-r--r--deskutils/glabels/files/patch-configure10
-rw-r--r--deskutils/glabels/files/patch-data_mime_Makefile.in25
-rw-r--r--deskutils/glabels/pkg-plist23
5 files changed, 47 insertions, 23 deletions
diff --git a/deskutils/glabels/Makefile b/deskutils/glabels/Makefile
index 7238dff88624..4f33d4816511 100644
--- a/deskutils/glabels/Makefile
+++ b/deskutils/glabels/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= glabels
-PORTVERSION= 1.93.3
-PORTREVISION= 1
+PORTVERSION= 2.0.0
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,8 +17,11 @@ COMMENT= A program to create labels and business cards
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui libgnomeprintui
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAN1= glabels.1
+
.include <bsd.port.mk>
diff --git a/deskutils/glabels/distinfo b/deskutils/glabels/distinfo
index 5dfe4f6c44bb..d3df748d71e6 100644
--- a/deskutils/glabels/distinfo
+++ b/deskutils/glabels/distinfo
@@ -1,2 +1,2 @@
-MD5 (glabels-1.93.3.tar.gz) = 29abf3f91ea9e8aec194744302175c02
-SIZE (glabels-1.93.3.tar.gz) = 1394894
+MD5 (glabels-2.0.0.tar.gz) = 77a421ee35b64f01a0fbf5ada5944add
+SIZE (glabels-2.0.0.tar.gz) = 1408734
diff --git a/deskutils/glabels/files/patch-configure b/deskutils/glabels/files/patch-configure
deleted file mode 100644
index 890bcb65910f..000000000000
--- a/deskutils/glabels/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sun Jan 4 13:27:53 2004
-+++ configure Mon Jan 5 00:47:16 2004
-@@ -7674,6 +7674,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/deskutils/glabels/files/patch-data_mime_Makefile.in b/deskutils/glabels/files/patch-data_mime_Makefile.in
new file mode 100644
index 000000000000..3182724727cf
--- /dev/null
+++ b/deskutils/glabels/files/patch-data_mime_Makefile.in
@@ -0,0 +1,25 @@
+--- data/mime/Makefile.in.orig Tue Aug 10 20:59:17 2004
++++ data/mime/Makefile.in Tue Aug 10 21:10:15 2004
+@@ -151,7 +151,7 @@
+ appdir = $(datadir)/application-registry
+ app_DATA = glabels.applications
+
+-newmimedir = $(datadir)/mime/packages
++newmimedir = $(prefix)/share/mime/packages
+ newmime_DATA = $(xml_files)
+
+ EXTRA_DIST = \
+@@ -331,11 +331,11 @@
+ @INTLTOOL_XML_RULE@
+
+ install-data-hook:
+-@HAVE_NEW_MIME_TRUE@ $(UPDATE_MIME_DATABASE) "$(DESTDIR)$(datadir)/mime"
++@HAVE_NEW_MIME_TRUE@ $(UPDATE_MIME_DATABASE) "$(DESTDIR)$(prefix)/share/mime"
+ @HAVE_NEWER_MIME_TRUE@ $(UPDATE_DESKTOP_DATABASE)
+
+ uninstall-hook:
+-@HAVE_NEW_MIME_TRUE@ $(UPDATE_MIME_DATABASE) "$(DESTDIR)$(datadir)/mime"
++@HAVE_NEW_MIME_TRUE@ $(UPDATE_MIME_DATABASE) "$(DESTDIR)$(prefix)/share/mime"
+ @HAVE_NEWER_MIME_TRUE@ $(UPDATE_DESKTOP_DATABASE)
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/deskutils/glabels/pkg-plist b/deskutils/glabels/pkg-plist
index c4094dccc508..2d3dd325d11b 100644
--- a/deskutils/glabels/pkg-plist
+++ b/deskutils/glabels/pkg-plist
@@ -8,20 +8,22 @@ include/libglabels/xml-template.h
include/libglabels/xml.h
lib/libglabels.a
lib/libglabels.so
-lib/libglabels.so.0
+lib/libglabels.so.1
share/gnome/application-registry/glabels.applications
share/gnome/applications/glabels.desktop
-share/gnome/glabels/avery-iso-templates.xml
-share/gnome/glabels/avery-us-templates.xml
-share/gnome/glabels/glabels-2.0.dtd
+share/gnome/glabels/dtd/glabels-2.0.dtd
share/gnome/glabels/glade/object-editor.glade
share/gnome/glabels/glade/prefs-dialog.glade
share/gnome/glabels/glade/template-designer.glade
-share/gnome/glabels/misc-iso-templates.xml
-share/gnome/glabels/misc-us-templates.xml
-share/gnome/glabels/paper-sizes.xml
+share/gnome/glabels/templates/avery-iso-templates.xml
+share/gnome/glabels/templates/avery-other-templates.xml
+share/gnome/glabels/templates/avery-us-templates.xml
+share/gnome/glabels/templates/misc-iso-templates.xml
+share/gnome/glabels/templates/misc-other-templates.xml
+share/gnome/glabels/templates/misc-us-templates.xml
+share/gnome/glabels/templates/paper-sizes.xml
+share/gnome/glabels/templates/zweckform-iso-templates.xml
share/gnome/glabels/ui/glabels-ui.xml
-share/gnome/glabels/zweckform-iso-templates.xml
share/gnome/help/glabels/C/figures/glabels-template-cd.png
share/gnome/help/glabels/C/figures/glabels-template-label.png
share/gnome/help/glabels/C/figures/glabels-template-layout.png
@@ -54,13 +56,18 @@ share/locale/pl/LC_MESSAGES/glabels.mo
share/locale/pt_BR/LC_MESSAGES/glabels.mo
share/locale/ru/LC_MESSAGES/glabels.mo
share/locale/zh_TW.Big5/LC_MESSAGES/glabels.mo
+share/mime/packages/glabels.xml
@dirrm share/gnome/pixmaps/glabels
@dirrm share/gnome/omf/glabels
@dirrm share/gnome/help/glabels/C/figures
@dirrm share/gnome/help/glabels/C
@dirrm share/gnome/help/glabels
@dirrm share/gnome/glabels/ui
+@dirrm share/gnome/glabels/templates
@dirrm share/gnome/glabels/glade
+@dirrm share/gnome/glabels/dtd
@dirrm share/gnome/glabels
@dirrm include/libglabels
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/glabels/glabels-C.omf 2>/dev/null || true
+@exec update-mime-database %D/share/mime
+@unexec update-mime-database %D/share/mime