aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/vanubi/Makefile2
-rw-r--r--editors/vanubi/files/patch-gui_main.vala17
-rw-r--r--editors/vanubi/files/patch-gui_searchbar.vala23
-rw-r--r--editors/vanubi/files/patch-gui_shellbar.vala40
-rw-r--r--editors/vanubi/files/patch-libvanubi_completion.vala16
-rw-r--r--editors/vanubi/files/patch-libvanubi_git.vala17
-rw-r--r--editors/vanubi/files/patch-libvanubi_util.vala37
-rw-r--r--x11-toolkits/vte3/Makefile17
-rw-r--r--x11-toolkits/vte3/distinfo5
-rw-r--r--x11-toolkits/vte3/pkg-plist10
-rw-r--r--x11/altyo/Makefile1
-rw-r--r--x11/altyo/files/patch-altyo__terminal.vala69
12 files changed, 240 insertions, 14 deletions
diff --git a/editors/vanubi/Makefile b/editors/vanubi/Makefile
index 69a7bfe5f6a7..f294695bc4a7 100644
--- a/editors/vanubi/Makefile
+++ b/editors/vanubi/Makefile
@@ -4,7 +4,7 @@
PORTNAME= vanubi
PORTVERSION= 0.0.16
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MAINTAINER= ports@FreeBSD.org
diff --git a/editors/vanubi/files/patch-gui_main.vala b/editors/vanubi/files/patch-gui_main.vala
new file mode 100644
index 000000000000..4a30529a9d30
--- /dev/null
+++ b/editors/vanubi/files/patch-gui_main.vala
@@ -0,0 +1,17 @@
+--- gui/main.vala.orig 2015-07-03 10:10:29 UTC
++++ gui/main.vala
+@@ -35,12 +35,12 @@ namespace Vanubi.UI {
+ { null }
+ };
+
+- static Regex file_pos_regex = null;
++ static GLib.Regex file_pos_regex = null;
+
+ static construct {
+ try {
+ var file_pos = """^(?<f>.+?)(?::(?<sl>\d+)(?::(?<sc>\d+))?)?$""";
+- file_pos_regex = new Regex (file_pos, RegexCompileFlags.CASELESS|RegexCompileFlags.OPTIMIZE);
++ file_pos_regex = new GLib.Regex (file_pos, GLib.RegexCompileFlags.CASELESS|GLib.RegexCompileFlags.OPTIMIZE);
+ } catch (Error e) {
+ error (e.message);
+ }
diff --git a/editors/vanubi/files/patch-gui_searchbar.vala b/editors/vanubi/files/patch-gui_searchbar.vala
new file mode 100644
index 000000000000..eea06698a8c3
--- /dev/null
+++ b/editors/vanubi/files/patch-gui_searchbar.vala
@@ -0,0 +1,23 @@
+--- gui/searchbar.vala.orig 2015-07-03 10:10:29 UTC
++++ gui/searchbar.vala
+@@ -153,11 +153,11 @@ namespace Vanubi.UI {
+ // do not parse in case of any error during parsing or evaluating the expression
+ }
+
+- Regex regex = null;
++ GLib.Regex regex = null;
+ if (is_regex) {
+ try {
+ state.status.clear ("search");
+- regex = new Regex (p, RegexCompileFlags.OPTIMIZE, RegexMatchFlags.ANCHORED);
++ regex = new GLib.Regex (p, GLib.RegexCompileFlags.OPTIMIZE, GLib.RegexMatchFlags.ANCHORED);
+ } catch (Error e) {
+ // user still writing regex, display an error
+ state.status.set (e.message, "search", Status.Type.ERROR);
+@@ -381,4 +381,4 @@ namespace Vanubi.UI {
+ return base.on_key_press_event (e);
+ }
+ }
+-}
+\ No newline at end of file
++}
diff --git a/editors/vanubi/files/patch-gui_shellbar.vala b/editors/vanubi/files/patch-gui_shellbar.vala
index 6d6bde6f454e..001923fcd5a2 100644
--- a/editors/vanubi/files/patch-gui_shellbar.vala
+++ b/editors/vanubi/files/patch-gui_shellbar.vala
@@ -1,7 +1,32 @@
Add support of vte-2.91 instead of vte-2.90
---- gui/shellbar.vala.orig 2014-12-09 10:52:31 UTC
+--- gui/shellbar.vala.orig 2015-07-03 10:10:29 UTC
+++ gui/shellbar.vala
+@@ -29,8 +29,8 @@ namespace Vanubi.UI {
+ Cancellable pty_cancellable;
+ bool is_first_line = true;
+
+- static Regex error_regex = null;
+- static Regex dir_regex = null;
++ static GLib.Regex error_regex = null;
++ static GLib.Regex dir_regex = null;
+
+ static construct {
+ try {
+@@ -44,11 +44,11 @@ namespace Vanubi.UI {
+ var php_error = """^(?<msg>.+)error:.* in (?<f>.+) on line (?<sl>\d+)\s*$""";
+ // sh style
+ var sh_error = """^(?<f>.+?):.*?(?<sl>\d+?):.*?:(?<msg>.*? error):""";
+- error_regex = new Regex (@"(?:$(vala_error))|(?:$(php_error))|(?:$(c_error))|(?:$(sh_error))|(?:$(java_error))", RegexCompileFlags.CASELESS|RegexCompileFlags.OPTIMIZE|RegexCompileFlags.DUPNAMES);
++ error_regex = new GLib.Regex (@"(?:$(vala_error))|(?:$(php_error))|(?:$(c_error))|(?:$(sh_error))|(?:$(java_error))", GLib.RegexCompileFlags.CASELESS|GLib.RegexCompileFlags.OPTIMIZE|GLib.RegexCompileFlags.DUPNAMES);
+
+ // enter directory
+ var make_dir = """^.*Entering directory `(.+?)'.*$""";
+- dir_regex = new Regex (@"(?:$(make_dir))", RegexCompileFlags.CASELESS|RegexCompileFlags.OPTIMIZE|RegexCompileFlags.DUPNAMES);
++ dir_regex = new GLib.Regex (@"(?:$(make_dir))", GLib.RegexCompileFlags.CASELESS|GLib.RegexCompileFlags.OPTIMIZE|GLib.RegexCompileFlags.DUPNAMES);
+ } catch (Error e) {
+ error (e.message);
+ }
@@ -146,10 +146,10 @@ namespace Vanubi.UI {
}
@@ -15,3 +40,16 @@ Add support of vte-2.91 instead of vte-2.90
mouse_match (term, """^.+error:""");
mouse_match (term, """^.+warning:""");
+@@ -255,10 +255,10 @@ namespace Vanubi.UI {
+
+ private void mouse_match (Terminal t, string str) {
+ try {
+- var regex = new Regex (str);
++ var regex = new GLib.Regex (str);
+ int id = t.match_add_gregex (regex, 0);
+ t.match_set_cursor_type (id, Gdk.CursorType.HAND2);
+- } catch (RegexError e) {
++ } catch (GLib.RegexError e) {
+ warning (e.message);
+ }
+ }
diff --git a/editors/vanubi/files/patch-libvanubi_completion.vala b/editors/vanubi/files/patch-libvanubi_completion.vala
new file mode 100644
index 000000000000..c7cdb33c13ad
--- /dev/null
+++ b/editors/vanubi/files/patch-libvanubi_completion.vala
@@ -0,0 +1,16 @@
+--- libvanubi/completion.vala.orig 2015-07-03 10:10:29 UTC
++++ libvanubi/completion.vala
+@@ -21,11 +21,11 @@ namespace Vanubi {
+ public class AbbrevCompletion {
+ LRU<string> lru = new LRU<string> (strcmp);
+ Annotated<string>[] tags = null;
+- Regex regex;
++ GLib.Regex regex;
+
+ public AbbrevCompletion () {
+ try {
+- regex = new Regex ("\\w+", RegexCompileFlags.MULTILINE | RegexCompileFlags.OPTIMIZE);
++ regex = new GLib.Regex ("\\w+", GLib.RegexCompileFlags.MULTILINE | GLib.RegexCompileFlags.OPTIMIZE);
+ } catch (Error e) {
+ warning (e.message);
+ }
diff --git a/editors/vanubi/files/patch-libvanubi_git.vala b/editors/vanubi/files/patch-libvanubi_git.vala
new file mode 100644
index 000000000000..44d6bfe27ebd
--- /dev/null
+++ b/editors/vanubi/files/patch-libvanubi_git.vala
@@ -0,0 +1,17 @@
+--- libvanubi/git.vala.orig 2015-07-03 10:10:29 UTC
++++ libvanubi/git.vala
+@@ -27,12 +27,12 @@ namespace Vanubi {
+
+ public class Git {
+ unowned Configuration config;
+- static Regex hunk_regex;
++ static GLib.Regex hunk_regex;
+ static HashTable<DataSource, bool> monitored = new HashTable<DataSource, bool> (DataSource.hash, DataSource.equal);
+
+ static construct {
+ try {
+- hunk_regex = new Regex ("^@@ -(\\d+),?(\\d*) \\+(\\d+),?(\\d*) @@");
++ hunk_regex = new GLib.Regex ("^@@ -(\\d+),?(\\d*) \\+(\\d+),?(\\d*) @@");
+ } catch (Error e) {
+ warning (e.message);
+ }
diff --git a/editors/vanubi/files/patch-libvanubi_util.vala b/editors/vanubi/files/patch-libvanubi_util.vala
new file mode 100644
index 000000000000..dadd462746b3
--- /dev/null
+++ b/editors/vanubi/files/patch-libvanubi_util.vala
@@ -0,0 +1,37 @@
+--- libvanubi/util.vala.orig 2015-07-03 10:10:29 UTC
++++ libvanubi/util.vala
+@@ -35,12 +35,12 @@ namespace Vanubi {
+ public int end_line;
+ public int end_column;
+
+- static Regex file_pos_regex = null;
++ static GLib.Regex file_pos_regex = null;
+
+ static construct {
+ try {
+ var file_pos = """^(?<f>.+?)(?::(?<sl>\d+)(?::(?<sc>\d+))?)?$""";
+- file_pos_regex = new Regex (file_pos, RegexCompileFlags.CASELESS|RegexCompileFlags.OPTIMIZE);
++ file_pos_regex = new GLib.Regex (file_pos, GLib.RegexCompileFlags.CASELESS|GLib.RegexCompileFlags.OPTIMIZE);
+ } catch (Error e) {
+ error (e.message);
+ }
+@@ -181,15 +181,15 @@ namespace Vanubi {
+
+ public async extern void spawn_async_with_pipes (string? working_directory, [CCode (array_length = false, array_null_terminated = true)] string[] argv, [CCode (array_length = false, array_null_terminated = true)] string[]? envp, SpawnFlags _flags, SpawnChildSetupFunc? child_setup, int io_priority, Cancellable? cancellable, out Pid child_pid, out int standard_input = null, out int standard_output = null, out int standard_error = null) throws SpawnError;
+
+- static Regex update_copyright_year_regex1 = null;
+- static Regex update_copyright_year_regex2 = null;
++ static GLib.Regex update_copyright_year_regex1 = null;
++ static GLib.Regex update_copyright_year_regex2 = null;
+
+ // Returns true if any copyright year has been replaced
+ public bool update_copyright_year (Buffer buf) {
+ if (update_copyright_year_regex1 == null || update_copyright_year_regex2 == null) {
+ try {
+- update_copyright_year_regex1 = new Regex ("Copyright.*\\d\\d\\d\\d-(\\d\\d\\d\\d)", RegexCompileFlags.OPTIMIZE | RegexCompileFlags.CASELESS);
+- update_copyright_year_regex2 = new Regex ("Copyright.*(\\d\\d\\d\\d)", RegexCompileFlags.OPTIMIZE | RegexCompileFlags.CASELESS);
++ update_copyright_year_regex1 = new GLib.Regex ("Copyright.*\\d\\d\\d\\d-(\\d\\d\\d\\d)", GLib.RegexCompileFlags.OPTIMIZE | GLib.RegexCompileFlags.CASELESS);
++ update_copyright_year_regex2 = new GLib.Regex ("Copyright.*(\\d\\d\\d\\d)", GLib.RegexCompileFlags.OPTIMIZE | GLib.RegexCompileFlags.CASELESS);
+ } catch (Error e) {
+ warning (e.message);
+ return false;
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
index cf242aa0e4a4..a057dcb4915f 100644
--- a/x11-toolkits/vte3/Makefile
+++ b/x11-toolkits/vte3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= vte
-PORTVERSION= 0.42.4
-PORTREVISION= 2
+PORTVERSION= 0.48.1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
PKGNAMESUFFIX= 3
@@ -12,19 +11,21 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Terminal widget with improved accessibility and I18N support
+LICENSE= LGPL21
+
BUILD_DEPENDS+= vapigen:lang/vala \
- bash:shells/bash
-LIB_DEPENDS= libgnutls.so:security/gnutls
+ bash:shells/bash \
+ gperf:devel/gperf
+LIB_DEPENDS= libgnutls.so:security/gnutls \
+ libpcre2-8.so:devel/pcre2
PORTSCOUT= limitw:1,even
-USES= bison compiler:c++0x gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz
+USES= bison compiler:c++0x gettext gmake gnome libtool localbase \
+ pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME?= gtk30 intltool referencehack introspection:build
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-introspection \
--disable-static \
--disable-Bsymbolic
diff --git a/x11-toolkits/vte3/distinfo b/x11-toolkits/vte3/distinfo
index 30adc042921c..e4f85765eac5 100644
--- a/x11-toolkits/vte3/distinfo
+++ b/x11-toolkits/vte3/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome3/vte-0.42.4.tar.xz) = 08c88bf5c0aa1dfa3711e2e83b784fb5ea82025661f30b54e93eebd5f4bce113
-SIZE (gnome3/vte-0.42.4.tar.xz) = 928048
+TIMESTAMP = 1491154703
+SHA256 (gnome3/vte-0.48.1.tar.xz) = d3b7d6a13e6b850f3ea1c35af2746ef78039493ed4bb87cb7a36f29b260861f6
+SIZE (gnome3/vte-0.48.1.tar.xz) = 1006380
diff --git a/x11-toolkits/vte3/pkg-plist b/x11-toolkits/vte3/pkg-plist
index 9c9e3c9efade..b155e4e780ef 100644
--- a/x11-toolkits/vte3/pkg-plist
+++ b/x11-toolkits/vte3/pkg-plist
@@ -6,25 +6,31 @@ include/vte-%%VERSION%%/vte/vteenums.h
include/vte-%%VERSION%%/vte/vteglobals.h
include/vte-%%VERSION%%/vte/vtemacros.h
include/vte-%%VERSION%%/vte/vtepty.h
+include/vte-%%VERSION%%/vte/vteregex.h
include/vte-%%VERSION%%/vte/vteterminal.h
include/vte-%%VERSION%%/vte/vtetypebuiltins.h
include/vte-%%VERSION%%/vte/vteversion.h
lib/girepository-1.0/Vte-%%VERSION%%.typelib
lib/libvte-%%VERSION%%.so
lib/libvte-%%VERSION%%.so.0
-lib/libvte-%%VERSION%%.so.0.4200.4
+lib/libvte-%%VERSION%%.so.0.4800.1
libdata/pkgconfig/vte-%%VERSION%%.pc
share/gir-1.0/Vte-%%VERSION%%.gir
+share/gtk-doc/html/vte-%%VERSION%%/VteRegex.html
share/gtk-doc/html/vte-%%VERSION%%/VteTerminal.html
+share/gtk-doc/html/vte-%%VERSION%%/annotation-glossary.html
share/gtk-doc/html/vte-%%VERSION%%/api-index-0-40.html
+share/gtk-doc/html/vte-%%VERSION%%/api-index-0-44.html
+share/gtk-doc/html/vte-%%VERSION%%/api-index-0-46.html
+share/gtk-doc/html/vte-%%VERSION%%/api-index-0-48.html
share/gtk-doc/html/vte-%%VERSION%%/api-index-deprecated.html
share/gtk-doc/html/vte-%%VERSION%%/api-index-full.html
share/gtk-doc/html/vte-%%VERSION%%/ch01.html
share/gtk-doc/html/vte-%%VERSION%%/ch02.html
share/gtk-doc/html/vte-%%VERSION%%/ch03.html
+share/gtk-doc/html/vte-%%VERSION%%/ch04.html
share/gtk-doc/html/vte-%%VERSION%%/home.png
share/gtk-doc/html/vte-%%VERSION%%/index.html
-share/gtk-doc/html/vte-%%VERSION%%/index.sgml
share/gtk-doc/html/vte-%%VERSION%%/left-insensitive.png
share/gtk-doc/html/vte-%%VERSION%%/left.png
share/gtk-doc/html/vte-%%VERSION%%/licence.html
diff --git a/x11/altyo/Makefile b/x11/altyo/Makefile
index fbab7ea960d1..fff3cd715980 100644
--- a/x11/altyo/Makefile
+++ b/x11/altyo/Makefile
@@ -4,6 +4,7 @@
PORTNAME= altyo
DISTVERSIONPREFIX= debian/
DISTVERSION= 0.4_rc19
+PORTREVISION= 1
DISTVERSIONSUFFIX= -${GH_ACCOUNT}1
CATEGORIES= x11
diff --git a/x11/altyo/files/patch-altyo__terminal.vala b/x11/altyo/files/patch-altyo__terminal.vala
new file mode 100644
index 000000000000..9256fe316faa
--- /dev/null
+++ b/x11/altyo/files/patch-altyo__terminal.vala
@@ -0,0 +1,69 @@
+--- altyo_terminal.vala.orig 2016-04-19 20:55:59 UTC
++++ altyo_terminal.vala
+@@ -50,7 +50,7 @@ public class TildaAuth:Object{
+ //string[] commands={};
+ //commands=command.split(",");
+ this.command=command;
+- if( GLib.Regex.match_simple("^ *ssh *(,.*)?$",this.command,RegexCompileFlags.CASELESS,0) )
++ if( GLib.Regex.match_simple("^ *ssh *(,.*)?$",this.command,GLib.RegexCompileFlags.CASELESS,0) )
+ this.type="ssh";
+ else
+ this.type="unknown";
+@@ -248,26 +248,26 @@ public class VTToggleButton : Gtk.Button
+ debug(" RegexEvalCallback %s %s %d",result.str,match_info.fetch(0),match_info.get_match_count());
+ GLib.Regex grx;
+
+- if(!done[0] && Regex.match_simple(".*_REPLACE_.*",this.tab_title_regex[i+1])){
++ if(!done[0] && GLib.Regex.match_simple(".*_REPLACE_.*",this.tab_title_regex[i+1])){
+ //done[0]=true;//replace is allowed repeatedly
+ grx = new GLib.Regex(GLib.Regex.escape_string("_REPLACE_"));
+ result.append(grx.replace_literal(this.tab_title_regex[i+1],-1, 0, match_info.fetch(match_info.get_match_count()-1)) );
+ return true;//stop
+ }else
+- if(!done[1] && Regex.match_simple(".*_USER_.*",this.tab_title_regex[i+1])){
++ if(!done[1] && GLib.Regex.match_simple(".*_USER_.*",this.tab_title_regex[i+1])){
+ done[1]=true;
+ grx = new GLib.Regex(GLib.Regex.escape_string("_USER_"));
+ result.append(grx.replace_literal(this.tab_title_regex[i+1],-1, 0, match_info.fetch(match_info.get_match_count()-1)) );
+ return true;//stop
+ }else
+- if(!done[2] && Regex.match_simple(".*_HOSTNAME_.*",this.tab_title_regex[i+1])){
++ if(!done[2] && GLib.Regex.match_simple(".*_HOSTNAME_.*",this.tab_title_regex[i+1])){
+ done[2]=true;
+ grx = new GLib.Regex(GLib.Regex.escape_string("_HOSTNAME_"));
+ result.append(grx.replace_literal(this.tab_title_regex[i+1],-1, 0, match_info.fetch(match_info.get_match_count()-1)) );
+ this.host_name=match_info.fetch(match_info.get_match_count()-1);
+ return true;//stop
+ }else
+- if(!done[3] && Regex.match_simple(".*_PATH_.*",this.tab_title_regex[i+1])){
++ if(!done[3] && GLib.Regex.match_simple(".*_PATH_.*",this.tab_title_regex[i+1])){
+ done[3]=true;
+ grx = new GLib.Regex(GLib.Regex.escape_string("_PATH_"));
+ result.append(grx.replace_literal(this.tab_title_regex[i+1],-1, 0, match_info.fetch(match_info.get_match_count()-1)) );
+@@ -802,7 +802,7 @@ public class VTTerminal : AYTab{
+ (arg == "GDK_CORE_DEVICE_EVENTS" && this.my_conf.get_boolean("workaround_if_focuslost",false) ) ){
+ continue;//skip
+ }else
+- if( !GLib.Regex.match_simple(term_exclude_vars,arg,RegexCompileFlags.CASELESS,0) ){
++ if( !GLib.Regex.match_simple(term_exclude_vars,arg,GLib.RegexCompileFlags.CASELESS,0) ){
+ unowned string val=GLib.Environment.get_variable(arg);
+ string s="%s=%s".printf(arg,(val!=null?val:""));
+ envv+=s;
+@@ -1056,7 +1056,7 @@ public class VTTerminal : AYTab{
+ this.match_tags.steal_all();
+ debug("url_regexps=%d",url_regexps.length);
+ for(int j=0;j<url_regexps.length-1;j+=2){
+- var key=this.vte_term.match_add_gregex((new Regex (url_regexps[j])),0);
++ var key=this.vte_term.match_add_gregex((new GLib.Regex (url_regexps[j])),0);
+ debug("match_add_gregex %d",key);
+ if(!this.match_tags.lookup_extended(key,null,null))
+ this.match_tags.insert(key,url_regexps[j+1]);
+@@ -1616,7 +1616,7 @@ public class VTTerminal : AYTab{
+ //Password:
+ vte_text=vte_text.strip();
+ debug("expect=%s get '%s'",expect_string,vte_text);
+- if(GLib.Regex.match_simple(".*"+expect_string+".*",vte_text,RegexCompileFlags.CASELESS,0)){
++ if(GLib.Regex.match_simple(".*"+expect_string+".*",vte_text,GLib.RegexCompileFlags.CASELESS,0)){
+ this.vte_term.feed_child(paste,paste.length);
+ if(cb!=null) cb();
+ return false;