aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/pam_ocra/Makefile21
-rw-r--r--security/pam_ocra/distinfo4
2 files changed, 20 insertions, 5 deletions
diff --git a/security/pam_ocra/Makefile b/security/pam_ocra/Makefile
index f320eaa71d2e..28e492028431 100644
--- a/security/pam_ocra/Makefile
+++ b/security/pam_ocra/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pam_ocra
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= security
MAINTAINER= sg2342@googlemail.com
@@ -13,9 +13,10 @@ LICENSE= BSD2CLAUSE
USES= uidfix
USE_GITHUB= yes
+
GH_ACCOUNT= sg2342
GH_PROJECT= pam_ocra
-GH_COMMIT= abacd1d
+GH_COMMIT= d8b4ad3
PLIST_FILES= lib/pam_ocra.so \
lib/pam_ocra.so.0 \
@@ -23,4 +24,18 @@ PLIST_FILES= lib/pam_ocra.so \
man/man8/pam_ocra.8.gz \
man/man8/ocra_tool.8.gz
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000015
+WITH_OPENSSL_PORT= yes
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+.endif
+
+# we need to .include bsd.openssl.mk manually here.because USE_OPENSSL only
+# works when it is defined before bsd.port{.pre}.mk is .included.
+# This makes it currently impossible to combine this macro with OSVERSION to
+# conditionally select WITH_OPENSSL_PORT for OSVERSIONS before 1000015.
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+
+.include <bsd.port.post.mk>
diff --git a/security/pam_ocra/distinfo b/security/pam_ocra/distinfo
index 1681b549b724..1187a66ac8d3 100644
--- a/security/pam_ocra/distinfo
+++ b/security/pam_ocra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pam_ocra-1.0.tar.gz) = 0d11ee2cb7a999d1f28c9c4370ffc138aea2fff310b16abc60d3fd0c994ed271
-SIZE (pam_ocra-1.0.tar.gz) = 13353
+SHA256 (pam_ocra-1.1.tar.gz) = b997af1805d0b724f037fecd74da7b73a0ab64063b3e1fe606f5b1c781731f65
+SIZE (pam_ocra-1.1.tar.gz) = 14358