aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/ogg2mp3/Makefile1
-rw-r--r--audio/slimserver-lastfm/Makefile1
-rw-r--r--databases/pxlib/Makefile1
-rw-r--r--databases/rrdtool/Makefile1
-rw-r--r--deskutils/adesklets/Makefile1
-rw-r--r--devel/subversion-devel/Makefile2
-rw-r--r--devel/subversion-freebsd/Makefile2
-rw-r--r--devel/subversion/Makefile2
-rw-r--r--devel/subversion16/Makefile2
-rw-r--r--dns/scavenge/Makefile1
-rw-r--r--games/asciiquarium/Makefile1
-rw-r--r--graphics/crystalspace-devel/Makefile1
-rw-r--r--graphics/crystalspace/Makefile1
-rw-r--r--graphics/inkscape/Makefile1
-rw-r--r--irc/insub/Makefile1
-rw-r--r--irc/xchat-gnome/Makefile1
-rw-r--r--irc/xchat/Makefile1
-rw-r--r--mail/couriergraph/Makefile1
-rw-r--r--mail/lightning/Makefile1
-rw-r--r--mail/ovs/Makefile1
-rw-r--r--mail/postfix-policyd-weight/Makefile1
-rw-r--r--mail/spampd/Makefile1
-rw-r--r--mail/sympa5/Makefile48
-rw-r--r--mail/thunderbird-esr/Makefile1
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird3/Makefile1
-rw-r--r--net-mgmt/smokeping/Makefile6
-rw-r--r--net/lla/Makefile1
-rw-r--r--net/vnc/Makefile1
-rw-r--r--net/xrdesktop/Makefile1
-rw-r--r--news/inn/Makefile1
-rw-r--r--news/newsstar/Makefile22
-rw-r--r--news/ubh/Makefile1
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile1
-rw-r--r--ports-mgmt/tinderbox/Makefile1
-rw-r--r--russian/apache13/Makefile3
-rw-r--r--russian/p5-XML-Parser-encodings/Makefile1
-rw-r--r--sysutils/gdmap/Makefile1
-rw-r--r--sysutils/jps/Makefile1
-rw-r--r--sysutils/jtop/Makefile1
-rw-r--r--sysutils/ldap-account-manager/Makefile1
-rw-r--r--sysutils/lmon/Makefile1
-rw-r--r--sysutils/namefix/Makefile1
-rw-r--r--textproc/sarep/Makefile1
-rw-r--r--www/firefox-devel/Makefile1
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox15/Makefile1
-rw-r--r--www/firefox3-devel/Makefile1
-rw-r--r--www/firefox35/Makefile1
-rw-r--r--www/firefox36/Makefile1
-rw-r--r--www/seamonkey/Makefile1
-rw-r--r--www/seamonkey2/Makefile1
-rw-r--r--www/xulrunner/Makefile1
-rw-r--r--x11-wm/beryl-core/Makefile1
-rw-r--r--x11/libexo/Makefile1
56 files changed, 92 insertions, 43 deletions
diff --git a/audio/ogg2mp3/Makefile b/audio/ogg2mp3/Makefile
index e2383e842e15..585cec78e7c4 100644
--- a/audio/ogg2mp3/Makefile
+++ b/audio/ogg2mp3/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
NO_BUILD= yes
USE_BZIP2= yes
+USE_PERL5= yes
PLIST_FILES= bin/ogg2mp3
diff --git a/audio/slimserver-lastfm/Makefile b/audio/slimserver-lastfm/Makefile
index fe5f7ff2e18c..db1833788e66 100644
--- a/audio/slimserver-lastfm/Makefile
+++ b/audio/slimserver-lastfm/Makefile
@@ -18,6 +18,7 @@ COMMENT= SlimServer plugin for playing last.fm radio
RUN_DEPENDS= ${LOCALBASE}/bin/softsqueeze:${PORTSDIR}/audio/slimserver \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+USE_PERL5= yes
USE_ZIP= yes
WRKSRC= LastFM
NO_BUILD= yes
diff --git a/databases/pxlib/Makefile b/databases/pxlib/Makefile
index d4ffaab6d03a..f0f72f6a3f2a 100644
--- a/databases/pxlib/Makefile
+++ b/databases/pxlib/Makefile
@@ -20,6 +20,7 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
USE_GETTEXT= yes
+USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index 36e83e7ae55d..6fa30e634e23 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -21,6 +21,7 @@ USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+WANT_PERL= yes
CONFIGURE_ARGS= --disable-tcl
diff --git a/deskutils/adesklets/Makefile b/deskutils/adesklets/Makefile
index fdc198dd9d8d..d3b8c3833087 100644
--- a/deskutils/adesklets/Makefile
+++ b/deskutils/adesklets/Makefile
@@ -23,6 +23,7 @@ USE_PYTHON= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_XLIB= yes
+WANT_PERL= yes
MAN1= adesklets.1 \
adesklets_checkin.1 \
diff --git a/devel/subversion-devel/Makefile b/devel/subversion-devel/Makefile
index d0e06a97203c..7a3cfa7c55a9 100644
--- a/devel/subversion-devel/Makefile
+++ b/devel/subversion-devel/Makefile
@@ -27,6 +27,7 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
+WANT_PERL= yes
USE_RC_SUBR= svnserve
@@ -94,7 +95,6 @@ PLIST_SUB+= WITHOUT_BDB=""
.if defined(WITH_PERL)
USE_PERL5= 5.8.0+
SWIG_BINDINGS+= yes
-USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
diff --git a/devel/subversion-freebsd/Makefile b/devel/subversion-freebsd/Makefile
index d0e06a97203c..7a3cfa7c55a9 100644
--- a/devel/subversion-freebsd/Makefile
+++ b/devel/subversion-freebsd/Makefile
@@ -27,6 +27,7 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
+WANT_PERL= yes
USE_RC_SUBR= svnserve
@@ -94,7 +95,6 @@ PLIST_SUB+= WITHOUT_BDB=""
.if defined(WITH_PERL)
USE_PERL5= 5.8.0+
SWIG_BINDINGS+= yes
-USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index d0e06a97203c..7a3cfa7c55a9 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -27,6 +27,7 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
+WANT_PERL= yes
USE_RC_SUBR= svnserve
@@ -94,7 +95,6 @@ PLIST_SUB+= WITHOUT_BDB=""
.if defined(WITH_PERL)
USE_PERL5= 5.8.0+
SWIG_BINDINGS+= yes
-USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index d0e06a97203c..7a3cfa7c55a9 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -27,6 +27,7 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
+WANT_PERL= yes
USE_RC_SUBR= svnserve
@@ -94,7 +95,6 @@ PLIST_SUB+= WITHOUT_BDB=""
.if defined(WITH_PERL)
USE_PERL5= 5.8.0+
SWIG_BINDINGS+= yes
-USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
diff --git a/dns/scavenge/Makefile b/dns/scavenge/Makefile
index 955a3e0d062a..2bae30d6b412 100644
--- a/dns/scavenge/Makefile
+++ b/dns/scavenge/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
PLIST_FILES= bin/scavenge
NO_BUILD= yes
+USE_PERL5= yes
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/scavenge ${PREFIX}/bin
diff --git a/games/asciiquarium/Makefile b/games/asciiquarium/Makefile
index e4f630fdc328..a69e1c9e2751 100644
--- a/games/asciiquarium/Makefile
+++ b/games/asciiquarium/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${SITE_PERL}/Term/Animation.pm:${PORTSDIR}/devel/p5-Term-Animation
WRKSRC= ${WRKDIR}/${DISTNAME}
NO_BUILD= yes
+USE_PERL5= yes
PLIST_FILES= bin/asciiquarium
do-install:
diff --git a/graphics/crystalspace-devel/Makefile b/graphics/crystalspace-devel/Makefile
index 8cd98f9099d3..b5a19267716b 100644
--- a/graphics/crystalspace-devel/Makefile
+++ b/graphics/crystalspace-devel/Makefile
@@ -32,6 +32,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
USE_GL= yes
+WANT_PERL= yes
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/graphics/crystalspace/Makefile b/graphics/crystalspace/Makefile
index 0ea75752631b..8a6efbea39ad 100644
--- a/graphics/crystalspace/Makefile
+++ b/graphics/crystalspace/Makefile
@@ -33,6 +33,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
USE_GL= yes
+WANT_PERL= yes
LDFLAGS+= -L/usr/lib -lc
LIBS= -lc
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 6de1506285c1..cac2427866ca 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -28,6 +28,7 @@ USE_GNOME= gnomehack desktopfileutils intlhack libxslt
USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
+USE_PERL5= yes
CONFIGURE_ARGS= --with-popt
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
diff --git a/irc/insub/Makefile b/irc/insub/Makefile
index e2173d0bda44..24b98988aa80 100644
--- a/irc/insub/Makefile
+++ b/irc/insub/Makefile
@@ -17,6 +17,7 @@ COMMENT= Some scripts for expressing how you feel on irc and the web
NO_BUILD= YES
USE_BZIP2= YES
+USE_PERL5= YES
SCRIPT= ${PORTNAME}.pl
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 76e79c911b96..a741c7741ddc 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -31,6 +31,7 @@ CONFIGURE_ARGS= --disable-tcl
GCONF_SCHEMAS= apps_xchat.schemas notification.schemas urlscraper.schemas
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
+WANT_PERL= yes
MAN1= xchat-gnome.1
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 2adb46c2028a..d2537dcd6e95 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -27,6 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-ipv6
+WANT_PERL= yes
OPTIONS= DBUS "Enable DBUS support" on \
GTKSPELL "Enable spell check support using gtkspell" on \
diff --git a/mail/couriergraph/Makefile b/mail/couriergraph/Makefile
index 3776da4becaa..759cfe659372 100644
--- a/mail/couriergraph/Makefile
+++ b/mail/couriergraph/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
+USE_PERL5= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
DATADIR?= /var/db/couriergraph
diff --git a/mail/lightning/Makefile b/mail/lightning/Makefile
index 51b20cb0dcf6..4f99a694b426 100644
--- a/mail/lightning/Makefile
+++ b/mail/lightning/Makefile
@@ -25,6 +25,7 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
WANT_GNOME= yes
+WANT_PERL= yes
LIGHTNING_DIR= lib/thunderbird/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
MOZILLA= thunderbird
MOZILLA_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
diff --git a/mail/ovs/Makefile b/mail/ovs/Makefile
index 78d8fee79af0..aaa17333f1c4 100644
--- a/mail/ovs/Makefile
+++ b/mail/ovs/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
+USE_PERL5= yes
CGIDIR?= ${PREFIX}/www/cgi-bin
DATADIR?= /var/db/ovs
diff --git a/mail/postfix-policyd-weight/Makefile b/mail/postfix-policyd-weight/Makefile
index 36f9829ea80a..fc4b818a3363 100644
--- a/mail/postfix-policyd-weight/Makefile
+++ b/mail/postfix-policyd-weight/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
SUB_FILES= pkg-message
PLIST_FILES= bin/${PORTNAME} etc/${PORTNAME}.conf.sample
+USE_PERL5= yes
USE_RC_SUBR+= policyd-weight
MAN8+= policyd-weight.8
diff --git a/mail/spampd/Makefile b/mail/spampd/Makefile
index aeed1659ea63..4702fd2d3c81 100644
--- a/mail/spampd/Makefile
+++ b/mail/spampd/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
NO_BUILD= yes
PLIST_FILES= sbin/spampd
+USE_PERL5= yes
USE_RC_SUBR= spampd
do-install:
diff --git a/mail/sympa5/Makefile b/mail/sympa5/Makefile
index b9be45db2a3e..cf0203be92f5 100644
--- a/mail/sympa5/Makefile
+++ b/mail/sympa5/Makefile
@@ -31,6 +31,30 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
LATEST_LINK= sympa5
USE_APACHE= 1.3+
+HAS_CONFIGURE= yes
+USE_PERL5= 5.8.6+
+CONFIGURE_ARGS+=--prefix=${PREFIX} \
+ --with-confdir=${PREFIX}/etc/sympa \
+ --with-initdir=${PREFIX}/etc/rc.d \
+ --with-etcdir=${PREFIX}/etc/sympa \
+ --with-cgidir=${PREFIX}/sympa/cgi-bin \
+ --with-iconsdir=${PREFIX}/sympa/icons \
+ --with-sbindir=${PREFIX}/sbin \
+ --with-libdir=${PREFIX}/lib/sympa \
+ --with-libexecdir=${PREFIX}/libexec/sympa \
+ --with-datadir=${DATADIR} \
+ --with-expldir=${PREFIX}/sympa/expl \
+ --with-lockdir=/var/spool/lock \
+ --with-piddir=/var/run \
+ --with-localedir=${PREFIX}/share/locale \
+ --with-docdir=${DOCSDIR} \
+ --with-sampledir=${EXAMPLESDIR} \
+ --with-spooldir=${PREFIX}/sympa/spool
+CONFIGURE_ENV+= lt_cv_sys_max_cmd_len=${CONFIGURE_MAX_CMD_LEN}
+MAKE_ENV?= PERL_EXTUTILS_AUTOINSTALL=--skip
+
+MAN8= alias_manager.8 archived.8 bounced.8 sympa.8
+
CONFLICTS= sympa-4* sympa-5.[0-2]*
DB_TYPE?=mysql
@@ -66,30 +90,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-
.endif
.endif
-HAS_CONFIGURE= yes
-USE_PERL5= 5.8.6+
-CONFIGURE_ARGS+=--prefix=${PREFIX} \
- --with-confdir=${PREFIX}/etc/sympa \
- --with-initdir=${PREFIX}/etc/rc.d \
- --with-etcdir=${PREFIX}/etc/sympa \
- --with-cgidir=${PREFIX}/sympa/cgi-bin \
- --with-iconsdir=${PREFIX}/sympa/icons \
- --with-sbindir=${PREFIX}/sbin \
- --with-libdir=${PREFIX}/lib/sympa \
- --with-libexecdir=${PREFIX}/libexec/sympa \
- --with-datadir=${DATADIR} \
- --with-expldir=${PREFIX}/sympa/expl \
- --with-lockdir=/var/spool/lock \
- --with-piddir=/var/run \
- --with-localedir=${PREFIX}/share/locale \
- --with-docdir=${DOCSDIR} \
- --with-sampledir=${EXAMPLESDIR} \
- --with-spooldir=${PREFIX}/sympa/spool
-CONFIGURE_ENV+= lt_cv_sys_max_cmd_len=${CONFIGURE_MAX_CMD_LEN}
-MAKE_ENV?= PERL_EXTUTILS_AUTOINSTALL=--skip
-
-MAN8= alias_manager.8 archived.8 bounced.8 sympa.8
-
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 11b760257317..2b0d361cd7ef 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -24,6 +24,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 11b760257317..2b0d361cd7ef 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -24,6 +24,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 11b760257317..2b0d361cd7ef 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -24,6 +24,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index 90a0d7a8e36a..94183e0597a0 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -22,6 +22,9 @@ RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-Pod-Parser \
${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+NO_BUILD= yes
+USE_PERL5= yes
+
OPTIONS= FPING "Support for fping probes" on
OPTIONS+= ECHOPING "Support for EchoPing probes" off
OPTIONS+= CURL "Support for Curl probes" off
@@ -69,9 +72,6 @@ RUN_DEPENDS+= ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
.endif
-NO_BUILD= yes
-USE_PERL5= yes
-
USE_RC_SUBR= smokeping
MAN1= smokeping.1 \
diff --git a/net/lla/Makefile b/net/lla/Makefile
index 34609a2dcca0..e825d75bc971 100644
--- a/net/lla/Makefile
+++ b/net/lla/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${SITE_ARCH_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
NO_BUILD= yes
NO_WRKSUBDIR= yes
+USE_PERL5= yes
PLIST_FILES= bin/lla
EXTRACT_CMD= ${CP}
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index d1e3a0706919..ba4f5fa69ce5 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_ARGS= --with-installed-zlib
USE_GCC= 3.4
USE_XLIB= yes
USE_XPM= yes
+WANT_PERL= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
PLIST= ${WRKDIR}/pkg-plist
diff --git a/net/xrdesktop/Makefile b/net/xrdesktop/Makefile
index 8b8b8b698084..075f08d67352 100644
--- a/net/xrdesktop/Makefile
+++ b/net/xrdesktop/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop \
${SITE_PERL}/${PERL_ARCH}/Gtk:${PORTSDIR}/x11-toolkits/p5-Gtk
NO_BUILD= yes
+USE_PERL5= yes
PLIST_FILES= bin/xrdesktop
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 948ebb2a6f57..eade0431ebd2 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -22,6 +22,7 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_GMAKE= yes
USE_OPENSSL= yes
+WANT_PERL= yes
CONFLICTS?= inn-stable-[0-9]* inn-current-[0-9]*
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index 7b5819b9a25c..71c65a2499ad 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -16,6 +16,17 @@ COMMENT= Transfer news between a local NNTP server (INN, sn, s-news)
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+USE_PERL5= yes
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS+=--prefix=${PREFIX} --mandir=${PREFIX}/man \
+ --with-conf-dir=${PREFIX}/etc/newsstar \
+ --with-rc-dir=/var/spool/newsstar/lib \
+ --with-incoming-dir=/var/spool/newsstar/incoming
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS+=--disable-ssl
.else
@@ -39,17 +50,6 @@ CONFIGURE_ARGS+=--with-sn-spool-dir=/var/spool/news \
CONFIGURE_ARGS+=--with-inn-path=${LOCALBASE}/news/bin
.endif
-CONFIGURE_ARGS+=--prefix=${PREFIX} --mandir=${PREFIX}/man \
- --with-conf-dir=${PREFIX}/etc/newsstar \
- --with-rc-dir=/var/spool/newsstar/lib \
- --with-incoming-dir=/var/spool/newsstar/incoming
-
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-USE_PERL5= yes
-HAS_CONFIGURE= yes
-
MAN1= newsstar.1
DOCS= AUTHORS INSTALL NEWS README TODO docs/QuickStart docs/manual.txt \
docs/index.html docs/ar01s02.html docs/ar01s03.html docs/ar01s04.html \
diff --git a/news/ubh/Makefile b/news/ubh/Makefile
index 6c437f5a2713..ddd09a02487d 100644
--- a/news/ubh/Makefile
+++ b/news/ubh/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= \
${SITE_PERL}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32
NO_BUILD= YES
+USE_PERL5= YES
pre-patch:
@${MV} ${WRKSRC}/ubh ${WRKSRC}/ubh.old
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 4c05858cb71d..4b5d7ed903f3 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -22,6 +22,7 @@ OPTIONS= PGSQL "With pgsql" Off \
LIGHTTPD "Use LightHTTPD for web interface" Off
NO_BUILD= yes
+WANT_PERL5= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 4c05858cb71d..4b5d7ed903f3 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -22,6 +22,7 @@ OPTIONS= PGSQL "With pgsql" Off \
LIGHTTPD "Use LightHTTPD for web interface" Off
NO_BUILD= yes
+WANT_PERL5= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/russian/apache13/Makefile b/russian/apache13/Makefile
index 00c2e772f862..25095187afb0 100644
--- a/russian/apache13/Makefile
+++ b/russian/apache13/Makefile
@@ -19,6 +19,8 @@ PATCHFILES= patches_${APACHE_VERSION}rusPL${RA_VERSION}.tar.gz
MAINTAINER= lev@FreeBSD.org
COMMENT= The extremely popular Apache http server. Very fast, very clean
+USE_PERL5= yes
+
# New ports feature: conflicts
CONFLICTS= apache+ipv6-* \
apache+mod_ssl-* \
@@ -98,7 +100,6 @@ SUEXEC_MAN=
# Configutre parameters
#
-USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS=\
--prefix=${PREFIX} \
diff --git a/russian/p5-XML-Parser-encodings/Makefile b/russian/p5-XML-Parser-encodings/Makefile
index c9750b84897f..dcba02c76c60 100644
--- a/russian/p5-XML-Parser-encodings/Makefile
+++ b/russian/p5-XML-Parser-encodings/Makefile
@@ -21,6 +21,7 @@ BUILD_DEPENDS= ${RUN_DEPENDS} \
${NONEXISTENT}:${PORTSDIR}/converters/iconv-extra:extract
NO_WRKSUBDIR= YES
+USE_PERL5= YES
RUSSIANENC= windows-1251 koi8-r cp1251 cp866 mac-cyrillic
post-extract:
diff --git a/sysutils/gdmap/Makefile b/sysutils/gdmap/Makefile
index cac665153d37..dbcbf2ee5b9c 100644
--- a/sysutils/gdmap/Makefile
+++ b/sysutils/gdmap/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-X
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gtk20
USE_GMAKE= yes
+USE_PERL5= yes
GNU_CONFIGURE= yes
MAN1= gdmap.1
diff --git a/sysutils/jps/Makefile b/sysutils/jps/Makefile
index 84fd06790d78..a9cb54cf2074 100644
--- a/sysutils/jps/Makefile
+++ b/sysutils/jps/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
MAN1= jps.1
MANCOMPRESSED= yes
+USE_PERL5= yes
PLIST_FILES= bin/jps
.include <bsd.port.mk>
diff --git a/sysutils/jtop/Makefile b/sysutils/jtop/Makefile
index 310eed7d33bf..9add4b278bb2 100644
--- a/sysutils/jtop/Makefile
+++ b/sysutils/jtop/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
MAN1= jtop.1
MANCOMPRESSED= yes
+USE_PERL5= yes
PLIST_FILES= bin/jtop
.include <bsd.port.mk>
diff --git a/sysutils/ldap-account-manager/Makefile b/sysutils/ldap-account-manager/Makefile
index a121751c55c6..3f5a2b906b80 100644
--- a/sysutils/ldap-account-manager/Makefile
+++ b/sysutils/ldap-account-manager/Makefile
@@ -18,6 +18,7 @@ COMMENT= Webfrontend for managing accounts stored in an OpenLDAP server
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Quota.pm:${PORTSDIR}/sysutils/p5-Quota\
${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+USE_PERL5= yes
USE_PHP= pcre xml gettext session mcrypt ldap mhash iconv
WANT_PHP_WEB= yes
NO_BUILD= YES
diff --git a/sysutils/lmon/Makefile b/sysutils/lmon/Makefile
index ff33576396b8..2e16f290da3e 100644
--- a/sysutils/lmon/Makefile
+++ b/sysutils/lmon/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFile
${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
+USE_PERL5= yes
do-install:
${INSTALL} -d -m 0755 ${PREFIX}/${PORTNAME}
diff --git a/sysutils/namefix/Makefile b/sysutils/namefix/Makefile
index c10cd9a3e6e5..18a8327a52bf 100644
--- a/sysutils/namefix/Makefile
+++ b/sysutils/namefix/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= p5-MP3-Tag>=0:${PORTSDIR}/audio/p5-MP3-Tag \
WRKSRC= ${WRKDIR}/usr/local/namefix.pl
NO_BUILD= yes
USE_BZIP2= yes
+USE_PERL5= yes
post-extract:
@${FIND} ${WRKSRC} -name '*~' -delete
diff --git a/textproc/sarep/Makefile b/textproc/sarep/Makefile
index 642c55c1e660..9bcfb840ed12 100644
--- a/textproc/sarep/Makefile
+++ b/textproc/sarep/Makefile
@@ -22,6 +22,7 @@ EXTRACT_AFTER_ARGS= | ${TR} -d '\r' > ${WRKSRC}/sarep
NO_BUILD= yes
NO_WRKSUBDIR= yes
+USE_PERL5= yes
PLIST_FILES= bin/sarep
do-install:
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index a24494175aef..c5f5b722977c 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -35,6 +35,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/firefox-devel/chrome/icons/default/default.xpm
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 3e48e4eeb15a..c9f55b2d20af 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -31,6 +31,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
GECKO_PLIST_PRE_FILES= lib/${MOZILLA}/chrome/icons/default/default.xpm
GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/icons
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 3e48e4eeb15a..c9f55b2d20af 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -31,6 +31,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
GECKO_PLIST_PRE_FILES= lib/${MOZILLA}/chrome/icons/default/default.xpm
GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/icons
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index f0f7d3fd2170..26c8b9ac1b01 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -32,6 +32,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
GECKO_PLIST_PRE_FILES= lib/${MOZILLA}/chrome/icons/default/default.xpm
GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/icons
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index a24494175aef..c5f5b722977c 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -35,6 +35,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/firefox-devel/chrome/icons/default/default.xpm
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index a24494175aef..c5f5b722977c 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -35,6 +35,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/firefox-devel/chrome/icons/default/default.xpm
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 3e48e4eeb15a..c9f55b2d20af 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -31,6 +31,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
GECKO_PLIST_PRE_FILES= lib/${MOZILLA}/chrome/icons/default/default.xpm
GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/icons
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index dcfc7bb86f25..c28561bacef9 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -19,6 +19,7 @@ COMMENT= The open source, standards compliant web browser
USE_BZIP2= yes
USE_GMAKE= yes
WANT_GNOME= yes
+WANT_PERL= yes
HAS_CONFIGURE= yes
ALL_TARGET= default
MOZ_PIS_SCRIPTS= moz_pis_S50cleanhome
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index dcfc7bb86f25..c28561bacef9 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -19,6 +19,7 @@ COMMENT= The open source, standards compliant web browser
USE_BZIP2= yes
USE_GMAKE= yes
WANT_GNOME= yes
+WANT_PERL= yes
HAS_CONFIGURE= yes
ALL_TARGET= default
MOZ_PIS_SCRIPTS= moz_pis_S50cleanhome
diff --git a/www/xulrunner/Makefile b/www/xulrunner/Makefile
index bd2d708ebaac..24988bcc7c21 100644
--- a/www/xulrunner/Makefile
+++ b/www/xulrunner/Makefile
@@ -18,6 +18,7 @@ MAINTAINER?= gnome@FreeBSD.org
COMMENT?= Mozilla runtime package that can be used to bootstrap XUL+XPCOM apps
WANT_GNOME= yes
+WANT_PERL= yes
ALL_TARGET= default
HAS_CONFIGURE= yes
USE_BZIP2= yes
diff --git a/x11-wm/beryl-core/Makefile b/x11-wm/beryl-core/Makefile
index 2826f03a2bbf..0ed02322b5fb 100644
--- a/x11-wm/beryl-core/Makefile
+++ b/x11-wm/beryl-core/Makefile
@@ -28,6 +28,7 @@ USE_GMAKE= yes
USE_GNOME= gnomehack glib20 gconf2
USE_GETTEXT= yes
USE_LDCONFIG= yes
+USE_PERL5= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --disable-berylmesa
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index 327e9e3a50fd..9a94fa9337dd 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -28,6 +28,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack gnometarget gtk20 intltool intlhack pkgconfig
USE_LDCONFIG= yes
+USE_PERL5= yes
USE_XFCE= configenv libutil mcsmanager
USE_XLIB= yes