aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/asterisk-bristuff/Makefile4
-rw-r--r--net/asterisk-bristuff/files/patch-apps::app_rxfax.c13
-rw-r--r--net/asterisk-bristuff/files/patch-apps::app_txfax.c13
-rw-r--r--net/asterisk-devel/Makefile4
-rw-r--r--net/asterisk-devel/files/patch-apps::app_rxfax.c13
-rw-r--r--net/asterisk-devel/files/patch-apps::app_txfax.c13
-rw-r--r--net/asterisk/Makefile4
-rw-r--r--net/asterisk/files/patch-apps::app_rxfax.c13
-rw-r--r--net/asterisk/files/patch-apps::app_txfax.c13
-rw-r--r--net/asterisk10/Makefile4
-rw-r--r--net/asterisk10/files/patch-apps::app_rxfax.c13
-rw-r--r--net/asterisk10/files/patch-apps::app_txfax.c13
-rw-r--r--net/asterisk12/Makefile4
-rw-r--r--net/asterisk12/files/patch-apps::app_rxfax.c13
-rw-r--r--net/asterisk12/files/patch-apps::app_txfax.c13
-rw-r--r--net/asterisk14/Makefile4
-rw-r--r--net/asterisk14/files/patch-apps::app_rxfax.c13
-rw-r--r--net/asterisk14/files/patch-apps::app_txfax.c13
-rw-r--r--net/asterisk16/Makefile4
-rw-r--r--net/asterisk16/files/patch-apps::app_rxfax.c13
-rw-r--r--net/asterisk16/files/patch-apps::app_txfax.c13
21 files changed, 147 insertions, 63 deletions
diff --git a/net/asterisk-bristuff/Makefile b/net/asterisk-bristuff/Makefile
index 60a8230c08cd..93e63cc0dc85 100644
--- a/net/asterisk-bristuff/Makefile
+++ b/net/asterisk-bristuff/Makefile
@@ -85,9 +85,7 @@ MAKE_ENV+= WITH_ODBC=1
USE_MYSQL= yes
.endif
-#
-# FAX apps can't be compiled on RELENG_4 at the moment
-.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+.if defined(WITHOUT_FAX)
PLIST_SUB+= WITH_FAX="@comment "
.else
MAKE_ENV+= WITH_FAX=1
diff --git a/net/asterisk-bristuff/files/patch-apps::app_rxfax.c b/net/asterisk-bristuff/files/patch-apps::app_rxfax.c
index c8f4e3e296dc..88362bfc7914 100644
--- a/net/asterisk-bristuff/files/patch-apps::app_rxfax.c
+++ b/net/asterisk-bristuff/files/patch-apps::app_rxfax.c
@@ -1,6 +1,9 @@
---- apps/app_rxfax.c.orig Fri Jun 17 21:13:01 2005
-+++ apps/app_rxfax.c Fri Jun 17 21:04:12 2005
-@@ -0,0 +1,367 @@
+
+$FreeBSD$
+
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,371 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -25,7 +28,11 @@
+#include <asterisk/manager.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <math.h>
diff --git a/net/asterisk-bristuff/files/patch-apps::app_txfax.c b/net/asterisk-bristuff/files/patch-apps::app_txfax.c
index 52bcc3fdde23..8daf0f979334 100644
--- a/net/asterisk-bristuff/files/patch-apps::app_txfax.c
+++ b/net/asterisk-bristuff/files/patch-apps::app_txfax.c
@@ -1,6 +1,9 @@
---- apps/app_txfax.c.orig Fri Jun 17 21:13:05 2005
-+++ apps/app_txfax.c Fri Jun 17 21:00:43 2005
-@@ -0,0 +1,289 @@
+
+$FreeBSD$
+
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,293 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -23,7 +26,11 @@
+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <tiffio.h>
diff --git a/net/asterisk-devel/Makefile b/net/asterisk-devel/Makefile
index 60a8230c08cd..93e63cc0dc85 100644
--- a/net/asterisk-devel/Makefile
+++ b/net/asterisk-devel/Makefile
@@ -85,9 +85,7 @@ MAKE_ENV+= WITH_ODBC=1
USE_MYSQL= yes
.endif
-#
-# FAX apps can't be compiled on RELENG_4 at the moment
-.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+.if defined(WITHOUT_FAX)
PLIST_SUB+= WITH_FAX="@comment "
.else
MAKE_ENV+= WITH_FAX=1
diff --git a/net/asterisk-devel/files/patch-apps::app_rxfax.c b/net/asterisk-devel/files/patch-apps::app_rxfax.c
index c8f4e3e296dc..88362bfc7914 100644
--- a/net/asterisk-devel/files/patch-apps::app_rxfax.c
+++ b/net/asterisk-devel/files/patch-apps::app_rxfax.c
@@ -1,6 +1,9 @@
---- apps/app_rxfax.c.orig Fri Jun 17 21:13:01 2005
-+++ apps/app_rxfax.c Fri Jun 17 21:04:12 2005
-@@ -0,0 +1,367 @@
+
+$FreeBSD$
+
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,371 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -25,7 +28,11 @@
+#include <asterisk/manager.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <math.h>
diff --git a/net/asterisk-devel/files/patch-apps::app_txfax.c b/net/asterisk-devel/files/patch-apps::app_txfax.c
index 52bcc3fdde23..8daf0f979334 100644
--- a/net/asterisk-devel/files/patch-apps::app_txfax.c
+++ b/net/asterisk-devel/files/patch-apps::app_txfax.c
@@ -1,6 +1,9 @@
---- apps/app_txfax.c.orig Fri Jun 17 21:13:05 2005
-+++ apps/app_txfax.c Fri Jun 17 21:00:43 2005
-@@ -0,0 +1,289 @@
+
+$FreeBSD$
+
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,293 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -23,7 +26,11 @@
+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <tiffio.h>
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 60a8230c08cd..93e63cc0dc85 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -85,9 +85,7 @@ MAKE_ENV+= WITH_ODBC=1
USE_MYSQL= yes
.endif
-#
-# FAX apps can't be compiled on RELENG_4 at the moment
-.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+.if defined(WITHOUT_FAX)
PLIST_SUB+= WITH_FAX="@comment "
.else
MAKE_ENV+= WITH_FAX=1
diff --git a/net/asterisk/files/patch-apps::app_rxfax.c b/net/asterisk/files/patch-apps::app_rxfax.c
index c8f4e3e296dc..88362bfc7914 100644
--- a/net/asterisk/files/patch-apps::app_rxfax.c
+++ b/net/asterisk/files/patch-apps::app_rxfax.c
@@ -1,6 +1,9 @@
---- apps/app_rxfax.c.orig Fri Jun 17 21:13:01 2005
-+++ apps/app_rxfax.c Fri Jun 17 21:04:12 2005
-@@ -0,0 +1,367 @@
+
+$FreeBSD$
+
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,371 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -25,7 +28,11 @@
+#include <asterisk/manager.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <math.h>
diff --git a/net/asterisk/files/patch-apps::app_txfax.c b/net/asterisk/files/patch-apps::app_txfax.c
index 52bcc3fdde23..8daf0f979334 100644
--- a/net/asterisk/files/patch-apps::app_txfax.c
+++ b/net/asterisk/files/patch-apps::app_txfax.c
@@ -1,6 +1,9 @@
---- apps/app_txfax.c.orig Fri Jun 17 21:13:05 2005
-+++ apps/app_txfax.c Fri Jun 17 21:00:43 2005
-@@ -0,0 +1,289 @@
+
+$FreeBSD$
+
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,293 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -23,7 +26,11 @@
+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <tiffio.h>
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 60a8230c08cd..93e63cc0dc85 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -85,9 +85,7 @@ MAKE_ENV+= WITH_ODBC=1
USE_MYSQL= yes
.endif
-#
-# FAX apps can't be compiled on RELENG_4 at the moment
-.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+.if defined(WITHOUT_FAX)
PLIST_SUB+= WITH_FAX="@comment "
.else
MAKE_ENV+= WITH_FAX=1
diff --git a/net/asterisk10/files/patch-apps::app_rxfax.c b/net/asterisk10/files/patch-apps::app_rxfax.c
index c8f4e3e296dc..88362bfc7914 100644
--- a/net/asterisk10/files/patch-apps::app_rxfax.c
+++ b/net/asterisk10/files/patch-apps::app_rxfax.c
@@ -1,6 +1,9 @@
---- apps/app_rxfax.c.orig Fri Jun 17 21:13:01 2005
-+++ apps/app_rxfax.c Fri Jun 17 21:04:12 2005
-@@ -0,0 +1,367 @@
+
+$FreeBSD$
+
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,371 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -25,7 +28,11 @@
+#include <asterisk/manager.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <math.h>
diff --git a/net/asterisk10/files/patch-apps::app_txfax.c b/net/asterisk10/files/patch-apps::app_txfax.c
index 52bcc3fdde23..8daf0f979334 100644
--- a/net/asterisk10/files/patch-apps::app_txfax.c
+++ b/net/asterisk10/files/patch-apps::app_txfax.c
@@ -1,6 +1,9 @@
---- apps/app_txfax.c.orig Fri Jun 17 21:13:05 2005
-+++ apps/app_txfax.c Fri Jun 17 21:00:43 2005
-@@ -0,0 +1,289 @@
+
+$FreeBSD$
+
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,293 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -23,7 +26,11 @@
+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <tiffio.h>
diff --git a/net/asterisk12/Makefile b/net/asterisk12/Makefile
index 60a8230c08cd..93e63cc0dc85 100644
--- a/net/asterisk12/Makefile
+++ b/net/asterisk12/Makefile
@@ -85,9 +85,7 @@ MAKE_ENV+= WITH_ODBC=1
USE_MYSQL= yes
.endif
-#
-# FAX apps can't be compiled on RELENG_4 at the moment
-.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+.if defined(WITHOUT_FAX)
PLIST_SUB+= WITH_FAX="@comment "
.else
MAKE_ENV+= WITH_FAX=1
diff --git a/net/asterisk12/files/patch-apps::app_rxfax.c b/net/asterisk12/files/patch-apps::app_rxfax.c
index c8f4e3e296dc..88362bfc7914 100644
--- a/net/asterisk12/files/patch-apps::app_rxfax.c
+++ b/net/asterisk12/files/patch-apps::app_rxfax.c
@@ -1,6 +1,9 @@
---- apps/app_rxfax.c.orig Fri Jun 17 21:13:01 2005
-+++ apps/app_rxfax.c Fri Jun 17 21:04:12 2005
-@@ -0,0 +1,367 @@
+
+$FreeBSD$
+
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,371 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -25,7 +28,11 @@
+#include <asterisk/manager.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <math.h>
diff --git a/net/asterisk12/files/patch-apps::app_txfax.c b/net/asterisk12/files/patch-apps::app_txfax.c
index 52bcc3fdde23..8daf0f979334 100644
--- a/net/asterisk12/files/patch-apps::app_txfax.c
+++ b/net/asterisk12/files/patch-apps::app_txfax.c
@@ -1,6 +1,9 @@
---- apps/app_txfax.c.orig Fri Jun 17 21:13:05 2005
-+++ apps/app_txfax.c Fri Jun 17 21:00:43 2005
-@@ -0,0 +1,289 @@
+
+$FreeBSD$
+
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,293 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -23,7 +26,11 @@
+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <tiffio.h>
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 60a8230c08cd..93e63cc0dc85 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -85,9 +85,7 @@ MAKE_ENV+= WITH_ODBC=1
USE_MYSQL= yes
.endif
-#
-# FAX apps can't be compiled on RELENG_4 at the moment
-.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+.if defined(WITHOUT_FAX)
PLIST_SUB+= WITH_FAX="@comment "
.else
MAKE_ENV+= WITH_FAX=1
diff --git a/net/asterisk14/files/patch-apps::app_rxfax.c b/net/asterisk14/files/patch-apps::app_rxfax.c
index c8f4e3e296dc..88362bfc7914 100644
--- a/net/asterisk14/files/patch-apps::app_rxfax.c
+++ b/net/asterisk14/files/patch-apps::app_rxfax.c
@@ -1,6 +1,9 @@
---- apps/app_rxfax.c.orig Fri Jun 17 21:13:01 2005
-+++ apps/app_rxfax.c Fri Jun 17 21:04:12 2005
-@@ -0,0 +1,367 @@
+
+$FreeBSD$
+
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,371 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -25,7 +28,11 @@
+#include <asterisk/manager.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <math.h>
diff --git a/net/asterisk14/files/patch-apps::app_txfax.c b/net/asterisk14/files/patch-apps::app_txfax.c
index 52bcc3fdde23..8daf0f979334 100644
--- a/net/asterisk14/files/patch-apps::app_txfax.c
+++ b/net/asterisk14/files/patch-apps::app_txfax.c
@@ -1,6 +1,9 @@
---- apps/app_txfax.c.orig Fri Jun 17 21:13:05 2005
-+++ apps/app_txfax.c Fri Jun 17 21:00:43 2005
-@@ -0,0 +1,289 @@
+
+$FreeBSD$
+
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,293 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -23,7 +26,11 @@
+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <tiffio.h>
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 60a8230c08cd..93e63cc0dc85 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -85,9 +85,7 @@ MAKE_ENV+= WITH_ODBC=1
USE_MYSQL= yes
.endif
-#
-# FAX apps can't be compiled on RELENG_4 at the moment
-.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+.if defined(WITHOUT_FAX)
PLIST_SUB+= WITH_FAX="@comment "
.else
MAKE_ENV+= WITH_FAX=1
diff --git a/net/asterisk16/files/patch-apps::app_rxfax.c b/net/asterisk16/files/patch-apps::app_rxfax.c
index c8f4e3e296dc..88362bfc7914 100644
--- a/net/asterisk16/files/patch-apps::app_rxfax.c
+++ b/net/asterisk16/files/patch-apps::app_rxfax.c
@@ -1,6 +1,9 @@
---- apps/app_rxfax.c.orig Fri Jun 17 21:13:01 2005
-+++ apps/app_rxfax.c Fri Jun 17 21:04:12 2005
-@@ -0,0 +1,367 @@
+
+$FreeBSD$
+
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,371 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -25,7 +28,11 @@
+#include <asterisk/manager.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <math.h>
diff --git a/net/asterisk16/files/patch-apps::app_txfax.c b/net/asterisk16/files/patch-apps::app_txfax.c
index 52bcc3fdde23..8daf0f979334 100644
--- a/net/asterisk16/files/patch-apps::app_txfax.c
+++ b/net/asterisk16/files/patch-apps::app_txfax.c
@@ -1,6 +1,9 @@
---- apps/app_txfax.c.orig Fri Jun 17 21:13:05 2005
-+++ apps/app_txfax.c Fri Jun 17 21:00:43 2005
-@@ -0,0 +1,289 @@
+
+$FreeBSD$
+
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,293 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -23,7 +26,11 @@
+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <tiffio.h>