aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--news/Makefile1
-rw-r--r--news/grn/Makefile33
-rw-r--r--news/grn/distinfo1
-rw-r--r--news/grn/pkg-comment1
-rw-r--r--news/grn/pkg-descr11
-rw-r--r--news/grn/pkg-plist19
6 files changed, 66 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index 36bab47ba1dd..d10dba968301 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -9,6 +9,7 @@
SUBDIR += diablo
SUBDIR += dnews
SUBDIR += fidogate
+ SUBDIR += grn
SUBDIR += gup
SUBDIR += ifmail
SUBDIR += inn
diff --git a/news/grn/Makefile b/news/grn/Makefile
new file mode 100644
index 000000000000..28fd2f40f434
--- /dev/null
+++ b/news/grn/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: grm
+# Date created: 20 July 2000
+# Whom: Maxim Sobolev
+#
+# $FreeBSD$
+#
+
+PORTNAME= grn
+PORTVERSION= 0.0.26
+CATEGORIES= news gnome
+MASTER_SITES= ftp://ivvs.ul.ru/pub/unix/grn/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ xml.5:${PORTSDIR}/textproc/libxml
+RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure libmutt/configure
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ENV= glibpath="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/news/grn/distinfo b/news/grn/distinfo
new file mode 100644
index 000000000000..4550f7c695b4
--- /dev/null
+++ b/news/grn/distinfo
@@ -0,0 +1 @@
+MD5 (grn-0.0.26.tar.bz2) = 9d888f17ceae21b8f3aaf8a47751b121
diff --git a/news/grn/pkg-comment b/news/grn/pkg-comment
new file mode 100644
index 000000000000..4939e15cca65
--- /dev/null
+++ b/news/grn/pkg-comment
@@ -0,0 +1 @@
+A NNTP client for Gnome
diff --git a/news/grn/pkg-descr b/news/grn/pkg-descr
new file mode 100644
index 000000000000..b3f718ce6814
--- /dev/null
+++ b/news/grn/pkg-descr
@@ -0,0 +1,11 @@
+Grn is NNTP client which is written with the help of Gnome and Gtk. It is
+designed primarily to look like tin as much as possible, but work under X, and
+use all the advantages that Gnome and Gtk provide. It is written also under the
+influence of FleetStreet - an FTN-compatible message editor for OS/2
+Presentation Manager.
+
+Grn also uses pthreads to allow the user to interact with the program during
+different time-consuming tasks (such as fetching grouplist or threading
+articles - these all run in another thread).
+
+WWW: http://ivvs.ul.ru/~sc/grn/
diff --git a/news/grn/pkg-plist b/news/grn/pkg-plist
new file mode 100644
index 000000000000..c0c85cbabe28
--- /dev/null
+++ b/news/grn/pkg-plist
@@ -0,0 +1,19 @@
+bin/grn
+share/locale/ru/LC_MESSAGES/grn.mo
+share/gnome/apps/Internet/grn.desktop
+share/gnome/help/grn/C/Perl_functions.html
+share/gnome/help/grn/C/hooks-Perl.html
+share/gnome/help/grn/C/index.html
+share/gnome/help/grn/C/inline_vars.html
+share/gnome/help/grn/C/keyboard.html
+share/gnome/help/grn/C/topic.dat
+share/gnome/help/grn/ru/Perl_functions.html
+share/gnome/help/grn/ru/hooks-Perl.html
+share/gnome/help/grn/ru/index.html
+share/gnome/help/grn/ru/inline_vars.html
+share/gnome/help/grn/ru/keyboard.html
+share/gnome/help/grn/ru/topic.dat
+share/gnome/pixmaps/grn.png
+@dirrm share/gnome/help/grn/ru
+@dirrm share/gnome/help/grn/C
+@dirrm share/gnome/help/grn