aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Breadcrumbs/Makefile22
-rw-r--r--www/p5-HTML-Breadcrumbs/distinfo1
-rw-r--r--www/p5-HTML-Breadcrumbs/pkg-descr20
-rw-r--r--www/p5-HTML-Breadcrumbs/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fe4f969ae4ff..2ba0434303c3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -338,6 +338,7 @@
SUBDIR += p5-Flash-FLAP
SUBDIR += p5-GtkHTML
SUBDIR += p5-HTML
+ SUBDIR += p5-HTML-Breadcrumbs
SUBDIR += p5-HTML-CalendarMonthSimple
SUBDIR += p5-HTML-Clean
SUBDIR += p5-HTML-Element-Extended
diff --git a/www/p5-HTML-Breadcrumbs/Makefile b/www/p5-HTML-Breadcrumbs/Makefile
new file mode 100644
index 000000000000..5adaf57dd4e3
--- /dev/null
+++ b/www/p5-HTML-Breadcrumbs/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-HTML-Breadcrumbs
+# Date created: 14 August 2003
+# Whom: andrew@scoop.co.nz
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Breadcrumbs
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrew@scoop.co.nz
+COMMENT= Module to produce HTML 'breadcrumb trails'
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Breadcrumbs.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Breadcrumbs/distinfo b/www/p5-HTML-Breadcrumbs/distinfo
new file mode 100644
index 000000000000..2f5a452a8c8f
--- /dev/null
+++ b/www/p5-HTML-Breadcrumbs/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-Breadcrumbs-0.03.tar.gz) = 416761bd652badf4b3308ea9be8b37d7
diff --git a/www/p5-HTML-Breadcrumbs/pkg-descr b/www/p5-HTML-Breadcrumbs/pkg-descr
new file mode 100644
index 000000000000..332117766a84
--- /dev/null
+++ b/www/p5-HTML-Breadcrumbs/pkg-descr
@@ -0,0 +1,20 @@
+HTML::Breadcrumbs
+=================
+
+HTML::Breadcrumbs is a module used to create HTML 'breadcrumb trails'
+i.e. an ordered set of html links locating the current page within
+a hierarchy.
+
+HTML::Breadcrumbs splits the given path up into a list of elements,
+derives labels to use for each of these elements, and then renders
+this list as N-1 links using the derived label, with the final
+element being just a label.
+
+Both procedural and object-oriented interfaces are provided. The OO
+interface is useful if you want to separate object creation and
+initialisation from rendering or display, or for subclassing.
+
+Both interfaces allow you to munge the path in various ways, to set
+labels either explicitly via a hashref or via a callback subroutine,
+and to control the formatting of elements via sprintf patterns or a
+callback subroutine.
diff --git a/www/p5-HTML-Breadcrumbs/pkg-plist b/www/p5-HTML-Breadcrumbs/pkg-plist
new file mode 100644
index 000000000000..d39528c22171
--- /dev/null
+++ b/www/p5-HTML-Breadcrumbs/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Breadcrumbs/.packlist
+%%SITE_PERL%%/HTML/Breadcrumbs.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Breadcrumbs
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true