aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/xpilot-ng-client/Makefile3
-rw-r--r--games/xpilot-ng-client/pkg-plist2
-rw-r--r--games/xpilot-ng-server/Makefile3
-rw-r--r--games/xpilot-ng-server/pkg-plist2
-rw-r--r--games/xpilot-ng/Makefile3
-rw-r--r--games/xpilot-ng/pkg-plist2
6 files changed, 15 insertions, 0 deletions
diff --git a/games/xpilot-ng-client/Makefile b/games/xpilot-ng-client/Makefile
index c145dde72d7f..4fd82b2c7fca 100644
--- a/games/xpilot-ng-client/Makefile
+++ b/games/xpilot-ng-client/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xpilot-ng
PORTVERSION= 4.5.4X2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.hut.fi/~ksoderbl/xpilot/
DISTNAME= xpilot-${PORTVERSION}
@@ -19,6 +20,8 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+MAN6= xp-mapedit-ng.6 xp-replay-ng.6 xpilot-ng.6 xpilots-ng.6
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --program-suffix=-ng
diff --git a/games/xpilot-ng-client/pkg-plist b/games/xpilot-ng-client/pkg-plist
index 72954edfb84e..85da5c490fdf 100644
--- a/games/xpilot-ng-client/pkg-plist
+++ b/games/xpilot-ng-client/pkg-plist
@@ -1,6 +1,7 @@
bin/xpilot-ng
bin/xpilots-ng
bin/xp-replay-ng
+share/xpilot/mapconvert.py
share/xpilot-ng/maps/teamcup.xp
share/xpilot-ng/maps/polybloods.xp2
share/xpilot-ng/textures/allitems.ppm
@@ -62,6 +63,7 @@ share/xpilot-ng/defaults
share/xpilot-ng/password
share/xpilot-ng/robots
share/xpilot-ng/sounds
+@dirrm share/xpilot
@dirrm share/xpilot-ng/maps
@dirrm share/xpilot-ng/textures
@dirrm share/xpilot-ng
diff --git a/games/xpilot-ng-server/Makefile b/games/xpilot-ng-server/Makefile
index c145dde72d7f..4fd82b2c7fca 100644
--- a/games/xpilot-ng-server/Makefile
+++ b/games/xpilot-ng-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xpilot-ng
PORTVERSION= 4.5.4X2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.hut.fi/~ksoderbl/xpilot/
DISTNAME= xpilot-${PORTVERSION}
@@ -19,6 +20,8 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+MAN6= xp-mapedit-ng.6 xp-replay-ng.6 xpilot-ng.6 xpilots-ng.6
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --program-suffix=-ng
diff --git a/games/xpilot-ng-server/pkg-plist b/games/xpilot-ng-server/pkg-plist
index 72954edfb84e..85da5c490fdf 100644
--- a/games/xpilot-ng-server/pkg-plist
+++ b/games/xpilot-ng-server/pkg-plist
@@ -1,6 +1,7 @@
bin/xpilot-ng
bin/xpilots-ng
bin/xp-replay-ng
+share/xpilot/mapconvert.py
share/xpilot-ng/maps/teamcup.xp
share/xpilot-ng/maps/polybloods.xp2
share/xpilot-ng/textures/allitems.ppm
@@ -62,6 +63,7 @@ share/xpilot-ng/defaults
share/xpilot-ng/password
share/xpilot-ng/robots
share/xpilot-ng/sounds
+@dirrm share/xpilot
@dirrm share/xpilot-ng/maps
@dirrm share/xpilot-ng/textures
@dirrm share/xpilot-ng
diff --git a/games/xpilot-ng/Makefile b/games/xpilot-ng/Makefile
index c145dde72d7f..4fd82b2c7fca 100644
--- a/games/xpilot-ng/Makefile
+++ b/games/xpilot-ng/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xpilot-ng
PORTVERSION= 4.5.4X2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.hut.fi/~ksoderbl/xpilot/
DISTNAME= xpilot-${PORTVERSION}
@@ -19,6 +20,8 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+MAN6= xp-mapedit-ng.6 xp-replay-ng.6 xpilot-ng.6 xpilots-ng.6
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --program-suffix=-ng
diff --git a/games/xpilot-ng/pkg-plist b/games/xpilot-ng/pkg-plist
index 72954edfb84e..85da5c490fdf 100644
--- a/games/xpilot-ng/pkg-plist
+++ b/games/xpilot-ng/pkg-plist
@@ -1,6 +1,7 @@
bin/xpilot-ng
bin/xpilots-ng
bin/xp-replay-ng
+share/xpilot/mapconvert.py
share/xpilot-ng/maps/teamcup.xp
share/xpilot-ng/maps/polybloods.xp2
share/xpilot-ng/textures/allitems.ppm
@@ -62,6 +63,7 @@ share/xpilot-ng/defaults
share/xpilot-ng/password
share/xpilot-ng/robots
share/xpilot-ng/sounds
+@dirrm share/xpilot
@dirrm share/xpilot-ng/maps
@dirrm share/xpilot-ng/textures
@dirrm share/xpilot-ng