aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/pecl-yaz/Makefile26
-rw-r--r--net/pecl-yaz/distinfo2
-rw-r--r--net/pecl-yaz/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3094dc7b1fff..d9044f615a1a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -507,6 +507,7 @@
SUBDIR += pear-Net_URL
SUBDIR += pear-SOAP
SUBDIR += pebrot
+ SUBDIR += pecl-yaz
SUBDIR += pen
SUBDIR += perldap
SUBDIR += pfflowd
diff --git a/net/pecl-yaz/Makefile b/net/pecl-yaz/Makefile
new file mode 100644
index 000000000000..b02ffbe45bc7
--- /dev/null
+++ b/net/pecl-yaz/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pecl-yaz
+# Date created: 9 Jul 2004
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yaz
+PORTVERSION= 1.0.1
+CATEGORIES= net pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A PECL extension that implements a Z39.50 client
+
+LIB_DEPENDS= yaz.2:${PORTSDIR}/net/yaz
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --with-yaz=${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/net/pecl-yaz/distinfo b/net/pecl-yaz/distinfo
new file mode 100644
index 000000000000..ce5627025fac
--- /dev/null
+++ b/net/pecl-yaz/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/yaz-1.0.1.tgz) = ae04a125b4ea3a4f292d06fc881be402
+SIZE (PECL/yaz-1.0.1.tgz) = 14656
diff --git a/net/pecl-yaz/pkg-descr b/net/pecl-yaz/pkg-descr
new file mode 100644
index 000000000000..d9d949f83b99
--- /dev/null
+++ b/net/pecl-yaz/pkg-descr
@@ -0,0 +1,7 @@
+PHP/YAZ is an extension to the popular web server language PHP that implements
+Z39.50 origin (client) functionality as well as the SRW/SRU protocols.
+
+WWW: http://pecl.php.net/package/yaz/
+
+- Alex Dupre
+ale@FreeBSD.org