aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/jabberd/Makefile5
-rw-r--r--net/jabberd/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index e1345bbfb0f9..d531494e8d8b 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -22,6 +22,7 @@ OPTIONS= POSTGRESQL "Use PostgreSQL for storage and authentication" off \
LDAP "Use LDAP for authentication" off \
BDB "Use BDB for storage and authentication" off \
PAM "Use PAM for authentication" off \
+ PIPE "Enable pipe auth/reg support" off \
DEBUG "Compile with debug information" on
GNU_CONFIGURE= yes
@@ -78,6 +79,10 @@ CONFIGURE_ARGS+=--enable-pam
CONFIGURE_ARGS+=--disable-pam
.endif
+.if defined(WITH_PIPE)
+CONFIGURE_ARGS+=--enable-pipe
+.endif
+
MAN8= c2s.8 jabberd.8 resolver.8 router.8 s2s.8 sm.8
pre-install:
diff --git a/net/jabberd/Makefile b/net/jabberd/Makefile
index e1345bbfb0f9..d531494e8d8b 100644
--- a/net/jabberd/Makefile
+++ b/net/jabberd/Makefile
@@ -22,6 +22,7 @@ OPTIONS= POSTGRESQL "Use PostgreSQL for storage and authentication" off \
LDAP "Use LDAP for authentication" off \
BDB "Use BDB for storage and authentication" off \
PAM "Use PAM for authentication" off \
+ PIPE "Enable pipe auth/reg support" off \
DEBUG "Compile with debug information" on
GNU_CONFIGURE= yes
@@ -78,6 +79,10 @@ CONFIGURE_ARGS+=--enable-pam
CONFIGURE_ARGS+=--disable-pam
.endif
+.if defined(WITH_PIPE)
+CONFIGURE_ARGS+=--enable-pipe
+.endif
+
MAN8= c2s.8 jabberd.8 resolver.8 router.8 s2s.8 sm.8
pre-install: