aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ripit-atapi/Makefile27
-rw-r--r--audio/ripit-atapi/distinfo1
-rw-r--r--audio/ripit-atapi/files/patch-aa82
-rw-r--r--audio/ripit-atapi/pkg-comment1
-rw-r--r--audio/ripit-atapi/pkg-descr17
-rw-r--r--audio/ripit-atapi/pkg-plist1
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-ApacheDBILogConfig/Makefile2
-rw-r--r--databases/p5-ApacheDBILogger/Makefile2
10 files changed, 2 insertions, 133 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 703c2a26d778..b63ec610cdc5 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -120,7 +120,6 @@
SUBDIR += rio500
SUBDIR += ripenc
SUBDIR += ripit
- SUBDIR += ripit-atapi
SUBDIR += rosegarden
SUBDIR += rplay
SUBDIR += rsynth
diff --git a/audio/ripit-atapi/Makefile b/audio/ripit-atapi/Makefile
deleted file mode 100644
index 5970fb45e748..000000000000
--- a/audio/ripit-atapi/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# New ports collection makefile for: ripit-atapi
-# Date created: 9 Sep 1999
-# Whom: Donald Burr <dburr@FreeBSD.ORG>
-#
-# $FreeBSD$
-#
-
-PORTNAME= ripit-atapi
-PORTVERSION= 1.5
-CATEGORIES= audio
-MASTER_SITES= http://www.initio.no/~oyvindmo/distfiles/
-DISTNAME= ripit-1.5
-
-MAINTAINER= dburr@FreeBSD.ORG
-
-RUN_DEPENDS= bladeenc:${PORTSDIR}/audio/bladeenc \
- cdd:${PORTSDIR}/audio/cdd \
- cda:${PORTSDIR}/audio/xmcd \
- sox:${PORTSDIR}/audio/sox
-
-NO_BUILD= yes
-USE_PERL5= yes
-
-do-install:
- @ ${INSTALL_SCRIPT} ${WRKSRC}/ripit.pl ${PREFIX}/bin
-
-.include <bsd.port.mk>
diff --git a/audio/ripit-atapi/distinfo b/audio/ripit-atapi/distinfo
deleted file mode 100644
index a9d1946ff0e5..000000000000
--- a/audio/ripit-atapi/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (ripit-1.5.tar.gz) = ad796d63c258a68de7edc800bfc67e9b
diff --git a/audio/ripit-atapi/files/patch-aa b/audio/ripit-atapi/files/patch-aa
deleted file mode 100644
index e057ae18d8dc..000000000000
--- a/audio/ripit-atapi/files/patch-aa
+++ /dev/null
@@ -1,82 +0,0 @@
---- ripit.pl.old Thu Sep 9 02:26:37 1999
-+++ ripit.pl Thu Sep 9 02:28:45 1999
-@@ -18,6 +18,11 @@
- # --device - CDROM device to rip from
- #
- # Version 1.5 01/08/99 - Simon Quinn
-+# Version 1.5db 09/09/99 - Donald Burr <dburr@pobox.com>
-+# Modified to use cdd instead of tosha, for those of us
-+# (unfortunate enough) who have ATAPI/IDE CD-ROMs. Tested
-+# on FreeBSD with the FreeBSD cdd port (/usr/ports/audio/cdd),
-+# YMMV if you are using a different OS.
- #
- # Usage: ripit.pl [--halt] [--bitrate rate]
- # [--year year] [--device cddevice] [start_track]
-@@ -26,10 +31,12 @@
- # User configurable variables
- #
-
--$cddev = "/dev/cdrom"; # CD Audio device
--$outputdir = "/dosc/cdrip/"; # Where the MP3s should go
-+# Note: devices must be specified this way (strip the leading '/dev/'
-+# and the trailing partition letter) because this is the way cdd wants it.
-+$cddev = "acd1"; # CD Audio device
-+$outputdir = "/home/mp3/"; # Where the MP3s should go
- $bitrate = 160; # Bitrate for MP3s
--$encoder = 1; # 0 - Bladeenc, 1 - Lame
-+$encoder = 0; # 0 - Bladeenc, 1 - Lame
-
- $use_underscore = 0; # Use _ instead of spaces in filenames (1 yes, 0 no)
-
-@@ -44,7 +51,7 @@
-
- #######################################################################
- # No User configurable parameters below here
--#######################################################################
-+######################################################################
-
- require "flush.pl";
- use Getopt::Long;
-@@ -173,9 +180,9 @@
-
- system("rm $tocfile >/dev/null 2>&1");
-
-- system("cda -dev $cddev on >/dev/null 2>&1") ;
-- system("cda -dev $cddev toc >$tocfile") ;
-- system("cda -dev $cddev off >/dev/null 2>&1") ;
-+ system("cda -dev /dev/r${cddev}c on >/dev/null 2>&1") ;
-+ system("cda -dev /dev/r${cddev}c toc >$tocfile") ;
-+ system("cda -dev /dev/r${cddev}c off >/dev/null 2>&1") ;
-
- if ( ! -r $tocfile ) { die "$tocfile is missing"; }
- }
-@@ -327,16 +334,14 @@
- $riptrackname = &get_trackname($_, $tracklist[$_ - 1]);
- $riptrackno = $_;
-
-+ print "Ripping track $tracklist[$_ - 1]...\n";
- &printflush(RIPLOG,"Ripping $tracklist[$_ - 1]...\n");
-
-- if (system("cdparanoia -d $cddev $riptrackno \"$riptrackname.rip\"")) {
-- &printflush(RIPLOG,"cdparanoia failed on $tracklist[$_ - 1]\n");
-- die "cdparanoia failed on $tracklist[$_ - 1]";
-+ if (system("cdd -t $riptrackno -q -f $cddev - 2>/dev/null | sox -t cdr - \"$riptrackname.wav\"")) {
-+ &printflush(RIPLOG,"cdd failed on $tracklist[$_ - 1]\n");
-+ die "cdd failed on $tracklist[$_ - 1]";
- }
-
-- # Rename rip file to a wav for encoder
-- rename "$riptrackname.rip","$riptrackname.wav";
--
- &printflush(RIPLOG,"Rip complete $tracklist[$_ - 1]\n");
-
- # Start the Encoder in the background. but only once
-@@ -367,7 +372,7 @@
- print "\nMP3 Encoding track ".$ncount." of ".($#seltrack + 1)."\n";
- &printflush(RIPLOG,"Encoding $tracklist[$_ - 1]...\n");
-
-- # Keep looping until the file appears, ie wait for cdparanoia
-+ # Keep looping until the file appears, ie wait for cdd
- # timeout after 30 minutes
- $x=0;
- while( ! -r "$riptrackname.wav" ){
diff --git a/audio/ripit-atapi/pkg-comment b/audio/ripit-atapi/pkg-comment
deleted file mode 100644
index 4eecfbf3a74a..000000000000
--- a/audio/ripit-atapi/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A perl-script frontend for encoding audio CDs to MP3 files (ATAPI)
diff --git a/audio/ripit-atapi/pkg-descr b/audio/ripit-atapi/pkg-descr
deleted file mode 100644
index 1f9ab1a4a6c5..000000000000
--- a/audio/ripit-atapi/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-ripit
------
-
-ripit is a small front-end program written in perl for ripping,
-encoding & tagging MP3s. It is a console program that needs no user
-intervention. It requires cdd, bladeenc and xmcd (for CDDB access).
-
-WWW: http://www.netcomuk.co.uk/~squinn/ripit.html
-
-This version has been modified from the original 'ripit' port to use
-CDD (/usr/ports/audio/cdd) to rip the tracks, for those of us (unfortunate
-enough) who own ATAPI CD-ROM drives.
-
-Note: This port also requires sox, the SOund eXchanger (/usr/ports/audio/sox)
-as part of the ripping process.
---
-Port by Donald Burr <dburr@FreeBSD.ORG>
diff --git a/audio/ripit-atapi/pkg-plist b/audio/ripit-atapi/pkg-plist
deleted file mode 100644
index cd38f19aa1f6..000000000000
--- a/audio/ripit-atapi/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/ripit.pl
diff --git a/databases/Makefile b/databases/Makefile
index fc6d9e7f4f4d..5d10de646589 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -32,7 +32,6 @@
SUBDIR += mysql323-server
SUBDIR += mysqltcl
SUBDIR += mytop
- SUBDIR += p5-ApacheDBI
SUBDIR += p5-ApacheDBILogConfig
SUBDIR += p5-ApacheDBILogger
SUBDIR += p5-DBD-CSV
diff --git a/databases/p5-ApacheDBILogConfig/Makefile b/databases/p5-ApacheDBILogConfig/Makefile
index b9cdde74caf5..4a8ecf132496 100644
--- a/databases/p5-ApacheDBILogConfig/Makefile
+++ b/databases/p5-ApacheDBILogConfig/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dburr@FreeBSD.ORG
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/Apache/DBI.pm:${PORTSDIR}/databases/p5-ApacheDBI \
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
diff --git a/databases/p5-ApacheDBILogger/Makefile b/databases/p5-ApacheDBILogger/Makefile
index 27577cd28dc2..779613a1679c 100644
--- a/databases/p5-ApacheDBILogger/Makefile
+++ b/databases/p5-ApacheDBILogger/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dburr@FreeBSD.ORG
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/Apache/DBI.pm:${PORTSDIR}/databases/p5-ApacheDBI \
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl