aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/Makefile1
-rw-r--r--biology/mummer/Makefile43
-rw-r--r--biology/mummer/distinfo3
-rw-r--r--biology/mummer/pkg-descr6
-rw-r--r--biology/mummer/pkg-plist26
5 files changed, 79 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 6625014fe476..9cc884558da2 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -46,6 +46,7 @@
SUBDIR += migrate
SUBDIR += molden
SUBDIR += mopac
+ SUBDIR += mummer
SUBDIR += nab
SUBDIR += ncbi-toolkit
SUBDIR += ortep3
diff --git a/biology/mummer/Makefile b/biology/mummer/Makefile
new file mode 100644
index 000000000000..0b7a065c9eb7
--- /dev/null
+++ b/biology/mummer/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# New ports collection makefile for: MUMmer
+# Date created: 20 November 2007
+# Whom: Tony Maher
+#
+# $FreeBSD$
+#
+
+PORTNAME= mummer
+PORTVERSION= 3.20
+CATEGORIES= biology
+MASTER_SITES= SF
+DISTNAME= MUMmer${PORTVERSION}
+
+MAINTAINER= Anthony.Maher@uts.edu.au
+COMMENT= A modular system for rapid whole genome alignment
+
+USE_GMAKE= yes
+
+PROGRAMS= annotate combineMUMs delta-filter gaps \
+ mgaps mummer repeat-match show-aligns \
+ show-coords show-diff show-snps show-tiling
+SCRIPTS= dnadiff exact-tandems mapview mummerplot nucmer \
+ nucmer2xfig promer run-mummer1 run-mummer3
+DOCUMENTS= COPYRIGHT INSTALL LICENSE README
+
+do-install:
+.for program in ${PROGRAMS}
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${program} ${PREFIX}/bin)
+.endfor
+
+.for script in ${SCRIPTS}
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} ${script} ${PREFIX}/bin)
+.endfor
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOCUMENTS}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${doc} ${DOCSDIR})
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/biology/mummer/distinfo b/biology/mummer/distinfo
new file mode 100644
index 000000000000..ef9cc2f7db58
--- /dev/null
+++ b/biology/mummer/distinfo
@@ -0,0 +1,3 @@
+MD5 (MUMmer3.20.tar.gz) = 4c3f6e528df50f8dfd3a7cd0ea224306
+SHA256 (MUMmer3.20.tar.gz) = 9c7880b4ce25ef3c6bed9ccdc26f1c4d7e74eb0ef1ce403907790c0f96c0f260
+SIZE (MUMmer3.20.tar.gz) = 3155446
diff --git a/biology/mummer/pkg-descr b/biology/mummer/pkg-descr
new file mode 100644
index 000000000000..61b5d007a15f
--- /dev/null
+++ b/biology/mummer/pkg-descr
@@ -0,0 +1,6 @@
+MUMmer is a modular system for the rapid whole genome alignment of finished
+or draft sequence. This package provides an efficient suffix tree library,
+seed-and-extend alignment, SNP detection, repeat detection, and
+visualization tools.
+
+WWW: http://mummer.sourceforge.net/
diff --git a/biology/mummer/pkg-plist b/biology/mummer/pkg-plist
new file mode 100644
index 000000000000..d569fa3bba7e
--- /dev/null
+++ b/biology/mummer/pkg-plist
@@ -0,0 +1,26 @@
+bin/annotate
+bin/combineMUMs
+bin/delta-filter
+bin/dnadiff
+bin/exact-tandems
+bin/gaps
+bin/mapview
+bin/mgaps
+bin/mummer
+bin/mummerplot
+bin/nucmer
+bin/nucmer2xfig
+bin/promer
+bin/repeat-match
+bin/run-mummer1
+bin/run-mummer3
+bin/show-aligns
+bin/show-coords
+bin/show-diff
+bin/show-snps
+bin/show-tiling
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%