aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/dspam-devel/Makefile11
-rw-r--r--mail/dspam-devel/distinfo4
-rw-r--r--mail/dspam-devel/files/UPDATING28
3 files changed, 38 insertions, 5 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 032b8d8971d5..48e06154b27e 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -16,7 +16,7 @@ COMMENT= Bayesian spam filter - development version
WRKSRC= ${WRKDIR}/dspam-cvs-devel${SNAP_DATE}
-SNAP_DATE= .20041125.0945
+SNAP_DATE= .20041201.1330
PORTVER_MAJ= 3.3.0.a
## debug / log / admin options
@@ -27,6 +27,7 @@ OPTIONS+= VERBOSE_DEBUG "Enable debug in LOGDIR/dspam.debug" off
#OPTIONS+= SAT "Log spam source addresses to syslog" on
#OPTIONS+= PARSE_TO_HEADERS "Get user from To header on fp spam" off
OPTIONS+= PREF_EXT "Preferences in database not in files" off
+OPTIONS+= DAEMON "Daemonize dspam; speak LMTP; EXPERIMENTAL" off
## algorithm options
OPTIONS+= GRAHAM_BAYES "Enable Graham (traditional) bayesian" on
OPTIONS+= BURTON_BAYES "Enable Burton (alternative) bayesian" on
@@ -162,10 +163,14 @@ CONFIGURE_ARGS+= --enable-verbose-debug
#CONFIGURE_ARGS+= --enable-parse-to-headers
#.endif
-.if defined(PREF_EXT)
+.if defined(WITH_PREF_EXT)
CONFIGURE_ARGS+= --enable-preferences-extension
.endif
+.ifdef(WITH_DAEMON)
+CONFIGURE_ARGS+= --enable-daemon
+.endif
+
.if !defined(WITH_GRAHAM_BAYES)
CONFIGURE_ARGS+= --disable-traditional-bayesian
.endif
@@ -315,7 +320,7 @@ CONFIGURE_ARGS+= --with-storage-driver=ora_drv \
DBDRV_COUNT:= ${DBDRV_COUNT:S/o//}
.endif
-.if defined(WITH_BDB)
+.if defined(WITH_BDB4)
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
CONFIGURE_ARGS+= --with-storage-driver=libdb4_drv \
--with-db4-includes=${LOCALBASE}/include/db41
diff --git a/mail/dspam-devel/distinfo b/mail/dspam-devel/distinfo
index c12de3a256d8..a3fd93ea53f9 100644
--- a/mail/dspam-devel/distinfo
+++ b/mail/dspam-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (dspam-devel.3.3.0.a.20041125.0945.tar.gz) = 91bcb96a4b42c14413c7a2b70603f0fb
-SIZE (dspam-devel.3.3.0.a.20041125.0945.tar.gz) = 624972
+MD5 (dspam-devel.3.3.0.a.20041201.1330.tar.gz) = aa5c742f12e9ada86d94af49f56b5ce3
+SIZE (dspam-devel.3.3.0.a.20041201.1330.tar.gz) = 626853
diff --git a/mail/dspam-devel/files/UPDATING b/mail/dspam-devel/files/UPDATING
index 92af4fb7c7c5..245461acf5f3 100644
--- a/mail/dspam-devel/files/UPDATING
+++ b/mail/dspam-devel/files/UPDATING
@@ -12,6 +12,34 @@ make extract; more `find . -type f -maxdepth 2 -name UPGRADING`
############################################################################
+# dspam-devel-3.3.0.a.20041201.1330
+#
+
+Say hello to the daemonized dspam! Enable it at compile-time with DAEMON option.
+
+- it speaks LMTP:
+LHLO
+MAIL FROM: [password]@[server id]
+RCPT TO: [list of DSPAM users] [DSPAM parameters] [delivery agent parameters]
+DATA
+[message]
+.
+
+- daemon processes *and* delivers at the moment (including to stdout).
+- For client-side delivery, use --stdout and configure your MTA to deliver.
+- it may be necessary to perform all delivery in the client, as using fork &&
+ pipe in a MT app may be bad
+- implemented multiple responses per recipient
+- changed storage driver layer to use a driver context (for caching connections)
+- stateful db connections done for mysql driver
+- to do next: client
+
+- remember that all this is experimental and it may change at any time.
+
+- fix PREX_EXT and BDB4 handling in the port Makefile to really enable them.
+
+
+############################################################################
# dspam-devel-3.3.0.a.20041125.0945
#