aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/dnsmasq/Makefile1
-rw-r--r--dns/dnsmasq/files/patch-src_cache.c11
-rw-r--r--dns/dnsmasq/files/patch-src_option.c23
3 files changed, 35 insertions, 0 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index a477e1876c04..1473d6ec7f8a 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dnsmasq
DISTVERSION= 2.75
+PORTREVISION= 1 # leave this in even if 0 to avoid PORTEPOCH bumps
PORTEPOCH= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/ \
diff --git a/dns/dnsmasq/files/patch-src_cache.c b/dns/dnsmasq/files/patch-src_cache.c
new file mode 100644
index 000000000000..2c0b026a0712
--- /dev/null
+++ b/dns/dnsmasq/files/patch-src_cache.c
@@ -0,0 +1,11 @@
+--- src/cache.c.orig 2015-07-30 19:59:07 UTC
++++ src/cache.c
+@@ -481,7 +481,7 @@ struct crec *cache_insert(char *name, st
+ existing record is for an A or AAAA and
+ the record we're trying to insert is the same,
+ just drop the insert, but don't error the whole process. */
+- if ((flags & (F_IPV4 | F_IPV6)) && (flags & F_FORWARD))
++ if ((flags & (F_IPV4 | F_IPV6)) && (flags & F_FORWARD) && addr)
+ {
+ if ((flags & F_IPV4) && (new->flags & F_IPV4) &&
+ new->addr.addr.addr.addr4.s_addr == addr->addr.addr4.s_addr)
diff --git a/dns/dnsmasq/files/patch-src_option.c b/dns/dnsmasq/files/patch-src_option.c
new file mode 100644
index 000000000000..91cbd33d4a6d
--- /dev/null
+++ b/dns/dnsmasq/files/patch-src_option.c
@@ -0,0 +1,23 @@
+--- src/option.c.orig 2015-07-30 19:59:07 UTC
++++ src/option.c
+@@ -1501,10 +1501,16 @@ static int one_opt(int option, char *arg
+ li = opt_malloc(sizeof(struct list));
+ if (*arg == '*')
+ {
+- li->next = match_suffix;
+- match_suffix = li;
+- /* Have to copy: buffer is overwritten */
+- li->suffix = opt_string_alloc(arg+1);
++ /* "*" with no suffix is a no-op */
++ if (arg[1] == 0)
++ free(li);
++ else
++ {
++ li->next = match_suffix;
++ match_suffix = li;
++ /* Have to copy: buffer is overwritten */
++ li->suffix = opt_string_alloc(arg+1);
++ }
+ }
+ else
+ {