aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/tcpdump/Makefile34
-rw-r--r--net/tcpdump/distinfo1
-rw-r--r--net/tcpdump/pkg-descr9
-rw-r--r--net/tcpdump/pkg-plist1
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 761af3a57f8b..757ec2d06c0f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -672,6 +672,7 @@
SUBDIR += tas
SUBDIR += tcpcat
SUBDIR += tcpdstat
+ SUBDIR += tcpdump
SUBDIR += tcpflow
SUBDIR += tcpillust
SUBDIR += tcpmssd
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
new file mode 100644
index 000000000000..509f8e395a39
--- /dev/null
+++ b/net/tcpdump/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: tcpdump
+# Date created: 10 December 2003
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpdump
+PORTVERSION= 3.8.1
+CATEGORIES= net
+MASTER_SITES= http://www.tcpdump.org/beta/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-316
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Ubiquitous network traffic analysis tool
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= tcpdump.1
+
+GNU_CONFIGURE= yes
+
+
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+.if defined(WITHOUT_CRYPTO)
+CONFIGURE_ARGS+= --without-crypto
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/tcpdump/distinfo b/net/tcpdump/distinfo
new file mode 100644
index 000000000000..05b49cfaac10
--- /dev/null
+++ b/net/tcpdump/distinfo
@@ -0,0 +1 @@
+MD5 (tcpdump-3.8.1-316.tar.gz) = 7149aeee925a4b05ac9d07aed3beb546
diff --git a/net/tcpdump/pkg-descr b/net/tcpdump/pkg-descr
new file mode 100644
index 000000000000..b2696651c3ec
--- /dev/null
+++ b/net/tcpdump/pkg-descr
@@ -0,0 +1,9 @@
+tcpdump is a ubiquitous network traffic capture tool available in a wide
+variety of BSD, Linux and UN*X distributions.
+
+Whilst FreeBSD has a vendor branch import of tcpdump in its source tree,
+the purpose of the port is to provide a means of offering additional,
+bleeding-edge features which might not make it into the tree.
+
+Bruce
+bms@FreeBSD.org
diff --git a/net/tcpdump/pkg-plist b/net/tcpdump/pkg-plist
new file mode 100644
index 000000000000..9b3c0b6e6bcb
--- /dev/null
+++ b/net/tcpdump/pkg-plist
@@ -0,0 +1 @@
+sbin/tcpdump