aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/PDL/Makefile27
-rw-r--r--math/PDL/distinfo4
-rw-r--r--math/PDL/files/patch-mconf.h13
-rw-r--r--math/PDL/files/patch-perldl.conf20
4 files changed, 16 insertions, 48 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index e518bda271d8..d6a0c1fc94b0 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= PDL
-PORTVERSION= 2.4.9
-PORTREVISION= 2
+PORTVERSION= 2.4.11
CATEGORIES= math perl5
MASTER_SITES= CPAN/${PORTNAME}:cpan \
SF/pdl/PDL/${PORTVERSION}:sf
@@ -18,10 +17,9 @@ COMMENT= Perl Data Language
BUILD_DEPENDS= p5-Astro-FITS-Header>=0:${PORTSDIR}/astro/p5-Astro-FITS-Header \
p5-Convert-UU>=0:${PORTSDIR}/converters/p5-Convert-UU \
+ p5-File-Map>=0.47:${PORTSDIR}/devel/p5-File-Map \
p5-Inline>=0.43:${PORTSDIR}/devel/p5-Inline
-RUN_DEPENDS= p5-Astro-FITS-Header>=0:${PORTSDIR}/astro/p5-Astro-FITS-Header \
- p5-Convert-UU>=0:${PORTSDIR}/converters/p5-Convert-UU \
- p5-Inline>=0.43:${PORTSDIR}/devel/p5-Inline
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
USE_GMAKE= yes
@@ -54,12 +52,12 @@ BUILD_DEPENDS+= p5-PGPLOT>=0:${PORTSDIR}/graphics/p5-PGPLOT
.endif
.if ${PORT_OPTIONS:MPLPLOT}
-LIB_DEPENDS+= plplotd.11:${PORTSDIR}/math/plplot
+LIB_DEPENDS+= plplotd:${PORTSDIR}/math/plplot
.endif
.if ${PORT_OPTIONS:MOPENGL}
-BUILD_DEPENDS+= p5-OpenGL>=0.60:${PORTSDIR}/graphics/p5-OpenGL
-RUN_DEPENDS+= p5-OpenGL>=0.60:${PORTSDIR}/graphics/p5-OpenGL
+BUILD_DEPENDS+= p5-OpenGL>=0.65:${PORTSDIR}/graphics/p5-OpenGL
+RUN_DEPENDS+= p5-OpenGL>=0.65:${PORTSDIR}/graphics/p5-OpenGL
USE_GL= yes
.endif
@@ -72,7 +70,7 @@ BUILD_DEPENDS+= p5-ExtUtils-F77>=0:${PORTSDIR}/lang/p5-ExtUtils-F77
.endif
.if ${PORT_OPTIONS:MFFTW}
-LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
+LIB_DEPENDS+= fftw:${PORTSDIR}/math/fftw
.endif
.if ${PORT_OPTIONS:MGSL}
@@ -100,10 +98,13 @@ RUN_DEPENDS+= ppmtogif:${PORTSDIR}/graphics/netpbm \
.endif
post-patch:
- @${GREP} -lR "/usr/local/bin/perl" ${WRKSRC} | ${XARGS} \
- ${PERL} -pi -e "s!/usr/local/bin/perl!${PERL}!"
- @${GREP} -lR "x86_64" ${WRKSRC} | ${XARGS} \
- ${PERL} -pi -e "s!x86_64!amd64!"
+ @${GREP} -lR '#!/usr/local/bin/perl' ${WRKSRC}/ | ${XARGS} ${SED} -e 's|#!/usr/local/bin/perl|#!${PERL}|' -i ''
+ @${GREP} -lR 'x86_64' ${WRKSRC}/ | ${XARGS} ${SED} -e 's|x86_64|amd64|g' -i ''
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|' ${WRKSRC}/perldl.conf
+ @${REINPLACE_CMD} -e "/POSIX_THREADS_LIBS/ s|undef|'${PTHREAD_LIBS}'|" \
+ -e '/WITH_IO_BROWSER/ s|0|1|' -e '/WITH_DEVEL_REPL/ s|1|0|' ${WRKSRC}/perldl.conf
+ @${REINPLACE_CMD} -e '/^#include <nan.h>/d' ${WRKSRC}/Basic/Math/mconf.h
+ @${REINPLACE_CMD} -e '/^require PDL::Core::Dev;/d' ${WRKSRC}/IO/Browser/Makefile.PL
test: build
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} make test
diff --git a/math/PDL/distinfo b/math/PDL/distinfo
index 2f4fa91fc3a6..efa9d99cab30 100644
--- a/math/PDL/distinfo
+++ b/math/PDL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PDL-2.4.9.tar.gz) = b67667294ec86bd94a34d17069dcca5cc8e773b57c333162ee6a9c0786b82210
-SIZE (PDL-2.4.9.tar.gz) = 2640318
+SHA256 (PDL-2.4.11.tar.gz) = c777ed2519d73ebde0d870e94931a2d2c57865abcee27dfec53f4412a2cac662
+SIZE (PDL-2.4.11.tar.gz) = 2859537
diff --git a/math/PDL/files/patch-mconf.h b/math/PDL/files/patch-mconf.h
deleted file mode 100644
index c00a9f7b5dcb..000000000000
--- a/math/PDL/files/patch-mconf.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- Basic/Math/mconf.h.orig 2010-05-08 21:43:08.000000000 -0500
-+++ Basic/Math/mconf.h 2011-03-19 17:12:01.099417176 -0500
-@@ -89,8 +89,10 @@ Copyright 1984, 1987, 1989, 1995 by Step
- #endif
- #if defined __alpha && ! defined __linux
- #include <float.h>
-+#ifndef __FreeBSD__
- #include <nan.h>
- #endif
-+#endif
- #ifndef NANARG
- #define NANARG
- #endif
diff --git a/math/PDL/files/patch-perldl.conf b/math/PDL/files/patch-perldl.conf
deleted file mode 100644
index 4da2214b2fe0..000000000000
--- a/math/PDL/files/patch-perldl.conf
+++ /dev/null
@@ -1,20 +0,0 @@
---- perldl.conf.orig 2010-08-15 12:38:21.000000000 -0500
-+++ perldl.conf 2011-03-19 19:07:04.854128623 -0500
-@@ -229,7 +229,7 @@
- # Do we build PDL::IO::Browser?
- # default -> do not build (module needs to be updated)
- #
-- WITH_IO_BROWSER => 0,
-+ WITH_IO_BROWSER => 1,
-
- # Quiet Astro::FITS::Header warnings for PDL build process by default
- # Eventually would be better to set undef by default, and have the
-@@ -246,7 +246,7 @@
- # false -> don't install pdl2 support
- # true -> force pdl2 install (default)
-
-- WITH_DEVEL_REPL => 1,
-+ WITH_DEVEL_REPL => 0,
-
- # Set this for official CPAN releases of PDL since these
- # tests will always fail until they are fixed. It can also