aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/p5-Crypt-AppleTwoFish/Makefile8
-rw-r--r--security/p5-Crypt-CFB/Makefile6
-rw-r--r--security/p5-Crypt-Caesar/Makefile6
-rw-r--r--security/p5-Crypt-Chimera/Makefile6
-rw-r--r--security/p5-Crypt-DES_PP/Makefile6
-rw-r--r--security/p5-Crypt-Enigma/Makefile6
-rw-r--r--security/p5-Crypt-GOST_PP/Makefile6
-rw-r--r--security/p5-Crypt-HCE_MD5/Makefile6
-rw-r--r--security/p5-Crypt-Khazad/Makefile13
-rw-r--r--security/p5-Crypt-Khazad/files/extrapatch-Khazad.xs18
-rw-r--r--security/p5-Crypt-Loki97/Makefile13
-rw-r--r--security/p5-Crypt-Loki97/files/extrapatch-Loki97.xs18
-rw-r--r--security/p5-Crypt-MySQL/Makefile6
-rw-r--r--security/p5-Crypt-Rabbit/Makefile12
-rw-r--r--security/p5-Crypt-Rabbit/files/extrapatch-Rabbit.xs18
-rw-r--r--security/p5-Crypt-Shark/Makefile13
-rw-r--r--security/p5-Crypt-Shark/files/extrapatch-Shark.xs18
-rw-r--r--security/p5-Crypt-X509/Makefile8
18 files changed, 135 insertions, 52 deletions
diff --git a/security/p5-Crypt-AppleTwoFish/Makefile b/security/p5-Crypt-AppleTwoFish/Makefile
index 26f4f6877abd..1f08fcd6b62c 100644
--- a/security/p5-Crypt-AppleTwoFish/Makefile
+++ b/security/p5-Crypt-AppleTwoFish/Makefile
@@ -18,7 +18,11 @@ PERL_CONFIGURE= yes
MAN3= Crypt::AppleTwoFish.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+
+.if ${PERL_LEVEL} < 500800
+post-patch:
+ ${PERL} -pi -e '$$_="" if m{5.008|warnings}' ${WRKSRC}/t/*.t \
+ ${WRKSRC}/lib/Crypt/AppleTwoFish.pm ${WRKSRC}/${CONFIGURE_SCRIPT}
.endif
+
.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-CFB/Makefile b/security/p5-Crypt-CFB/Makefile
index 5a0c6bc9ec9a..19ce0b6c4922 100644
--- a/security/p5-Crypt-CFB/Makefile
+++ b/security/p5-Crypt-CFB/Makefile
@@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::CFB.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Caesar/Makefile b/security/p5-Crypt-Caesar/Makefile
index b313821e23cd..764cb1590efc 100644
--- a/security/p5-Crypt-Caesar/Makefile
+++ b/security/p5-Crypt-Caesar/Makefile
@@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Caesar.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Chimera/Makefile b/security/p5-Crypt-Chimera/Makefile
index 75f6a80c4228..dfd9e261dd4b 100644
--- a/security/p5-Crypt-Chimera/Makefile
+++ b/security/p5-Crypt-Chimera/Makefile
@@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Chimera.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-DES_PP/Makefile b/security/p5-Crypt-DES_PP/Makefile
index eb801a09cbf7..3c3c67afa868 100644
--- a/security/p5-Crypt-DES_PP/Makefile
+++ b/security/p5-Crypt-DES_PP/Makefile
@@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::DES_PP.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Enigma/Makefile b/security/p5-Crypt-Enigma/Makefile
index 088a12a1c01f..b0b5a6356838 100644
--- a/security/p5-Crypt-Enigma/Makefile
+++ b/security/p5-Crypt-Enigma/Makefile
@@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Enigma.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-GOST_PP/Makefile b/security/p5-Crypt-GOST_PP/Makefile
index ca31963d841a..06b149e35b74 100644
--- a/security/p5-Crypt-GOST_PP/Makefile
+++ b/security/p5-Crypt-GOST_PP/Makefile
@@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::GOST_PP.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-HCE_MD5/Makefile b/security/p5-Crypt-HCE_MD5/Makefile
index b0252f102159..be733ee06c4e 100644
--- a/security/p5-Crypt-HCE_MD5/Makefile
+++ b/security/p5-Crypt-HCE_MD5/Makefile
@@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::HCE_MD5.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Khazad/Makefile b/security/p5-Crypt-Khazad/Makefile
index eba084670386..09635ac0bf08 100644
--- a/security/p5-Crypt-Khazad/Makefile
+++ b/security/p5-Crypt-Khazad/Makefile
@@ -18,7 +18,16 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Khazad.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Khazad.xs
+
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Khazad.pm
+ ${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Khazad.pm ${WRKSRC}/t/*.t
+ ${PERL} -pi -e 's/void/int argc, char**argv, char**env/ if m{int main}' ${WRKSRC}/_khazad.c
.endif
+
.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Khazad/files/extrapatch-Khazad.xs b/security/p5-Crypt-Khazad/files/extrapatch-Khazad.xs
new file mode 100644
index 000000000000..b7c12bca7356
--- /dev/null
+++ b/security/p5-Crypt-Khazad/files/extrapatch-Khazad.xs
@@ -0,0 +1,18 @@
+--- Khazad.xs.orig Sat Dec 31 02:51:21 2005
++++ Khazad.xs Sat Dec 31 02:51:56 2005
+@@ -4,6 +4,15 @@
+ #include "ppport.h"
+ #include "_khazad.c"
+
++/* try to be compatible with older perls */
++/* SvPV_nolen() macro first defined in 5.005_55 */
++/* this is slow, not threadsafe, but works */
++#include "patchlevel.h"
++#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
++static STRLEN nolen_na;
++# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
++#endif
++
+ typedef struct khazad {
+ NESSIEstruct key;
+ }* Crypt__Khazad;
diff --git a/security/p5-Crypt-Loki97/Makefile b/security/p5-Crypt-Loki97/Makefile
index bdff16b7bcd4..9a98cc479471 100644
--- a/security/p5-Crypt-Loki97/Makefile
+++ b/security/p5-Crypt-Loki97/Makefile
@@ -18,7 +18,16 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Loki97.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Loki97.xs
+
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Loki97.pm
+ ${PERL} -pi -e 's/void/int argc, char**argv, char**env/ if m{int main}' ${WRKSRC}/_loki97.c
+ ${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Loki97.pm ${WRKSRC}/t/*.t
.endif
+
.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Loki97/files/extrapatch-Loki97.xs b/security/p5-Crypt-Loki97/files/extrapatch-Loki97.xs
new file mode 100644
index 000000000000..f2e7f9ebb40c
--- /dev/null
+++ b/security/p5-Crypt-Loki97/files/extrapatch-Loki97.xs
@@ -0,0 +1,18 @@
+--- Loki97.xs.orig Sat Dec 31 03:04:38 2005
++++ Loki97.xs Sat Dec 31 03:05:06 2005
+@@ -4,6 +4,15 @@
+ #include "ppport.h"
+ #include "_loki97.c"
+
++/* try to be compatible with older perls */
++/* SvPV_nolen() macro first defined in 5.005_55 */
++/* this is slow, not threadsafe, but works */
++#include "patchlevel.h"
++#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
++static STRLEN nolen_na;
++# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
++#endif
++
+ typedef struct loki97 {
+ keyInstance enc_key, dec_key;
+ cipherInstance cipher;
diff --git a/security/p5-Crypt-MySQL/Makefile b/security/p5-Crypt-MySQL/Makefile
index 39c229446fb7..7ef651bd57ae 100644
--- a/security/p5-Crypt-MySQL/Makefile
+++ b/security/p5-Crypt-MySQL/Makefile
@@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::MySQL.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Rabbit/Makefile b/security/p5-Crypt-Rabbit/Makefile
index e021749a99ee..6962cd42873c 100644
--- a/security/p5-Crypt-Rabbit/Makefile
+++ b/security/p5-Crypt-Rabbit/Makefile
@@ -18,7 +18,15 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Rabbit.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Rabbit.xs
+
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Rabbit.pm
+ ${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Rabbit.pm ${WRKSRC}/t/*.t
.endif
+
.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Rabbit/files/extrapatch-Rabbit.xs b/security/p5-Crypt-Rabbit/files/extrapatch-Rabbit.xs
new file mode 100644
index 000000000000..ccff81e7ae2f
--- /dev/null
+++ b/security/p5-Crypt-Rabbit/files/extrapatch-Rabbit.xs
@@ -0,0 +1,18 @@
+--- Rabbit.xs.orig Sat Dec 31 03:49:51 2005
++++ Rabbit.xs Sat Dec 31 03:50:13 2005
+@@ -4,6 +4,15 @@
+ #include "ppport.h"
+ #include "_rabbit.c"
+
++/* try to be compatible with older perls */
++/* SvPV_nolen() macro first defined in 5.005_55 */
++/* this is slow, not threadsafe, but works */
++#include "patchlevel.h"
++#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
++static STRLEN nolen_na;
++# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
++#endif
++
+ typedef struct rabbit {
+ t_instance state;
+ }* Crypt__Rabbit;
diff --git a/security/p5-Crypt-Shark/Makefile b/security/p5-Crypt-Shark/Makefile
index 8d3548140cb6..740b28c4d6ef 100644
--- a/security/p5-Crypt-Shark/Makefile
+++ b/security/p5-Crypt-Shark/Makefile
@@ -18,7 +18,16 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Shark.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Shark.xs
+
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Shark.pm
+ ${PERL} -pi -e 's/void/int argc, char**argv, char**env/ if m{int main}' ${WRKSRC}/_shark.c
+ ${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Shark.pm ${WRKSRC}/t/*.t
.endif
+
.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Shark/files/extrapatch-Shark.xs b/security/p5-Crypt-Shark/files/extrapatch-Shark.xs
new file mode 100644
index 000000000000..baec9dae7647
--- /dev/null
+++ b/security/p5-Crypt-Shark/files/extrapatch-Shark.xs
@@ -0,0 +1,18 @@
+--- Shark.xs.orig Sat Dec 31 04:10:06 2005
++++ Shark.xs Sat Dec 31 04:10:37 2005
+@@ -4,6 +4,15 @@
+ #include "ppport.h"
+ #include "_shark.c"
+
++/* try to be compatible with older perls */
++/* SvPV_nolen() macro first defined in 5.005_55 */
++/* this is slow, not threadsafe, but works */
++#include "patchlevel.h"
++#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
++static STRLEN nolen_na;
++# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
++#endif
++
+ typedef struct shark {
+ ddword roundkey_enc[14];
+ ddword roundkey_dec[14];
diff --git a/security/p5-Crypt-X509/Makefile b/security/p5-Crypt-X509/Makefile
index 8e3537671142..0f3434ef24ed 100644
--- a/security/p5-Crypt-X509/Makefile
+++ b/security/p5-Crypt-X509/Makefile
@@ -22,7 +22,11 @@ MAN3= Crypt::X509.3
WRKSRC= ${WRKDIR}/Crypt-X509
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/lib/Crypt/X509.pm
+ ${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/lib/Crypt/X509.pm
.endif
+
.include <bsd.port.post.mk>