aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/opera-devel/Makefile9
-rw-r--r--www/opera/Makefile9
2 files changed, 14 insertions, 4 deletions
diff --git a/www/opera-devel/Makefile b/www/opera-devel/Makefile
index 2c1f71ca9ac6..737daad827d2 100644
--- a/www/opera-devel/Makefile
+++ b/www/opera-devel/Makefile
@@ -15,7 +15,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/10./10-/}.1-static-qt.i386.freebsd
MAINTAINER= des@FreeBSD.org
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-LIB_DEPENDS= c_r.4:${PORTSDIR}/misc/compat4x
USE_BZIP2= yes
ONLY_FOR_ARCHS= i386
@@ -27,4 +26,10 @@ NO_FILTER_SHLIBS=yes
do-install:
(cd ${WRKSRC} && ${SH} install.sh --prefix="${PREFIX}")
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 2c1f71ca9ac6..737daad827d2 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -15,7 +15,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/10./10-/}.1-static-qt.i386.freebsd
MAINTAINER= des@FreeBSD.org
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-LIB_DEPENDS= c_r.4:${PORTSDIR}/misc/compat4x
USE_BZIP2= yes
ONLY_FOR_ARCHS= i386
@@ -27,4 +26,10 @@ NO_FILTER_SHLIBS=yes
do-install:
(cd ${WRKSRC} && ${SH} install.sh --prefix="${PREFIX}")
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
+.endif
+
+.include <bsd.port.post.mk>