aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/ntop/Makefile41
1 files changed, 9 insertions, 32 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index e09ba6ae743e..04dff5e3dc5c 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -50,44 +50,21 @@ XMLDUMP_DESC= Enable XML Dump support
JUMBO_FRAMES_DESC= Jumbo Frames (experimental)
MAKO_DESC= Install py-mako for Host Map, Region View
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPCAP_PORT}
-LIB_DEPENDS+= libpcap.so:${PORTSDIR}/net/libpcap
-CONFIGURE_ARGS+= --with-pcap-root=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --with-pcap-root=/usr
-.endif
-
-.if ${PORT_OPTIONS:MXMLDUMP}
-LIB_DEPENDS+= libgdome.so:${PORTSDIR}/textproc/gdome2
-CPPFLAGS+= -I${LOCALBASE}/include/libxml2 \
+PCAP_PORT_LIB_DEPENDS= libpcap.so.1:${PORTSDIR}/net/libpcap
+PCAP_PORT_CONFIGURE_ON= --with-pcap-root=${LOCALBASE}
+PCAP_PORT_CONFIGURE_OFF=--with-pcap-root=/usr
+
+XMLDUMP_LIB_DEPENDS= libgdome.so:${PORTSDIR}/textproc/gdome2
+XMLDUMP_CPPFLAGS= -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/libxml2/libxml \
-I${LOCALBASE}/include/libgdome \
-I${LOCALBASE}/include/glib-2.0
-.endif
-.if ${PORT_OPTIONS:MJUMBO_FRAMES}
-CONFIGURE_ARGS+= --enable-jumbo-frames
# should set your mtu to 9000
# see http://www.cyberciti.biz/faq/freebsd-jumbo-frames-networking-configration/
-.endif
-
-.if ${PORT_OPTIONS:MMAKO}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako
-.endif
-
-.include <bsd.port.pre.mk>
+JUMBO_FRAMES_CONFIGURE_ON= --enable-jumbo-frames
-# Quick and dirty hackaround - older binutils barf when asked to strip
-# an .a file, newer complain about missing sections and succeed.
-# The real fix would be for ntop to not try stripping .a files,
-# but upstream seems to have gone ahead with ntopng so this may not
-# ever be fixed.
-.if ${OSVERSION} < 900033
-USE_BINUTILS= yes
-CONFIGURE_ARGS+= STRIP=${LOCALBASE}/bin/strip
-.endif
+MAKO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako
pre-configure:
@(cd ${WRKSRC} && ./autogen.sh --noconfig)
@@ -98,4 +75,4 @@ pre-install:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ntop/plugins/*.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>