aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/mod_fcgid/Makefile2
-rw-r--r--www/mod_fcgid/distinfo6
-rw-r--r--www/mod_fcgid/files/patch-modules-fcgid-fcgid_mutex_unix.c17
-rw-r--r--www/mod_fcgid/files/patch-modules-fcgid-fcgid_spawn_ctl.c17
4 files changed, 21 insertions, 21 deletions
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index 965404c0ebc8..f067d2c4a1d7 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_fcgid
-PORTVERSION= 2.3.5
+PORTVERSION= 2.3.6
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/www/mod_fcgid/distinfo b/www/mod_fcgid/distinfo
index a7ec56c039b5..d90763ac5c78 100644
--- a/www/mod_fcgid/distinfo
+++ b/www/mod_fcgid/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_fcgid-2.3.5.tar.gz) = 82b5bec1ed1c0fc106d5271075641ef9
-SHA256 (mod_fcgid-2.3.5.tar.gz) = 3280fd287659539d577fc3c77a975739c06bb9d0a9cef48275d4beb13c64ef39
-SIZE (mod_fcgid-2.3.5.tar.gz) = 97784
+MD5 (mod_fcgid-2.3.6.tar.gz) = fbfc115eb47cd9bda91269743aba5e83
+SHA256 (mod_fcgid-2.3.6.tar.gz) = e831795498d91cf27a519ea1332c2a92a2a9920b0844d817b2ea7f079056d12b
+SIZE (mod_fcgid-2.3.6.tar.gz) = 101883
diff --git a/www/mod_fcgid/files/patch-modules-fcgid-fcgid_mutex_unix.c b/www/mod_fcgid/files/patch-modules-fcgid-fcgid_mutex_unix.c
deleted file mode 100644
index 630f11e67cb9..000000000000
--- a/www/mod_fcgid/files/patch-modules-fcgid-fcgid_mutex_unix.c
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: modules/fcgid/fcgid_mutex_unix.c
-===================================================================
---- modules/fcgid/fcgid_mutex_unix.c (revision 904780)
-+++ modules/fcgid/fcgid_mutex_unix.c (working copy)
-@@ -56,6 +56,10 @@
-
- #include "ap_mpm.h"
-
-+#if MODULE_MAGIC_NUMBER_MAJOR < 20051115
-+#define AP_NEED_SET_MUTEX_PERMS 1
-+#endif
-+
- #if AP_NEED_SET_MUTEX_PERMS
- #include "unixd.h"
- #endif
-
-
diff --git a/www/mod_fcgid/files/patch-modules-fcgid-fcgid_spawn_ctl.c b/www/mod_fcgid/files/patch-modules-fcgid-fcgid_spawn_ctl.c
new file mode 100644
index 000000000000..1b9304f6487c
--- /dev/null
+++ b/www/mod_fcgid/files/patch-modules-fcgid-fcgid_spawn_ctl.c
@@ -0,0 +1,17 @@
+#
+# Fix regression in 2.3.6 which broke process controls when using vhost-
+# specific configuration.
+#
+Index: modules/fcgid/fcgid_spawn_ctl.c
+===================================================================
+--- modules/fcgid/fcgid_spawn_ctl.c (revision 1037726)
++++ modules/fcgid/fcgid_spawn_ctl.c (revision 1037727)
+@@ -178,7 +178,7 @@
+ if (current_node->inode == command->inode
+ && current_node->deviceid == command->deviceid
+ && !strcmp(current_node->cmdline, command->cmdline)
+- && current_node->vhost_id == sconf->vhost_id
++ && current_node->vhost_id == command->vhost_id
+ && current_node->uid == command->uid
+ && current_node->gid == command->gid)
+ break;