aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/postgis/Makefile5
-rw-r--r--security/klamav/Makefile13
-rw-r--r--security/kovpn/Makefile6
-rw-r--r--security/tuntun/Makefile15
-rw-r--r--www/drupal6-chaos/Makefile8
-rw-r--r--www/drupal6-ckeditor/Makefile8
-rw-r--r--www/drupal6-content_access/Makefile8
-rw-r--r--www/drupal6-image/Makefile8
-rw-r--r--www/drupal6-imce/Makefile8
-rw-r--r--www/drupal6-panels/Makefile8
10 files changed, 25 insertions, 62 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index 73f1016c7216..ec7ea9cabeb6 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= databases geography
MASTER_SITES= http://postgis.refractions.net/download/ \
http://www.postgis.org/download/
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= Adds support for geographic objects to PostgreSQL databases
LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj \
@@ -17,10 +17,9 @@ RUN_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
CONFLICTS= postgis-2.*
-USES= bison iconv
+USES= bison iconv gmake
USE_GNOME= libxml2
USE_PGSQL= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
diff --git a/security/klamav/Makefile b/security/klamav/Makefile
index 0587b38ed69f..0392a3a283d4 100644
--- a/security/klamav/Makefile
+++ b/security/klamav/Makefile
@@ -1,15 +1,14 @@
# Created by: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
# $FreeBSD$
-#
PORTNAME= klamav
PORTVERSION= 0.46
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/Source%20%28For%20ClamAV%20and%20gt_%3D%200.9x%29/KlamAV-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= KDE 3 front-end to Clam Anti-Virus
LIB_DEPENDS= clamav:${PORTSDIR}/security/clamav
@@ -18,10 +17,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}-${PORTVERSION}
PREFIX= ${KDE_PREFIX}
-USE_GMAKE= yes
+USES= gettext gmake pkgconfig
USE_SQLITE= 3
-USE_GNOME= pkgconfig
-USES= gettext
INSTALLS_ICONS= yes
USE_AUTOTOOLS= libtool aclocal
@@ -32,11 +29,9 @@ CONFIGURE_ARGS+=--with-qt-dir=${QT_PREFIX} \
USE_KDELIBS_VER= 3
-.include <bsd.port.pre.mk>
-
pre-configure:
@${CP} ${LTMAIN} ${WRKSRC}/admin
@${CP} ${LIBTOOL_M4} ${WRKSRC}/admin
@${CP} ${LOCALBASE}/include/clamav-config.h ${WRKSRC}/src/klamd
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/kovpn/Makefile b/security/kovpn/Makefile
index 21d19c5246bc..74f4ea67f678 100644
--- a/security/kovpn/Makefile
+++ b/security/kovpn/Makefile
@@ -1,6 +1,5 @@
# Created by: anderson@cnpm.embrapa.br
# $FreeBSD$
-#
PORTNAME= kovpn
PORTVERSION= 0.3
@@ -9,7 +8,7 @@ CATEGORIES= security kde
MASTER_SITES= https://projects.fslab.de/projects/kovpn/chrome/site/
DISTNAME= ${PORTNAME}-${PORTVERSION}.pre7
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= Simple GUI for OpenVPN clients
RUN_DEPENDS= openvpn:${PORTSDIR}/security/openvpn
@@ -19,9 +18,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
USE_BZIP2= yes
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
-USES= gettext
+USES= gettext gmake
INSTALLS_ICONS= yes
-USE_GMAKE= yes
USE_XORG= xpm
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:env automake:env libtool
diff --git a/security/tuntun/Makefile b/security/tuntun/Makefile
index bc467da63392..e7df551543f1 100644
--- a/security/tuntun/Makefile
+++ b/security/tuntun/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tuntun
-# Date created: 2008-09-16
-# Whom: Anderson S. Ferreira <anderson@cnpm.embrapa.br>
-#
+# Created by: Anderson S. Ferreira <anderson@cnpm.embrapa.br>
# $FreeBSD$
-#
PORTNAME= tuntun
PORTVERSION= 0.4.0
@@ -11,18 +7,17 @@ PORTREVISION= 5
CATEGORIES= security gnome
MASTER_SITES= http://tuntun.googlecode.com/files/
-MAINTAINER= anderson@cnpm.embrapa.br
-COMMENT= A Gnome applet gui for OpenVPN
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Gnome applet gui for OpenVPN
LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
+USES= gmake pkgconfig pathfix
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"
CPPFLAGS+= `pkg-config --cflags libgnomeui-2.0`
CONFIGURE_ARGS= --libdir=${PREFIX}/libdata/servers
-USE_GMAKE= yes
-USE_GNOME= gnomehier intlhack gnomeprefix gnomehack gnomepanel glib20 \
- libgnomeui
+USE_GNOME= gnomehier intlhack gnomeprefix gnomepanel glib20 libgnomeui
.include <bsd.port.mk>
diff --git a/www/drupal6-chaos/Makefile b/www/drupal6-chaos/Makefile
index c70527cb120e..624a7192b374 100644
--- a/www/drupal6-chaos/Makefile
+++ b/www/drupal6-chaos/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: drupal6-chaos
-# Date created: 09 Feb 2010
-# Whom: anderson@cnpm.embrapa.br
-#
+# Created by: anderson@cnpm.embrapa.br
# $FreeBSD$
-#
PORTNAME= ctools
DISTVERSION= 6.x-1.6
@@ -11,7 +7,7 @@ PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.drupal.org/files/projects/
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= Drupal 6.x Chaos tool suite module
USE_DRUPAL= yes
diff --git a/www/drupal6-ckeditor/Makefile b/www/drupal6-ckeditor/Makefile
index eb3fb8e085e9..060cbed74a20 100644
--- a/www/drupal6-ckeditor/Makefile
+++ b/www/drupal6-ckeditor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: drupal6-ckeditor
-# Date created: 02 jun 2010
-# Whom: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
-#
+# Created by: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
# $FreeBSD$
-#
PORTNAME= ckeditor
DISTVERSION= 6.x-1.1
@@ -15,7 +11,7 @@ DISTFILES= ckeditor-6.x-1.1.tar.gz:1 \
ckeditor_3.3.tar.gz:2
EXTRACT_ONLY= ckeditor-6.x-1.1.tar.gz
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= Drupal 6.x Ckeditor WYSIWYG HTML editor
USE_DRUPAL= yes
diff --git a/www/drupal6-content_access/Makefile b/www/drupal6-content_access/Makefile
index 3e46cb3377ce..7ba7cc7b8289 100644
--- a/www/drupal6-content_access/Makefile
+++ b/www/drupal6-content_access/Makefile
@@ -1,16 +1,12 @@
-# New ports collection makefile for: drupal6-content_access
-# Date created: 02 jun 2010
-# Whom: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
-#
+# Created by: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
# $FreeBSD$
-#
PORTNAME= content_access
DISTVERSION= 6.x-1.2
CATEGORIES= www
MASTER_SITES= http://ftp.drupal.org/files/projects/
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= Drupal 6.x Content Access module
USE_DRUPAL= yes
diff --git a/www/drupal6-image/Makefile b/www/drupal6-image/Makefile
index a5c7577a956f..b5954fe7af07 100644
--- a/www/drupal6-image/Makefile
+++ b/www/drupal6-image/Makefile
@@ -1,16 +1,12 @@
-# New ports collection makefile for: drupal6-image
-# Date created: 09 Feb 2010
-# Whom: anderson@cnpm.embrapa.br
-#
+# Created by: anderson@cnpm.embrapa.br
# $FreeBSD$
-#
PORTNAME= image
DISTVERSION= 6.x-1.0-beta5
CATEGORIES= www
MASTER_SITES= http://ftp.drupal.org/files/projects/
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= Drupal 6.x image upload module
USE_DRUPAL= yes
diff --git a/www/drupal6-imce/Makefile b/www/drupal6-imce/Makefile
index d5e146dfacfc..8aa394082541 100644
--- a/www/drupal6-imce/Makefile
+++ b/www/drupal6-imce/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: drupal6-imce
-# Date created: 10 feb 2010
-# Whom: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
-#
+# Created by: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
# $FreeBSD$
-#
PORTNAME= imce
DISTVERSION= 6.x-1.4
@@ -11,7 +7,7 @@ PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.drupal.org/files/projects/
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= Drupal 6.x image/file uploader module
USE_DRUPAL= yes
diff --git a/www/drupal6-panels/Makefile b/www/drupal6-panels/Makefile
index acc74248e8e2..482a0ad531b7 100644
--- a/www/drupal6-panels/Makefile
+++ b/www/drupal6-panels/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: drupal6-panels
-# Date created: 09 Feb 2010
-# Whom: anderson@cnpm.embrapa.br
-#
+# Created by: anderson@cnpm.embrapa.br
# $FreeBSD$
-#
PORTNAME= panels
DISTVERSION= 6.x-3.5
@@ -11,7 +7,7 @@ PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.drupal.org/files/projects/
-MAINTAINER= anderson@cnpm.embrapa.br
+MAINTAINER= ports@FreeBSD.org
COMMENT= Drupal 6.x panels module
USE_DRUPAL= yes