aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES8
-rw-r--r--Mk/Uses/python.mk8
-rw-r--r--astro/weather/Makefile2
-rw-r--r--databases/py-bsddb/Makefile2
-rw-r--r--databases/py-gdbm/Makefile2
-rw-r--r--databases/py-sqlalchemy-devel/Makefile10
-rw-r--r--databases/py-sqlalchemy/Makefile10
-rw-r--r--databases/py-sqlalchemy06/Makefile6
-rw-r--r--databases/py-sqlite3/Makefile2
-rw-r--r--devel/awscli/Makefile2
-rw-r--r--devel/dee/Makefile2
-rw-r--r--devel/ice/Makefile2
-rw-r--r--devel/py-Jinja2/Makefile6
-rw-r--r--devel/py-efl/Makefile2
-rw-r--r--devel/py-filemagic/Makefile2
-rw-r--r--devel/py-nose/Makefile2
-rw-r--r--devel/py-olefile/Makefile2
-rw-r--r--editors/vim/Makefile2
-rw-r--r--graphics/opencv/Makefile2
-rw-r--r--graphics/py-opencv/Makefile2
-rw-r--r--lang/python-tools/Makefile2
-rw-r--r--mail/py-spf/Makefile2
-rw-r--r--misc/py-yolk/Makefile2
-rw-r--r--net/py-urllib3/Makefile4
-rw-r--r--security/py-cryptography/Makefile2
-rw-r--r--security/py-oauthlib/Makefile2
-rw-r--r--security/py-python-registry/Makefile2
-rw-r--r--textproc/py-gettext/Makefile2
-rw-r--r--www/py-aiohttp/Makefile2
-rw-r--r--www/py-autobahn/Makefile6
-rw-r--r--www/py-cherrypy/Makefile4
-rw-r--r--www/py-gandi.cli/Makefile2
-rw-r--r--www/py-hyper/Makefile2
-rw-r--r--www/py-slimit/Makefile2
-rw-r--r--www/py-tornado/Makefile2
-rw-r--r--www/py-wikitools/Makefile2
-rw-r--r--x11-toolkits/py-tkinter/Makefile2
37 files changed, 63 insertions, 55 deletions
diff --git a/CHANGES b/CHANGES
index 19442d133e9b..5c8a641921fe 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,14 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20150526:
+AUTHOR: antoine@FreeBSD.org
+
+ PYTHON_REL has been switched from a 3 digits number to a 4 digits number to
+ handle python 2.7.10. Ports checking for python 2.7.9 should compare
+ PYTHON_REL against 2709 and ports checking for python 2.7.10 should compare
+ PYTHON_REL against 2710.
+
20150521:
AUTHOR: mat@FreeBSD.org
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 36824605fa32..714bee4480f7 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -142,7 +142,7 @@
# PYTHON_PORTSDIR - The port directory of the chosen Python interpreter
#
# PYTHON_REL - The release number of the chosen Python interpreter
-# without dots, e.g. 276, 341, ...
+# without dots, e.g. 2706, 3401, ...
#
# PYTHON_SUFFIX - The major-minor release number of the chosen Python
# interpreter without dots, e.g. 27, 34, ...
@@ -383,7 +383,7 @@ PYTHON_REL= # empty
PYTHON_ABIVER= # empty
PYTHON_PORTSDIR= ${_PYTHON_RELPORTDIR}${PYTHON_SUFFIX}
PYTHON_PORTVERSION!= ${MAKE} -V PORTVERSION -C ${PYTHON_PORTSDIR}
-PYTHON_REL= ${PYTHON_PORTVERSION:S/.//g}
+PYTHON_REL= ${PYTHON_PORTVERSION:C/\.([0-9]+)$/.0\1/:C/\.0?([0-9][0-9])$/.\1/:S/.//g}
# Might be overridden by calling ports
PYTHON_CMD?= ${_PYTHON_BASECMD}${_PYTHON_VERSION}
@@ -500,7 +500,7 @@ add-plist-pymod:
${_PYTHONPKGLIST} | ${SORT} >> ${TMPPLIST}
.else
-.if ${PYTHON_REL} >= 320 && defined(_PYTHON_FEATURE_PY3KPLIST)
+.if ${PYTHON_REL} >= 3200 && defined(_PYTHON_FEATURE_PY3KPLIST)
# When Python version is 3.2+ we rewrite all the filenames
# of TMPPLIST that end with .py[co], so that they conform
# to PEP 3147 (see http://www.python.org/dev/peps/pep-3147/)
@@ -515,7 +515,7 @@ add-plist-post:
pc="__pycache__" mt="$$(${PYMAGICTAG})" \
${TMPPLIST} > ${TMPPLIST}.pyc_tmp
@${MV} ${TMPPLIST}.pyc_tmp ${TMPPLIST}
-.endif # ${PYTHON_REL} >= 320 && defined(_PYTHON_FEATURE_PY3KPLIST)
+.endif # ${PYTHON_REL} >= 3200 && defined(_PYTHON_FEATURE_PY3KPLIST)
.endif # defined(_PYTHON_FEATURE_AUTOPLIST) && defined(_PYTHON_FEATURE_DISTUTILS)
# Fix for programs that build python from a GNU auto* environment
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index 27a60e8b9d62..536bbaf340b6 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -27,7 +27,7 @@ python_CMD= ${PYTHON_CMD}
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 320
+.if ${PYTHON_REL} < 3200
PYCACHE_DIR= # empty
PYCACHE_FILE= ${PORTNAME}
.else
diff --git a/databases/py-bsddb/Makefile b/databases/py-bsddb/Makefile
index ad7a61e290b4..8d41cf5864dd 100644
--- a/databases/py-bsddb/Makefile
+++ b/databases/py-bsddb/Makefile
@@ -30,7 +30,7 @@ MAKE_ENV= BSDDB_VERSION=${BDB_LIB_NAME}
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
IGNORE= bsddb package was removed from core standard library since 3.0, use databases/py-bsddb3 instead
.endif
diff --git a/databases/py-gdbm/Makefile b/databases/py-gdbm/Makefile
index eeb9e613b960..5b211307eb86 100644
--- a/databases/py-gdbm/Makefile
+++ b/databases/py-gdbm/Makefile
@@ -30,7 +30,7 @@ WRKSRC= ${WRKDIR}/Python-${PORTVERSION}/Modules
.include <bsd.port.pre.mk>
post-extract:
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
@${CP} ${FILESDIR}/setup.py ${WRKSRC}
.else
@${CP} ${FILESDIR}/setup3.py ${WRKSRC}/setup.py
diff --git a/databases/py-sqlalchemy-devel/Makefile b/databases/py-sqlalchemy-devel/Makefile
index abb0b9b24b5e..44ac7be2d694 100644
--- a/databases/py-sqlalchemy-devel/Makefile
+++ b/databases/py-sqlalchemy-devel/Makefile
@@ -64,18 +64,18 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MyS
.endif
.endif
-.if ${PYTHON_REL} < 330
+.if ${PYTHON_REL} < 3300
TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock
.endif
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
pre-build:
@${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/lib
.endif
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/doc
.endif
@@ -88,13 +88,13 @@ post-install:
.endfor
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/examples
.endif
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
regression-test: build
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/test
.endif
@cd ${WRKSRC} && ${PYTHON_CMD} sqla_nose.py
diff --git a/databases/py-sqlalchemy/Makefile b/databases/py-sqlalchemy/Makefile
index 9072cffd4168..b7dcf09d345b 100644
--- a/databases/py-sqlalchemy/Makefile
+++ b/databases/py-sqlalchemy/Makefile
@@ -81,12 +81,12 @@ post-patch:
${REINPLACE_CMD} -e 's/import logging/&.handlers/1' -i.bak ${WRKSRC}/test/engine/test_execute.py
pre-build:
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
@${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/lib
.endif
post-install:
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
@${PY2TO3_CMD} ${PY2TO3_ARGS} ${STAGEDIR}${WRKSRC}/doc
.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -99,12 +99,12 @@ post-install:
.endfor
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
@${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/examples
.endif
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
PLIST_SUB+= SPEEDUPS=""
.else
# C extensions are not supported in py3k
@@ -112,7 +112,7 @@ PLIST_SUB+= SPEEDUPS="@comment "
.endif
regression-test: build
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/test
.endif
@cd ${WRKSRC} && ${PYTHON_CMD} sqla_nose.py
diff --git a/databases/py-sqlalchemy06/Makefile b/databases/py-sqlalchemy06/Makefile
index 1577fecddb36..d8d6260a6899 100644
--- a/databases/py-sqlalchemy06/Makefile
+++ b/databases/py-sqlalchemy06/Makefile
@@ -40,7 +40,7 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MCEXTENSIONS} && ${PYTHON_REL} < 300
+.if ${PORT_OPTIONS:MCEXTENSIONS} && ${PYTHON_REL} < 3000
PLIST_SUB+= SPEEDUPS=""
.else
PLIST_SUB+= SPEEDUPS="@comment "
@@ -55,7 +55,7 @@ AL_PORTDOCS_SUBDIR= core dialects orm
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pymssql.py:${PORTSDIR}/databases/py-mssql
.endif
-.if ${PORT_OPTIONS:MMYSQL} && ${PYTHON_REL} < 300
+.if ${PORT_OPTIONS:MMYSQL} && ${PYTHON_REL} < 3000
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
.endif
@@ -76,7 +76,7 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Sybase.py:${PORTSDIR}/databases/py-sybase
.endif
post-patch:
-.if ${PORT_OPTIONS:MCEXTENSIONS} && ${PYTHON_REL} < 300
+.if ${PORT_OPTIONS:MCEXTENSIONS} && ${PYTHON_REL} < 3000
@${REINPLACE_CMD} -e 's|BUILD_CEXTENSIONS = False|BUILD_CEXTENSIONS = True|' \
${WRKSRC}/setup.py
.endif
diff --git a/databases/py-sqlite3/Makefile b/databases/py-sqlite3/Makefile
index e6fb955bd250..a0e9265a3d42 100644
--- a/databases/py-sqlite3/Makefile
+++ b/databases/py-sqlite3/Makefile
@@ -31,7 +31,7 @@ PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHON_LIBDIR}/lib-dynload
.include <bsd.port.pre.mk>
post-extract:
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
@${CP} ${FILESDIR}/setup.py ${WRKSRC}
.else
@${CP} ${FILESDIR}/setup3.py ${WRKSRC}/setup.py
diff --git a/devel/awscli/Makefile b/devel/awscli/Makefile
index 150d2a79941e..7861f1628dcc 100644
--- a/devel/awscli/Makefile
+++ b/devel/awscli/Makefile
@@ -22,7 +22,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 270
+.if ${PYTHON_REL} < 2700
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}argparse>0:${PORTSDIR}/devel/py-argparse
.endif
diff --git a/devel/dee/Makefile b/devel/dee/Makefile
index 03eabe75191e..e81b010b8992 100644
--- a/devel/dee/Makefile
+++ b/devel/dee/Makefile
@@ -31,7 +31,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
USE_GNOME+= py3gobject3
.else
USE_GNOME+= pygobject3
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index f261c9ee0abf..d8a3a6d5f93f 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -77,7 +77,7 @@ MAKE_ENV+= NOICEDOCS=yes
.include <bsd.port.pre.mk>
-.if defined(PYTHON_REL) && ${PYTHON_REL} >= 320
+.if defined(PYTHON_REL) && ${PYTHON_REL} >= 3200
PLIST_SUB+= PYTHON32=""
PLIST_SUB+= PYTHONPRE32="@comment "
.else
diff --git a/devel/py-Jinja2/Makefile b/devel/py-Jinja2/Makefile
index cfa6b2ddeb2a..3a198abfe931 100644
--- a/devel/py-Jinja2/Makefile
+++ b/devel/py-Jinja2/Makefile
@@ -45,14 +45,14 @@ PORT_OPTIONS:= ${PORT_OPTIONS:NEXAMPLES}
.endif
# no problem with Python > 3.2
-.if ${PYTHON_REL} >= 320
+.if ${PYTHON_REL} >= 3200
pre-build:
${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/jinja2
.endif
.if ${PKGNAMESUFFIX} == "-doc"
do-build:
-. if ${PYTHON_REL} >= 300
+. if ${PYTHON_REL} >= 3000
@${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/docs
. endif
(cd ${WRKSRC}/docs && ${MAKE} html)
@@ -66,7 +66,7 @@ do-install:
.if ${PORT_OPTIONS:MEXAMPLES}
PORTEXAMPLES= *
post-build:
-. if ${PYTHON_REL} >= 300
+. if ${PYTHON_REL} >= 3000
${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/examples
. endif
${PYTHON_CMD} -m compileall ${WRKSRC}/examples ; \
diff --git a/devel/py-efl/Makefile b/devel/py-efl/Makefile
index 70cf4460bb69..efaee9719172 100644
--- a/devel/py-efl/Makefile
+++ b/devel/py-efl/Makefile
@@ -23,7 +23,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:${PORTSDIR}/devel/py-dbus
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:${PORTSDIR}/devel/py-dbus
.else
diff --git a/devel/py-filemagic/Makefile b/devel/py-filemagic/Makefile
index 0506750243d5..d45df99b1c78 100644
--- a/devel/py-filemagic/Makefile
+++ b/devel/py-filemagic/Makefile
@@ -28,7 +28,7 @@ GH_TAGNAME= b24df9f
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2
.endif
diff --git a/devel/py-nose/Makefile b/devel/py-nose/Makefile
index ae8141879885..fad4b2c15f81 100644
--- a/devel/py-nose/Makefile
+++ b/devel/py-nose/Makefile
@@ -20,7 +20,7 @@ USE_PYTHON= autoplist concurrent distutils
regression-test: build
# Extra tests for python 3, added in by setup3lib.py
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} build_tests
.endif
@cd ${WRKSRC} && ${PYTHON_CMD} selftest.py --verbose
diff --git a/devel/py-olefile/Makefile b/devel/py-olefile/Makefile
index 3b7db75220f9..7be748782190 100644
--- a/devel/py-olefile/Makefile
+++ b/devel/py-olefile/Makefile
@@ -20,7 +20,7 @@ USE_PYTHON= distutils autoplist
# Remove files not python 3 ready and allow compile again
post-patch:
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
${RM} ${WRKSRC}/olefile/olefile2.py
.endif
${REINPLACE_CMD} "/install' in sys.argv:/,+1d" ${WRKSRC}/setup.py
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 93cef38d53df..4c14d824685a 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -111,7 +111,7 @@ CTAGS_CMD= ${FIND} . -type f \\| ${XARGS} ctags
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MPYTHON}
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
MAKE_ARGS+= CONF_OPT_PYTHON="--enable-pythoninterp --disable-python3interp"
.else
MAKE_ARGS+= CONF_OPT_PYTHON="--enable-python3interp --disable-pythoninterp"
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 995dde35395b..68fda6504e77 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -262,7 +262,7 @@ post-install:
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
-d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S|${PREFIX}/||})
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
-. if defined(PYTHON_REL) && ${PYTHON_REL} >= 300
+. if defined(PYTHON_REL) && ${PYTHON_REL} >= 3000
cd ${WRKSRC}/samples/python && \
${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/python
. else
diff --git a/graphics/py-opencv/Makefile b/graphics/py-opencv/Makefile
index 54695d090c51..47da9502f25c 100644
--- a/graphics/py-opencv/Makefile
+++ b/graphics/py-opencv/Makefile
@@ -12,7 +12,7 @@ OCV_PYTHON= yes
MASTERDIR= ${.CURDIR:H}/opencv
PLIST= ${.CURDIR}/pkg-plist
-.if defined(PYTHON_REL) && ${PYTHON_REL} >= 320
+.if defined(PYTHON_REL) && ${PYTHON_REL} >= 3200
PLIST_SUB+= PYTHON3="" \
PYTHON2="@comment " \
PYTHON_SUFFIX="${PYTHON_SUFFIX}"
diff --git a/lang/python-tools/Makefile b/lang/python-tools/Makefile
index 97fb063f24b5..db328ff56aa9 100644
--- a/lang/python-tools/Makefile
+++ b/lang/python-tools/Makefile
@@ -37,7 +37,7 @@ UNIQUE_SUFFIX_FILES= ${SCRIPT_FILES:C/^.*/bin\/&/g} \
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 320
+.if ${PYTHON_REL} < 3200
SCRIPT_FILES+= logmerge
python_OLD_CMD= /usr/bin/env python
.else
diff --git a/mail/py-spf/Makefile b/mail/py-spf/Makefile
index 1d4ac1ba59e0..f312f44a4e6b 100644
--- a/mail/py-spf/Makefile
+++ b/mail/py-spf/Makefile
@@ -22,7 +22,7 @@ SHEBANG_FILES= spf.py
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dns>=0:${PORTSDIR}/dns/py-dns
.else
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dns3>=0:${PORTSDIR}/dns/py-dns3
diff --git a/misc/py-yolk/Makefile b/misc/py-yolk/Makefile
index e0d348427c9f..3cb9cc3f2039 100644
--- a/misc/py-yolk/Makefile
+++ b/misc/py-yolk/Makefile
@@ -34,7 +34,7 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} == 271 || ${PYTHON_REL} == 320
+.if ${PYTHON_REL} == 2701 || ${PYTHON_REL} == 3200
IGNORE= does not work with ${PYTHON_VERSION} (see http://goo.gl/SZpDN)
.endif
diff --git a/net/py-urllib3/Makefile b/net/py-urllib3/Makefile
index 65c5d40a2284..5e8580c0fc19 100644
--- a/net/py-urllib3/Makefile
+++ b/net/py-urllib3/Makefile
@@ -19,12 +19,12 @@ USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
# ndg_httpclient is only available for Python 2
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ndg_httpsclient>=0.3.3:${PORTSDIR}/net/py-ndg_httpsclient
.endif
post-extract:
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
@${RM} ${WRKSRC}/urllib3/contrib/pyopenssl.py
.endif
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 2125d1d2463a..704d3b4047e1 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -29,7 +29,7 @@ LDFLAGS+= -L${OPENSSLLIB}
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 340
+.if ${PYTHON_REL} < 3400
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:${PORTSDIR}/devel/py-enum34
.endif
diff --git a/security/py-oauthlib/Makefile b/security/py-oauthlib/Makefile
index 9f06123db067..bfdd3f7602c8 100644
--- a/security/py-oauthlib/Makefile
+++ b/security/py-oauthlib/Makefile
@@ -39,7 +39,7 @@ USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2
.endif
diff --git a/security/py-python-registry/Makefile b/security/py-python-registry/Makefile
index e83cf36966cc..27839fc8395a 100644
--- a/security/py-python-registry/Makefile
+++ b/security/py-python-registry/Makefile
@@ -28,7 +28,7 @@ PORTEXAMPLES= *
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 340
+.if ${PYTHON_REL} < 3400
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>=0:${PORTSDIR}/devel/py-enum34
.endif
diff --git a/textproc/py-gettext/Makefile b/textproc/py-gettext/Makefile
index 499a950eed37..250189aabfbd 100644
--- a/textproc/py-gettext/Makefile
+++ b/textproc/py-gettext/Makefile
@@ -18,7 +18,7 @@ USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} <= 300
+.if ${PYTHON_REL} <= 3000
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}unittest2>=0:${PORTSDIR}/devel/py-unittest2
.endif
diff --git a/www/py-aiohttp/Makefile b/www/py-aiohttp/Makefile
index 38d53d49595b..760911da1559 100644
--- a/www/py-aiohttp/Makefile
+++ b/www/py-aiohttp/Makefile
@@ -27,7 +27,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 340
+.if ${PYTHON_REL} < 3400
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}asyncio>0:${PORTSDIR}/devel/py-asyncio
.endif
diff --git a/www/py-autobahn/Makefile b/www/py-autobahn/Makefile
index 9da5782cbf9e..471fe6675a98 100644
--- a/www/py-autobahn/Makefile
+++ b/www/py-autobahn/Makefile
@@ -40,12 +40,12 @@ TWISTED_USES= twisted:run
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MTWISTED} && ${PYTHON_REL} >= 300
+.if ${PORT_OPTIONS:MTWISTED} && ${PYTHON_REL} >= 3000
BROKEN= Twisted currently only supports Python 2.x. Disable the TWISTED option and use ASYNCIO instead
.endif
-.if ${PORT_OPTIONS:MASYNCIO} && ${PYTHON_REL} <= 340
-.if ${PYTHON_REL} >= 330
+.if ${PORT_OPTIONS:MASYNCIO} && ${PYTHON_REL} <= 3400
+.if ${PYTHON_REL} >= 3300
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}asyncio>=0.2.1:${PORTSDIR}/devel/py-asyncio
.else
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}trollius>=0.1.2:${PORTSDIR}/devel/py-trollius \
diff --git a/www/py-cherrypy/Makefile b/www/py-cherrypy/Makefile
index 0504b4053ecb..903d4a719d1b 100644
--- a/www/py-cherrypy/Makefile
+++ b/www/py-cherrypy/Makefile
@@ -45,7 +45,7 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} >= 300 # devel/py-cheetah doesn't yet build with Python 3
+.if ${PYTHON_REL} >= 3000 # devel/py-cheetah doesn't yet build with Python 3
.undef EXAMPLES_RUN_DEPENDS
.endif
@@ -54,7 +54,7 @@ post-install:
# Instead of defining a cherrypy_build_py.get_outputs() method in setup.py
# we simply remove unwanted modules (see cherrypy_build_py() in setup.py)
post-extract:
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
@(cd ${WRKSRC}/cherrypy && ${RM} _cpcompat_subprocess.py && \
cd wsgiserver && ${RM} ssl_pyopenssl.py wsgiserver2.py)
.else
diff --git a/www/py-gandi.cli/Makefile b/www/py-gandi.cli/Makefile
index bf95f715f4ff..fd1f90c49100 100644
--- a/www/py-gandi.cli/Makefile
+++ b/www/py-gandi.cli/Makefile
@@ -30,7 +30,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 330
+.if ${PYTHON_REL} < 3300
TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
.endif
diff --git a/www/py-hyper/Makefile b/www/py-hyper/Makefile
index 68826dae914b..30e5e990a5bc 100644
--- a/www/py-hyper/Makefile
+++ b/www/py-hyper/Makefile
@@ -18,7 +18,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} == 330 || (${PYTHON_VER} == 2.7 && ${PYTHON_REL} < 279)
+.if ${PYTHON_REL} == 3300 || (${PYTHON_VER} == 2.7 && ${PYTHON_REL} < 2709)
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=0.14:${PORTSDIR}/security/py-openssl
.endif
diff --git a/www/py-slimit/Makefile b/www/py-slimit/Makefile
index c6db278b0cfe..9124e411381b 100644
--- a/www/py-slimit/Makefile
+++ b/www/py-slimit/Makefile
@@ -20,7 +20,7 @@ USE_PYTHON= distutils autoplist
# Maintainer: Reminder to keep testing python 3.x compatibility.
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} >= 300
+.if ${PYTHON_REL} >= 3000
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
pre-build:
@cd ${WRKSRC} && 2to3-${PYTHON_VER} -w src
diff --git a/www/py-tornado/Makefile b/www/py-tornado/Makefile
index 97999af3fd1f..c1dc055aae90 100644
--- a/www/py-tornado/Makefile
+++ b/www/py-tornado/Makefile
@@ -20,7 +20,7 @@ USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.ssl_match_hostname>0:${PORTSDIR}/security/py-backports.ssl_match_hostname \
${PYTHON_PKGNAMEPREFIX}futures>0:${PORTSDIR}/devel/py-futures
.endif
diff --git a/www/py-wikitools/Makefile b/www/py-wikitools/Makefile
index df278fe9a89a..3256a8b07724 100644
--- a/www/py-wikitools/Makefile
+++ b/www/py-wikitools/Makefile
@@ -18,7 +18,7 @@ USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 260
+.if ${PYTHON_REL} < 2600
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0.9:${PORTSDIR}/devel/py-simplejson
.endif
diff --git a/x11-toolkits/py-tkinter/Makefile b/x11-toolkits/py-tkinter/Makefile
index 63e87251de59..8a436a377ff3 100644
--- a/x11-toolkits/py-tkinter/Makefile
+++ b/x11-toolkits/py-tkinter/Makefile
@@ -28,7 +28,7 @@ PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHON_LIBDIR}/lib-dynload
.include <bsd.port.pre.mk>
post-extract:
-.if ${PYTHON_REL} < 300
+.if ${PYTHON_REL} < 3000
@${SED} -e "s|%%TK_VER%%|${TK_VER}|" ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
.else
@${SED} -e "s|%%TK_VER%%|${TK_VER}|" ${FILESDIR}/setup3.py > ${WRKSRC}/setup.py