aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/astrometry/Makefile2
-rw-r--r--audio/ardour5/Makefile2
-rw-r--r--audio/trommler/Makefile2
-rw-r--r--benchmarks/pybench/Makefile2
-rw-r--r--biology/pycogent/Makefile2
-rw-r--r--cad/freecad/Makefile8
-rw-r--r--chinese/sunpinyin/Makefile2
-rw-r--r--comms/gr-osmosdr/Makefile2
-rw-r--r--comms/py-libimobiledevice/Makefile1
-rw-r--r--databases/postgresql-libpqxx/Makefile2
-rw-r--r--databases/postgresql-libpqxx3/Makefile2
-rw-r--r--devel/aap/Makefile2
-rw-r--r--devel/alf/Makefile2
-rw-r--r--devel/blitz/Makefile2
-rw-r--r--devel/evolution-gconf-tools/Makefile2
-rw-r--r--devel/libnxt/Makefile2
-rw-r--r--devel/libredblack/Makefile2
-rw-r--r--devel/py-json-py/Makefile2
-rw-r--r--devel/py-kqueue/Makefile2
-rw-r--r--devel/uatraits/Makefile2
-rw-r--r--emulators/openmsx/Makefile2
-rw-r--r--games/4stattack/Makefile2
-rw-r--r--games/adonthell/Makefile2
-rw-r--r--games/battletanks/Makefile2
-rw-r--r--games/bombz/Makefile2
-rw-r--r--games/bubbros/Makefile2
-rw-r--r--games/diameter/Makefile2
-rw-r--r--games/duckmaze/Makefile2
-rw-r--r--games/farblazer/Makefile2
-rw-r--r--games/gemrb/Makefile2
-rw-r--r--games/golly/Makefile2
-rw-r--r--games/gtkradiant/Makefile2
-rw-r--r--games/liquidwar/Makefile2
-rw-r--r--games/monsterz/Makefile2
-rw-r--r--games/mopesnake/Makefile2
-rw-r--r--games/pyawale/Makefile2
-rw-r--r--games/pykawari/Makefile2
37 files changed, 40 insertions, 39 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index b93a4f0475ba..26663d6b14a9 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libcairo.so:graphics/cairo \
libnetpbm.so:graphics/netpbm
RUN_DEPENDS= ${PYNUMPY}
-USES= gmake jpeg pkgconfig python shebangfix tar:bzip2
+USES= gmake jpeg pkgconfig python:2.7 shebangfix tar:bzip2
SHEBANG_FILES= blind/*.py sdss/*.py util/[!c]*.py util/casjobs.py
USE_LDCONFIG= ${PREFIX}/${PORTNAME}/lib
ALL_TARGET= all extra
diff --git a/audio/ardour5/Makefile b/audio/ardour5/Makefile
index 83b5a86f3b56..67b1f40b4fc1 100644
--- a/audio/ardour5/Makefile
+++ b/audio/ardour5/Makefile
@@ -39,7 +39,7 @@ LIB_DEPENDS= libserd-0.so:devel/serd \
libFLAC.so:audio/flac
USES= compiler:c++11-lang desktop-file-utils gettext libarchive \
- pkgconfig python:build readline:port tar:bzip2 waf
+ pkgconfig python:2.7,build readline:port tar:bzip2 waf
USE_CXXSTD= c++11
USE_XORG= x11
USE_GNOME= atk cairo cairomm gdkpixbuf2 glib20 glibmm gtk20 gtkmm24 pango
diff --git a/audio/trommler/Makefile b/audio/trommler/Makefile
index 9986e370e5be..678ba28031b5 100644
--- a/audio/trommler/Makefile
+++ b/audio/trommler/Makefile
@@ -13,7 +13,7 @@ COMMENT= GTK+2 based drum machine
LICENSE= GPLv2
-USES= gmake pkgconfig python:build shebangfix
+USES= gmake pkgconfig python:2.7,build shebangfix
SHEBANG_FILES= genexport.py
USE_GNOME= gtk20
diff --git a/benchmarks/pybench/Makefile b/benchmarks/pybench/Makefile
index fe154672080e..a405d1c4c795 100644
--- a/benchmarks/pybench/Makefile
+++ b/benchmarks/pybench/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= python shebangfix zip
+USES= python:2.7 shebangfix zip
SHEBANG_FILES= platform.py
NO_ARCH= yes
diff --git a/biology/pycogent/Makefile b/biology/pycogent/Makefile
index a70e2e31f00c..73dde351e471 100644
--- a/biology/pycogent/Makefile
+++ b/biology/pycogent/Makefile
@@ -11,7 +11,7 @@ COMMENT= Toolkit for statistical analysis of biological sequences
LICENSE= GPLv2
BUILD_DEPENDS= ${PYNUMPY} \
- ${LOCALBASE}/bin/sphinx-build:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0.13:databases/py-sqlalchemy10@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index a917dd1eec88..9a14e90f3269 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= pyside-rcc:devel/pyside-tools \
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
libboost_python.so:devel/boost-python-libs \
- libpyside-python2.7.so:devel/pyside \
+ libpyside-python2.7.so:devel/pyside@${PY_FLAVOR} \
libCoin.so:graphics/Coin \
libpng.so:graphics/png \
libtiff.so:graphics/tiff \
@@ -29,10 +29,10 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libmed.so:french/med \
libshiboken-${PYTHON_VERSION}.so:devel/shiboken \
libhdf5.so:science/hdf5
-RUN_DEPENDS= pivy>0:graphics/py-pivy
+RUN_DEPENDS= pivy>0:graphics/py-pivy@${PY_FLAVOR}
USES= dos2unix compiler:c++11-lib cmake:outsource fortran jpeg \
- python localbase
+ python:2.7 localbase
USE_XORG= ice sm x11 xext xt
USE_GL= gl glu
USE_QT4= qmake_build corelib gui moc_build network opengl rcc_build \
@@ -58,7 +58,7 @@ GH_TAGNAME= f27617e
OPTIONS_DEFINE= COLLADA
COLLADA_DESC= Install pycollada for Collada files import
-COLLADA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycollada>0:graphics/py-pycollada
+COLLADA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycollada>0:graphics/py-pycollada@${PY_FLAVOR}
DESKTOP_ENTRIES=${PORTNAME} "" "${PREFIX}/FreeCAD/data/freecad.svg" \
${PORTNAME} "Engineering;" false
diff --git a/chinese/sunpinyin/Makefile b/chinese/sunpinyin/Makefile
index 6d77f3a39ffa..b5621f6c4e3b 100644
--- a/chinese/sunpinyin/Makefile
+++ b/chinese/sunpinyin/Makefile
@@ -21,7 +21,7 @@ GH_TAGNAME= a8bd811
MAKE_ARGS+= --prefix=${PREFIX}
USE_LDCONFIG= yes
-USES= gmake iconv perl5 pkgconfig python scons shebangfix
+USES= gmake iconv perl5 pkgconfig python:2.7 scons shebangfix
USE_PERL5= build
SHEBANG_FILES= python/*.py
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
diff --git a/comms/gr-osmosdr/Makefile b/comms/gr-osmosdr/Makefile
index a5f756221d6d..edec723e77fe 100644
--- a/comms/gr-osmosdr/Makefile
+++ b/comms/gr-osmosdr/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libgnuradio-runtime.so:comms/gnuradio \
libboost_system.so:devel/boost-libs \
libboost_thread.so:devel/boost-libs
-USES= cmake fortran pkgconfig python tar:tgz
+USES= cmake fortran pkgconfig python:2.7 tar:tgz
USE_LDCONFIG= yes
# See lib/CMakeLists.txt to enable more components
diff --git a/comms/py-libimobiledevice/Makefile b/comms/py-libimobiledevice/Makefile
index ba1d40cd263a..6e0aa46f0bd1 100644
--- a/comms/py-libimobiledevice/Makefile
+++ b/comms/py-libimobiledevice/Makefile
@@ -15,6 +15,7 @@ PORTSCOUT= ignore:1
USES= python:2.7
USE_PYTHON= flavors cython
+BINARY_ALIAS= cython=cython-${PYTHON_VER}
CONFIGURE_ENV= PYTHON_LDFLAGS="`pkg-config --libs python-${PYTHON_VER}`"
SLAVE_PORT= yes
MASTERDIR= ${.CURDIR:H:H}/comms/libimobiledevice
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 89228c5c54a6..0cca69f5b2f7 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -17,7 +17,7 @@ LICENSE= BSD3CLAUSE
CONFLICTS= postgresql-libpqxx-3.* postgresql-libpqxx3-3.*
PORTSCOUT= limit:^2\.
-USES+= gmake libtool pathfix pgsql python:build shebangfix
+USES+= gmake libtool pathfix pgsql python:2.7,build shebangfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION:R}
diff --git a/databases/postgresql-libpqxx3/Makefile b/databases/postgresql-libpqxx3/Makefile
index 591a12c42658..7f56b7fdf596 100644
--- a/databases/postgresql-libpqxx3/Makefile
+++ b/databases/postgresql-libpqxx3/Makefile
@@ -16,7 +16,7 @@ COMMENT= New C++ interface for PostgreSQL
CONFLICTS= postgresql-libpqxx-[2-4].*
PORTSCOUT= limit:^2\.
-USES+= gmake libtool pathfix pgsql pkgconfig python:build shebangfix
+USES+= gmake libtool pathfix pgsql pkgconfig python:2.7,build shebangfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/devel/aap/Makefile b/devel/aap/Makefile
index 5390f79ba3fc..872d10e7af67 100644
--- a/devel/aap/Makefile
+++ b/devel/aap/Makefile
@@ -17,7 +17,7 @@ OPTIONS_DEFINE= DOCS
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USES= python zip
+USES= python:2.7 zip
PLIST_SUB= PORTVERSION="${PORTVERSION}"
NO_ARCH= yes
diff --git a/devel/alf/Makefile b/devel/alf/Makefile
index 0737ac0a2371..fcf587cb8e38 100644
--- a/devel/alf/Makefile
+++ b/devel/alf/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/largefiles/largefiles/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Abstract Large File
-USES= libtool python
+USES= libtool python:2.7
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/devel/blitz/Makefile b/devel/blitz/Makefile
index 73e9a8fd62fc..afb38a52e5f2 100644
--- a/devel/blitz/Makefile
+++ b/devel/blitz/Makefile
@@ -10,7 +10,7 @@ COMMENT= Blitz++ Multi-Dimensional Array Library for C++
LICENSE= ART20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake libtool localbase python:build
+USES= gmake libtool localbase python:2.7,build
USE_GITHUB= yes
GH_ACCOUNT= blitzpp
GNU_CONFIGURE= yes
diff --git a/devel/evolution-gconf-tools/Makefile b/devel/evolution-gconf-tools/Makefile
index 4c36394d0169..abd8f97711f2 100644
--- a/devel/evolution-gconf-tools/Makefile
+++ b/devel/evolution-gconf-tools/Makefile
@@ -14,7 +14,7 @@ COMMENT= Scripts to make it easier to work with Evolution's configuration
RUN_DEPENDS= evolution:mail/evolution
GNU_CONFIGURE= yes
-USES= python
+USES= python:2.7
USE_GNOME= gnomeprefix
NO_ARCH= yes
diff --git a/devel/libnxt/Makefile b/devel/libnxt/Makefile
index 6aeae8456de9..83975c50d21f 100644
--- a/devel/libnxt/Makefile
+++ b/devel/libnxt/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= bacon4000@gmail.com
COMMENT= Lego NXT library
SUB_FILES= pkg-message
-USES= python:build scons shebangfix
+USES= python:2.7,build scons shebangfix
USE_LDCONFIG= yes
SHEBANG_FILES= make_flash_header.py
diff --git a/devel/libredblack/Makefile b/devel/libredblack/Makefile
index d7c9ba3bfe7e..b4f50f28c0d8 100644
--- a/devel/libredblack/Makefile
+++ b/devel/libredblack/Makefile
@@ -20,7 +20,7 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS+= --without-rbgen
PLIST_SUB+= PYTHON="@comment "
.else
-USES+= python
+USES+= python:2.7
CONFIGURE_ARGS+= --with-python=${PYTHON_CMD}
PLIST_SUB+= PYTHON=""
.endif
diff --git a/devel/py-json-py/Makefile b/devel/py-json-py/Makefile
index bde22e42699c..0ca90e3d0727 100644
--- a/devel/py-json-py/Makefile
+++ b/devel/py-json-py/Makefile
@@ -15,7 +15,7 @@ LICENSE= LGPL20
NO_WRKSUBDIR= yes
-USES= python zip
+USES= python:2.7 zip
do-build:
# compile python files
diff --git a/devel/py-kqueue/Makefile b/devel/py-kqueue/Makefile
index d6ee6a16957e..c709d279bf0c 100644
--- a/devel/py-kqueue/Makefile
+++ b/devel/py-kqueue/Makefile
@@ -13,7 +13,7 @@ EXTRACT_SUFX= .tbz
MAINTAINER= ports2@dclg.ca
COMMENT= Python interface to kqueue(2) and kevent(2) system calls
-USES= python tar:bzip2
+USES= python:2.7 tar:bzip2
FILES= kqsyscallmodule.so KQueue.py KQueue.pyc
PLIST_FILES= ${FILES:S+^+%%PYTHON_SITELIBDIR%%/+g}
MAKE_ENV= MAINCC=${CC}
diff --git a/devel/uatraits/Makefile b/devel/uatraits/Makefile
index 6939277850fa..fc4fc3e7b02d 100644
--- a/devel/uatraits/Makefile
+++ b/devel/uatraits/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
libpcre.so:devel/pcre \
libxml2.so:textproc/libxml2
-USES= autoreconf libtool pkgconfig python ssl
+USES= autoreconf libtool pkgconfig python:2.7 ssl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/emulators/openmsx/Makefile b/emulators/openmsx/Makefile
index 0334bcecf714..f17885f28692 100644
--- a/emulators/openmsx/Makefile
+++ b/emulators/openmsx/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libao.so:audio/libao
MAKEFILE= GNUmakefile
-USES= gmake python tcl
+USES= gmake python:2.7 tcl
USE_GCC= yes
USE_GL= glew
USE_SDL= sdl ttf
diff --git a/games/4stattack/Makefile b/games/4stattack/Makefile
index 1eafeef4d6a9..3026b9d9103d 100644
--- a/games/4stattack/Makefile
+++ b/games/4stattack/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/GPL
RUN_DEPENDS= ${PYGAME}
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= 4stattack.py
NO_ARCH= yes
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index c3268023bd04..f3d8183a6667 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -19,7 +19,7 @@ LICENSE_DISTFILES= ${DISTFILES}
LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libfreetype.so:print/freetype2
-USES= gettext gmake python
+USES= gettext gmake python:2.7
USE_SDL= mixer ttf sdl
USE_GCC= any
GNU_CONFIGURE= yes
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index 95d27df8b056..16e4fe85cf49 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libvorbisfile.so:audio/libvorbis \
libsmpeg.so:multimedia/smpeg
-USES= openal:al pkgconfig lua:51 python:build scons tar:bzip2
+USES= openal:al pkgconfig lua:51 python:2.7,build scons tar:bzip2
USE_LDCONFIG= yes
USE_SDL= image sdl
MAKE_ARGS= prefix=${PREFIX} resources_dir=${DATADIR} \
diff --git a/games/bombz/Makefile b/games/bombz/Makefile
index a1c136bce6bb..bde916fbf607 100644
--- a/games/bombz/Makefile
+++ b/games/bombz/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYGAME}
WRKSRC= ${WRKDIR}/Bombz
-USES= dos2unix python zip
+USES= dos2unix python:2.7 zip
DOS2UNIX_FILES= *.txt
USE_SDL= sdl image mixer
INSTALLS_ICONS= yes
diff --git a/games/bubbros/Makefile b/games/bubbros/Makefile
index 50eb59035a6f..80a1ee9d380c 100644
--- a/games/bubbros/Makefile
+++ b/games/bubbros/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYGAME}
BUILD_DEPENDS= ${PYGAME}
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= BubBob.py
USE_XORG= x11 xext
diff --git a/games/diameter/Makefile b/games/diameter/Makefile
index e03f4d4b5cd1..69eb864dcda0 100644
--- a/games/diameter/Makefile
+++ b/games/diameter/Makefile
@@ -13,7 +13,7 @@ COMMENT= Arcade-style game with elements of economy and adventure
LIB_DEPENDS= libpng.so:graphics/png \
libguichan.so:devel/guichan
-USES= tar:bzip2 gmake pkgconfig python
+USES= tar:bzip2 gmake pkgconfig python:2.7
GNU_CONFIGURE= yes
USE_GL= gl
USE_SDL= sdl mixer image
diff --git a/games/duckmaze/Makefile b/games/duckmaze/Makefile
index 48a4660a0c1c..bb123fdad37e 100644
--- a/games/duckmaze/Makefile
+++ b/games/duckmaze/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYGAME}
WRKSRC= ${WRKDIR}/${PORTNAME}/trunk
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= *.py mopelib/mopelib.py
NO_ARCH= yes
diff --git a/games/farblazer/Makefile b/games/farblazer/Makefile
index 4a613a4320f4..94c004dd5334 100644
--- a/games/farblazer/Makefile
+++ b/games/farblazer/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING.txt
RUN_DEPENDS= ${PYGAME}
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= farblazer.py
NO_ARCH= yes
diff --git a/games/gemrb/Makefile b/games/gemrb/Makefile
index db1fb124a72d..3cce349c8e52 100644
--- a/games/gemrb/Makefile
+++ b/games/gemrb/Makefile
@@ -23,7 +23,7 @@ OPENGL_USE= gl=gl,glu,glew
OPENGL_CMAKE_ON=-DOPENGL_BACKEND=OpenGL
PLIST_SUB= PORTVERSION=${PORTVERSION}
-USES= cmake:outsource openal:al,alut python shebangfix iconv localbase
+USES= cmake:outsource openal:al,alut python:2.7 shebangfix iconv localbase
SHEBANG_FILES= admin/extend2da.py
USE_SDL= sdl2
USE_LDCONFIG= yes
diff --git a/games/golly/Makefile b/games/golly/Makefile
index f5069dd05546..2a26806f35a4 100644
--- a/games/golly/Makefile
+++ b/games/golly/Makefile
@@ -12,7 +12,7 @@ COMMENT= Conway's Game of Life and other cellular automata
LICENSE= GPLv2+
-USES= compiler:c++11-lib cmake:outsource perl5 python
+USES= compiler:c++11-lib cmake:outsource perl5 python:2.7
USE_CXXSTD= c++11
USE_WX= 3.0
diff --git a/games/gtkradiant/Makefile b/games/gtkradiant/Makefile
index 1717a3d3ca81..18e65d9b3e20 100644
--- a/games/gtkradiant/Makefile
+++ b/games/gtkradiant/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libmhash.so:security/mhash \
libpng.so:graphics/png
-USES= pkgconfig python:build scons zip
+USES= pkgconfig python:2.7,build scons zip
USE_GNOME= gtk20 libxml2
MAKE_ARGS= ${MAKE_ENV} BUILD=release
SSP_UNSAFE= yes
diff --git a/games/liquidwar/Makefile b/games/liquidwar/Makefile
index 4c4c25543f6d..ff1ccb7f934e 100644
--- a/games/liquidwar/Makefile
+++ b/games/liquidwar/Makefile
@@ -15,7 +15,7 @@ COMMENT= You control an army of liquid and have to try and eat your opponents
LIB_DEPENDS= liballeg.so:devel/allegro
GNU_CONFIGURE= yes
-USES= gmake makeinfo python:build
+USES= gmake makeinfo python:2.7,build
CONFIGURE_ARGS= --disable-target-opt --disable-doc-ps --disable-doc-pdf
CONFIGURE_ENV= ac_cv_prog_PYTHON=yes
diff --git a/games/monsterz/Makefile b/games/monsterz/Makefile
index dcfc71a6ffc6..f9d3de4dee15 100644
--- a/games/monsterz/Makefile
+++ b/games/monsterz/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYGAME}
-USES= python
+USES= python:2.7
MAKE_ENV= prefix=${PREFIX}
PORTDOCS= AUTHORS README TODO
diff --git a/games/mopesnake/Makefile b/games/mopesnake/Makefile
index e744cdf9ab63..a9b8e52a0ea2 100644
--- a/games/mopesnake/Makefile
+++ b/games/mopesnake/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYGAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-pc-${DISTVERSION}
-USES= python zip
+USES= python:2.7 zip
NO_ARCH= yes
PORTDOCS= index.html
diff --git a/games/pyawale/Makefile b/games/pyawale/Makefile
index 1a3581c9e5f0..e9355f23cf4d 100644
--- a/games/pyawale/Makefile
+++ b/games/pyawale/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYGAME}
-USES= python
+USES= python:2.7
SUB_FILES= ${PORTNAME}
diff --git a/games/pykawari/Makefile b/games/pykawari/Makefile
index b5eb313717a6..9eaf5b0662a1 100644
--- a/games/pykawari/Makefile
+++ b/games/pykawari/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ninix:games/ninix-aya
BUILD_WRKSRC= ${WRKSRC}/build/src
-USES= gmake python zip
+USES= gmake python:2.7 zip
MAKEFILE= gcc.mak
MAKE_ARGS= CXX="${CXX}" CFLAGS="${CXXFLAGS}" \
PYTHONBASE="${PYTHONBASE}" PYTHON_VERSION="${PYTHON_VERSION}"