aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/linuxthreads/Makefile2
-rw-r--r--devel/linuxthreads/files/libc_thread.c6
2 files changed, 7 insertions, 1 deletions
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index 72a50bf863c7..ff55a6e57b3e 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linuxthreads
PORTVERSION= 2.2.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glibc
diff --git a/devel/linuxthreads/files/libc_thread.c b/devel/linuxthreads/files/libc_thread.c
index b58de1990a91..ada205fd2858 100644
--- a/devel/linuxthreads/files/libc_thread.c
+++ b/devel/linuxthreads/files/libc_thread.c
@@ -102,6 +102,12 @@ void _spinlock (int * spinlock)
__pthread_acquire(spinlock);
}
+
+void _spinunlock(int *spinlock)
+{
+ *spinlock = 0;
+}
+
void * lock_create (void *context)
{
pthread_rwlock_t *lock;