aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python32/Makefile4
-rw-r--r--lang/python33/Makefile4
-rw-r--r--lang/python34/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 9ba8a8e45f6f..553f8471f050 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -91,8 +91,8 @@ PLIST_FILES+= libdata/pkgconfig/python-3.2%%ABI%%.pc
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-# See http://bugs.freebsd.org/115940
-.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
+.if defined(WITHOUT_NIS) || !exists(/usr/include/rpcsvc/yp_prot.h)
PLIST_SUB+= NO_NIS="@comment "
.else
PLIST_SUB+= NO_NIS=""
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 61706e10b759..1e9b2e75ff67 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -85,8 +85,8 @@ PLIST_FILES+= libdata/pkgconfig/python-3.3%%ABI%%.pc
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-# See http://bugs.freebsd.org/115940
-.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
+.if defined(WITHOUT_NIS) || !exists(/usr/include/rpcsvc/yp_prot.h)
PLIST_SUB+= NO_NIS="@comment "
.else
PLIST_SUB+= NO_NIS=""
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index ac193fb0c7f9..fc963260baf5 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -100,8 +100,8 @@ PLIST_FILES+= libdata/pkgconfig/python-3.4%%ABI%%.pc
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-# See http://bugs.freebsd.org/115940
-.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
+.if defined(WITHOUT_NIS) || !exists(/usr/include/rpcsvc/yp_prot.h)
PLIST_SUB+= NO_NIS="@comment "
DISABLED_EXTENSIONS+= nis
.else