aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--accessibility/kmag/Makefile2
-rw-r--r--accessibility/kmousetool/Makefile2
-rw-r--r--accessibility/kmouth/Makefile2
-rw-r--r--astro/libkgeomap/Makefile3
-rw-r--r--audio/audiocd-kio/Makefile2
-rw-r--r--comms/qt5-connectivity/Makefile2
-rw-r--r--devel/kcachegrind/Makefile3
-rw-r--r--devel/kdesdk-thumbnailers/Makefile2
-rw-r--r--devel/umbrello/Makefile2
-rw-r--r--games/bomber/Makefile2
-rw-r--r--games/bovo/Makefile2
-rw-r--r--games/granatier/Makefile2
-rw-r--r--games/kanagram/Makefile2
-rw-r--r--games/kapman/Makefile2
-rw-r--r--games/katomic/Makefile3
-rw-r--r--games/kblackbox/Makefile2
-rw-r--r--games/kblocks/Makefile2
-rw-r--r--games/kbounce/Makefile2
-rw-r--r--games/kbreakout/Makefile2
-rw-r--r--games/kdiamond/Makefile2
-rw-r--r--games/kfourinline/Makefile2
-rw-r--r--games/killbots/Makefile2
-rw-r--r--games/kiriki/Makefile2
-rw-r--r--games/kjumpingcube/Makefile2
-rw-r--r--games/klickety/Makefile3
-rw-r--r--games/klines/Makefile2
-rw-r--r--games/kmahjongg/Makefile2
-rw-r--r--games/kmines/Makefile2
-rw-r--r--games/knavalbattle/Makefile2
-rw-r--r--games/knetwalk/Makefile2
-rw-r--r--games/kolf/Makefile2
-rw-r--r--games/kollision/Makefile2
-rw-r--r--games/kpat/Makefile3
-rw-r--r--games/kshisen/Makefile2
-rw-r--r--games/ksirk/Makefile2
-rw-r--r--games/ksquares/Makefile2
-rw-r--r--games/ktuberling/Makefile2
-rw-r--r--games/palapeli/Makefile3
-rw-r--r--games/picmi/Makefile2
-rw-r--r--graphics/kolourpaint/Makefile2
-rw-r--r--graphics/skanlite/Makefile2
-rw-r--r--graphics/spectacle/Makefile2
-rw-r--r--misc/kwordquiz/Makefile2
-rw-r--r--multimedia/kdemultimedia-ffmpegthumbs/Makefile2
-rw-r--r--net-im/kaccounts-integration/Makefile3
-rw-r--r--net-im/kaccounts-providers/Makefile3
-rw-r--r--net-im/ktp-common-internals/Makefile3
-rw-r--r--net/libkvkontakte/Makefile2
-rw-r--r--net/libmediawiki/Makefile2
-rw-r--r--textproc/kompare/Makefile2
-rw-r--r--textproc/kreport/Makefile3
-rw-r--r--x11-toolkits/qt5-charts/Makefile2
-rw-r--r--x11/konsole/Makefile3
53 files changed, 64 insertions, 53 deletions
diff --git a/accessibility/kmag/Makefile b/accessibility/kmag/Makefile
index 9028786ceea8..3a4e4c006505 100644
--- a/accessibility/kmag/Makefile
+++ b/accessibility/kmag/Makefile
@@ -10,7 +10,7 @@ COMMENT= KDE Screen magnifier
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons ecm \
i18n kio service widgetsaddons xmlgui
USE_QT= core dbus gui printsupport widgets xml \
diff --git a/accessibility/kmousetool/Makefile b/accessibility/kmousetool/Makefile
index 7a6a9e7b363e..e215632d1874 100644
--- a/accessibility/kmousetool/Makefile
+++ b/accessibility/kmousetool/Makefile
@@ -10,7 +10,7 @@ COMMENT= Automatic mouse click tool for KDE
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons dbusaddons \
ecm i18n iconthemes notifications widgetsaddons xmlgui
USE_QT= core dbus gui phonon4 widgets xml \
diff --git a/accessibility/kmouth/Makefile b/accessibility/kmouth/Makefile
index f082dda94540..39f2c0f78179 100644
--- a/accessibility/kmouth/Makefile
+++ b/accessibility/kmouth/Makefile
@@ -10,7 +10,7 @@ COMMENT= Speech synthesizer frontend for KDE
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
ecm i18n jobwidgets kio service widgetsaddons xmlgui
USE_QT= core dbus gui network printsupport speech widgets xml \
diff --git a/astro/libkgeomap/Makefile b/astro/libkgeomap/Makefile
index a467a7cbf08c..5aa0e4475cd7 100644
--- a/astro/libkgeomap/Makefile
+++ b/astro/libkgeomap/Makefile
@@ -13,7 +13,8 @@ LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/buffer_concepts.hpp:devel/boost-libs
LIB_DEPENDS= libopencv_video.so:graphics/opencv
-USES= cmake:outsource gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 pkgconfig \
+ qt:5 tar:xz
USE_KDE= config coreaddons ecm i18n kio marble service textwidgets
USE_QT= concurrent core gui network webkit widgets xml \
buildtools_build qmake_build
diff --git a/audio/audiocd-kio/Makefile b/audio/audiocd-kio/Makefile
index 4592b57e04e7..d0b5cea8dfda 100644
--- a/audio/audiocd-kio/Makefile
+++ b/audio/audiocd-kio/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libKF5Cddb.so:audio/libkcddb \
libKF5CompactDisc.so:audio/libkcompactdisc
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash guiaddons i18n iconthemes itemviews \
jobwidgets kdelibs4support kio notifications parts \
diff --git a/comms/qt5-connectivity/Makefile b/comms/qt5-connectivity/Makefile
index 5ed2aa66c552..8cbe606bab1f 100644
--- a/comms/qt5-connectivity/Makefile
+++ b/comms/qt5-connectivity/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt connectivity (Bluetooth/NFC) module
USE_QT= concurrent core declarative buildtools_build
-USES= qmake qt-dist:5,connectivity
+USES= compiler:c++11-lang qmake qt-dist:5,connectivity
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/devel/kcachegrind/Makefile b/devel/kcachegrind/Makefile
index 02111ea7726e..7013b0eb79a9 100644
--- a/devel/kcachegrind/Makefile
+++ b/devel/kcachegrind/Makefile
@@ -7,7 +7,8 @@ CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Profiler frontend for KDE
-USES= cmake:outsource kde:5 python:run qt:5 shebangfix tar:xz
+USES= cmake:outsource compiler:c++11-lang kde:5 python:run qt:5 \
+ shebangfix tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons ecm i18n itemviews jobwidgets kio service solid \
widgetsaddons xmlgui
diff --git a/devel/kdesdk-thumbnailers/Makefile b/devel/kdesdk-thumbnailers/Makefile
index 69268fbadd7c..6858f79c17e4 100644
--- a/devel/kdesdk-thumbnailers/Makefile
+++ b/devel/kdesdk-thumbnailers/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE thumbnail generator for gettext po files
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= completion config coreaddons ecm i18n jobwidgets \
kio service widgetsaddons
USE_QT= core dbus gui network widgets xml \
diff --git a/devel/umbrello/Makefile b/devel/umbrello/Makefile
index d4bec279afea..f32e464213d7 100644
--- a/devel/umbrello/Makefile
+++ b/devel/umbrello/Makefile
@@ -9,7 +9,7 @@ COMMENT= UML modeller for KDE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-USES= cmake:outsource kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gnome kde:5 qt:5 tar:xz
USE_GNOME= libxml2 libxslt
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash ecm guiaddons i18n iconthemes itemviews \
diff --git a/games/bomber/Makefile b/games/bomber/Makefile
index 2c22cba9dce4..3b40a9a7dd17 100644
--- a/games/bomber/Makefile
+++ b/games/bomber/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
ecm i18n kio libkdegames widgetsaddons xmlgui
USE_QT= core dbus declarative gui network widgets phonon4 xml \
diff --git a/games/bovo/Makefile b/games/bovo/Makefile
index e18fe53345a3..6cd3c82257be 100644
--- a/games/bovo/Makefile
+++ b/games/bovo/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
ecm i18n kdeclarative libkdegames newstuff widgetsaddons xmlgui
USE_QT= concurrent core dbus declarative gui network svg widgets xml \
diff --git a/games/granatier/Makefile b/games/granatier/Makefile
index 4f81d8d4da6d..6095e3bb78d9 100644
--- a/games/granatier/Makefile
+++ b/games/granatier/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= attica auth codecs config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes itemviews kio \
libkdegames newstuff notifyconfig service widgetsaddons xmlgui
diff --git a/games/kanagram/Makefile b/games/kanagram/Makefile
index 8e1bca747859..bae13ad56cbd 100644
--- a/games/kanagram/Makefile
+++ b/games/kanagram/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Letter order game for KDE
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= attica auth codecs config configwidgets coreaddons crash \
doctools ecm i18n kdeclarative kio libkeduvocdocument newstuff \
package service sonnet widgetsaddons xmlgui
diff --git a/games/kapman/Makefile b/games/kapman/Makefile
index b4e9790e7cb8..9cdc9947fe94 100644
--- a/games/kapman/Makefile
+++ b/games/kapman/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons ecm i18n libkdegames notifyconfig widgetsaddons \
windowsystem xmlgui
diff --git a/games/katomic/Makefile b/games/katomic/Makefile
index 9af7b3e2c37c..9170325481e4 100644
--- a/games/katomic/Makefile
+++ b/games/katomic/Makefile
@@ -7,7 +7,8 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 shebangfix tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 \
+ shebangfix tar:xz
USE_KDE= attica auth codecs config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes itemviews kio \
libkdegames newstuff notifyconfig service widgetsaddons xmlgui
diff --git a/games/kblackbox/Makefile b/games/kblackbox/Makefile
index c9694f2ddd15..f98f20caa13d 100644
--- a/games/kblackbox/Makefile
+++ b/games/kblackbox/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth codecs config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes libkdegames sonnet \
textwidgets widgetsaddons xmlgui
diff --git a/games/kblocks/Makefile b/games/kblocks/Makefile
index 6e2b5b4edce7..2a2fab8c9157 100644
--- a/games/kblocks/Makefile
+++ b/games/kblocks/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons i18n itemmodels kio libkdegames newstuff \
notifyconfig textwidgets widgetsaddons windowsystem xmlgui
diff --git a/games/kbounce/Makefile b/games/kbounce/Makefile
index 23732e2753e7..6e0220eaed95 100644
--- a/games/kbounce/Makefile
+++ b/games/kbounce/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes jobwidgets kio \
libkdegames notifyconfig service textwidgets widgetsaddons xmlgui
diff --git a/games/kbreakout/Makefile b/games/kbreakout/Makefile
index 31a163cf0c85..2ddd8cf174d3 100644
--- a/games/kbreakout/Makefile
+++ b/games/kbreakout/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes jobwidgets kio libkdegames \
service widgetsaddons xmlgui
diff --git a/games/kdiamond/Makefile b/games/kdiamond/Makefile
index f3147783362c..6d20580fd80b 100644
--- a/games/kdiamond/Makefile
+++ b/games/kdiamond/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
doctools ecm guiaddons i18n iconthemes libkdegames \
notifications notifyconfig widgetsaddons xmlgui
diff --git a/games/kfourinline/Makefile b/games/kfourinline/Makefile
index b7aa16863581..e79d687a2a0a 100644
--- a/games/kfourinline/Makefile
+++ b/games/kfourinline/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons dnssd ecm i18n iconthemes itemmodels itemviews \
kdeclarative kdelibs4support kio libkdegames notifyconfig \
diff --git a/games/killbots/Makefile b/games/killbots/Makefile
index 9b11283538cf..c90a4771c18f 100644
--- a/games/killbots/Makefile
+++ b/games/killbots/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes itemviews kio \
libkdegames notifyconfig widgetsaddons xmlgui
diff --git a/games/kiriki/Makefile b/games/kiriki/Makefile
index c7f6f1602ee1..052ad0bdc3e9 100644
--- a/games/kiriki/Makefile
+++ b/games/kiriki/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
ecm guiaddons i18n iconthemes kio libkdegames widgetsaddons xmlgui
USE_QT= core dbus declarative gui network printsupport svg widgets xml \
diff --git a/games/kjumpingcube/Makefile b/games/kjumpingcube/Makefile
index af2633b0fc51..7316674389c3 100644
--- a/games/kjumpingcube/Makefile
+++ b/games/kjumpingcube/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes itemviews jobwidgets \
kio libkdegames newstuff notifyconfig service widgetsaddons \
diff --git a/games/klickety/Makefile b/games/klickety/Makefile
index 685cb9b97dab..c514b8b95d4a 100644
--- a/games/klickety/Makefile
+++ b/games/klickety/Makefile
@@ -8,7 +8,8 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 shebangfix tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 \
+ shebangfix tar:xz
SHEBANG_FILES= klickety-2.0-inherit-ksame-highscore.pl
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons doctools ecm i18n itemviews \
diff --git a/games/klines/Makefile b/games/klines/Makefile
index 88cbfa4b06fd..316db3aa3595 100644
--- a/games/klines/Makefile
+++ b/games/klines/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
ecm guiaddons i18n iconthemes itemviews kio libkdegames \
newstuff service widgetsaddons xmlgui
diff --git a/games/kmahjongg/Makefile b/games/kmahjongg/Makefile
index bef90a128c43..03708bef05b3 100644
--- a/games/kmahjongg/Makefile
+++ b/games/kmahjongg/Makefile
@@ -10,7 +10,7 @@ COMMENT= ${${PORTNAME}_DESC}
LIB_DEPENDS= libKF5KMahjongglib.so:games/libkmahjongg
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons doctools ecm i18n kdeclarative libkdegames newstuff \
widgetsaddons xmlgui
diff --git a/games/kmines/Makefile b/games/kmines/Makefile
index 767b5ff532e7..bcc95363f6a5 100644
--- a/games/kmines/Makefile
+++ b/games/kmines/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
ecm i18n kio libkdegames notifyconfig sonnet textwidgets \
widgetsaddons xmlgui
diff --git a/games/knavalbattle/Makefile b/games/knavalbattle/Makefile
index 124e21c38032..a06c773c8833 100644
--- a/games/knavalbattle/Makefile
+++ b/games/knavalbattle/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons dnssd doctools ecm i18n libkdegames sonnet \
textwidgets widgetsaddons xmlgui
diff --git a/games/knetwalk/Makefile b/games/knetwalk/Makefile
index be58af74849a..3bbcd8d74854 100644
--- a/games/knetwalk/Makefile
+++ b/games/knetwalk/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
ecm guiaddons i18n iconthemes itemviews kio libkdegames \
notifyconfig sonnet textwidgets widgetsaddons xmlgui
diff --git a/games/kolf/Makefile b/games/kolf/Makefile
index 21c23df882e2..a3a445af8616 100644
--- a/games/kolf/Makefile
+++ b/games/kolf/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm guiaddons i18n iconthemes \
itemviews jobwidgets kdelibs4support kio libkdegames \
diff --git a/games/kollision/Makefile b/games/kollision/Makefile
index 6964c46945da..7d6f9ea41d1e 100644
--- a/games/kollision/Makefile
+++ b/games/kollision/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
ecm i18n kio libkdegames newstuff notifyconfig textwidgets \
widgetsaddons xmlgui
diff --git a/games/kpat/Makefile b/games/kpat/Makefile
index d4c8b5af9223..67a4243444f6 100644
--- a/games/kpat/Makefile
+++ b/games/kpat/Makefile
@@ -10,7 +10,8 @@ COMMENT= ${${PORTNAME}_DESC}
LIB_DEPENDS= libfreecell-solver.so:games/freecell-solver
-USES= cmake:outsource gettext kde:5 pkgconfig qt:5 shared-mime-info tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 pkgconfig \
+ qt:5 shared-mime-info tar:xz
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
crash dbusaddons ecm guiaddons i18n iconthemes itemviews \
kdeclarative kio libkdegames newstuff notifyconfig service \
diff --git a/games/kshisen/Makefile b/games/kshisen/Makefile
index a44aae94748a..de60e4eb82a1 100644
--- a/games/kshisen/Makefile
+++ b/games/kshisen/Makefile
@@ -10,7 +10,7 @@ COMMENT= ${${PORTNAME}_DESC}
LIB_DEPENDS= libKF5KMahjongglib.so:games/libkmahjongg
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons dnssd ecm i18n kdeclarative kio libkdegames \
newstuff widgetsaddons xmlgui
diff --git a/games/ksirk/Makefile b/games/ksirk/Makefile
index 64df27a2fa12..e7fbe7b32b57 100644
--- a/games/ksirk/Makefile
+++ b/games/ksirk/Makefile
@@ -10,7 +10,7 @@ COMMENT= ${${PORTNAME}_DESC}
LIB_DEPENDS= libqca-qt5.so:devel/qca@qt5
-USES= cmake:outsource kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= attica auth codecs completion config configwidgets \
coreaddons crash i18n iconthemes kio libkdegames newstuff \
service wallet widgetsaddons xmlgui
diff --git a/games/ksquares/Makefile b/games/ksquares/Makefile
index 50a71da23c68..4c36901ca0e8 100644
--- a/games/ksquares/Makefile
+++ b/games/ksquares/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons ecm guiaddons i18n iconthemes itemviews kio \
libkdegames notifyconfig widgetsaddons xmlgui
diff --git a/games/ktuberling/Makefile b/games/ktuberling/Makefile
index 6b1108528732..d77bfa608694 100644
--- a/games/ktuberling/Makefile
+++ b/games/ktuberling/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm emoticons guiaddons i18n \
iconthemes init itemmodels itemviews jobwidgets \
diff --git a/games/palapeli/Makefile b/games/palapeli/Makefile
index 4c8212376e30..ce5ef0a245e8 100644
--- a/games/palapeli/Makefile
+++ b/games/palapeli/Makefile
@@ -7,7 +7,8 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource kde:5 qt:5 shared-mime-info tar:xz
+USES= cmake:outsource compiler:c++11-lang kde:5 qt:5 \
+ shared-mime-info tar:xz
USE_KDE= archive auth codecs completion config configwidgets coreaddons \
crash i18n itemviews jobwidgets kio libkdegames notifications service \
widgetsaddons xmlgui
diff --git a/games/picmi/Makefile b/games/picmi/Makefile
index 2a01c17c274d..93b7c03d43e6 100644
--- a/games/picmi/Makefile
+++ b/games/picmi/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons doctools ecm i18n jobwidgets kdeclarative kio \
libkdegames newstuff service widgetsaddons xmlgui
diff --git a/graphics/kolourpaint/Makefile b/graphics/kolourpaint/Makefile
index 06ebc6690c05..3c30550c117f 100644
--- a/graphics/kolourpaint/Makefile
+++ b/graphics/kolourpaint/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE paint program
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash ecm emoticons guiaddons i18n iconthemes init \
itemmodels itemviews jobwidgets kdelibs4support kio libkexiv2 \
diff --git a/graphics/skanlite/Makefile b/graphics/skanlite/Makefile
index b52d30ba594f..91b83f8291d4 100644
--- a/graphics/skanlite/Makefile
+++ b/graphics/skanlite/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/src/COPYING
LIB_DEPENDS= libKF5Sane.so:graphics/libksane \
libpng.so:graphics/png
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= ecm auth config configwidgets codecs completion \
coreaddons doctools i18n jobwidgets kio \
service widgetsaddons xmlgui
diff --git a/graphics/spectacle/Makefile b/graphics/spectacle/Makefile
index 68b6f96cf6a1..6de9e532feae 100644
--- a/graphics/spectacle/Makefile
+++ b/graphics/spectacle/Makefile
@@ -12,7 +12,7 @@ LIB_DEPENDS= libxcb-cursor.so:x11/xcb-util-cursor \
libxcb-image.so:x11/xcb-util-image \
libxcb-util.so:x11/xcb-util
-USES= cmake:outsource gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 pkgconfig qt:5 tar:xz
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
dbusaddons doctools ecm i18n jobwidgets kdeclarative kio \
libkipi newstuff notifications package service widgetsaddons \
diff --git a/misc/kwordquiz/Makefile b/misc/kwordquiz/Makefile
index 64c60763b79d..fbccf9a15861 100644
--- a/misc/kwordquiz/Makefile
+++ b/misc/kwordquiz/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Flash card trainer for KDE Applications
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= attica auth bookmarks codecs completion config configwidgets \
coreaddons crash doctools ecm emoticons guiaddons i18n \
iconthemes init itemmodels itemviews jobwidgets kdeclarative \
diff --git a/multimedia/kdemultimedia-ffmpegthumbs/Makefile b/multimedia/kdemultimedia-ffmpegthumbs/Makefile
index 9e91c908dc36..8370ab405f7c 100644
--- a/multimedia/kdemultimedia-ffmpegthumbs/Makefile
+++ b/multimedia/kdemultimedia-ffmpegthumbs/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libswscale.so:multimedia/ffmpeg
-USES= cmake:outsource kde:5 pkgconfig qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang kde:5 pkgconfig qt:5 tar:xz
USE_KDE= completion config coreaddons i18n jobwidgets kio service widgetsaddons
USE_QT= core dbus gui network widgets xml \
buildtools_build qmake_build
diff --git a/net-im/kaccounts-integration/Makefile b/net-im/kaccounts-integration/Makefile
index dc7f1f31c59a..790e38119c33 100644
--- a/net-im/kaccounts-integration/Makefile
+++ b/net-im/kaccounts-integration/Makefile
@@ -14,7 +14,8 @@ LIB_DEPENDS= libaccounts-glib.so:net-im/libaccounts-glib \
libkeyring-kwallet.so:sysutils/signon-kwallet-extension
RUN_DEPENDS= signon-ui:sysutils/signon-ui
-USES= cmake:outsource gettext pkgconfig kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext pkgconfig kde:5 \
+ qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons dbusaddons ecm \
i18n iconthemes kcmutils kio service wallet widgetsaddons \
akonadi
diff --git a/net-im/kaccounts-providers/Makefile b/net-im/kaccounts-providers/Makefile
index 001b8d4e5cbf..985059435514 100644
--- a/net-im/kaccounts-providers/Makefile
+++ b/net-im/kaccounts-providers/Makefile
@@ -13,7 +13,8 @@ LIB_DEPENDS= libaccounts-glib.so:net-im/libaccounts-glib \
libaccounts-qt5.so:net-im/libaccounts-qt5 \
libsignon-qt5.so:sysutils/signon-qt5
-USES= cmake:outsource gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext gnome kde:5 \
+ pkgconfig qt:5 tar:xz
USE_GNOME= intltool
USE_KDE= config coreaddons i18n kdeclarative kio package service
USE_QT= core declarative gui network xml \
diff --git a/net-im/ktp-common-internals/Makefile b/net-im/ktp-common-internals/Makefile
index a642f1532dfe..4ef3078b28af 100644
--- a/net-im/ktp-common-internals/Makefile
+++ b/net-im/ktp-common-internals/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
RUN_DEPENDS= ${LOCALBASE}/lib/mission-control-plugins.0/mcp-account-manager-accounts-sso.so:net-im/telepathy-accounts-signon \
${LOCALBASE}/libexec/mission-control-5:net-im/telepathy-mission-control
-USES= cmake:outsource gettext pkgconfig kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext pkgconfig kde:5 \
+ qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons ecm i18n iconthemes itemviews jobwidgets kcmutils \
kio notifications notifyconfig parts people service solid \
diff --git a/net/libkvkontakte/Makefile b/net/libkvkontakte/Makefile
index 2f60636a85e8..3c28ab985267 100644
--- a/net/libkvkontakte/Makefile
+++ b/net/libkvkontakte/Makefile
@@ -13,7 +13,7 @@ COMMENT= KDE library for accessing vk.com
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= config coreaddons ecm i18n kdewebkit kio service widgetsaddons
USE_QT= core gui network webkit widgets \
buildtools_build qmake_build
diff --git a/net/libmediawiki/Makefile b/net/libmediawiki/Makefile
index b2db738687eb..99e6289e7278 100644
--- a/net/libmediawiki/Makefile
+++ b/net/libmediawiki/Makefile
@@ -12,7 +12,7 @@ COMMENT= KDE library for accessing MediaWiki sites
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-USES= cmake:outsource kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= coreaddons ecm
USE_QT= core network testlib \
buildtools_build qmake_build
diff --git a/textproc/kompare/Makefile b/textproc/kompare/Makefile
index 2c85690bfe52..49fd50d47e1d 100644
--- a/textproc/kompare/Makefile
+++ b/textproc/kompare/Makefile
@@ -9,7 +9,7 @@ COMMENT= Diff/Patch Frontend
LIB_DEPENDS= libkomparediff2.so:textproc/libkomparediff2
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
doctools ecm i18n iconthemes jobwidgets kio parts service \
sonnet texteditor textwidgets widgetsaddons xmlgui
diff --git a/textproc/kreport/Makefile b/textproc/kreport/Makefile
index 70e2d2f0b24e..328af7d4a7bb 100644
--- a/textproc/kreport/Makefile
+++ b/textproc/kreport/Makefile
@@ -11,7 +11,8 @@ COMMENT= Framework for creation of reports in multiple formats
LIB_DEPENDS= libKPropertyCore3.so:x11-toolkits/kproperty
-USES= cmake:outsource gettext kde:5 python:2.7 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 \
+ python:2.7 qt:5 tar:xz
USE_KDE= config coreaddons ecm marble widgetsaddons
USE_QT= core declarative gui network webkit widgets xml \
buildtools_build printsupport qmake_build
diff --git a/x11-toolkits/qt5-charts/Makefile b/x11-toolkits/qt5-charts/Makefile
index 575019a39262..5a0ba2774b21 100644
--- a/x11-toolkits/qt5-charts/Makefile
+++ b/x11-toolkits/qt5-charts/Makefile
@@ -9,7 +9,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 5 charts module
-USES= qmake qt-dist:5,charts tar:xz
+USES= compiler:c++11-lang qmake qt-dist:5,charts tar:xz
USE_QT= core declarative network gui widgets designer \
buildtools_build qmake_build
diff --git a/x11/konsole/Makefile b/x11/konsole/Makefile
index 9620d59af60b..c7445d0d10eb 100644
--- a/x11/konsole/Makefile
+++ b/x11/konsole/Makefile
@@ -11,7 +11,8 @@ BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-
docbook-xml>0:textproc/docbook-xml
RUN_DEPENDS= keditbookmarks:deskutils/keditbookmarks
-USES= cmake:outsource gettext pkgconfig kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext pkgconfig kde:5 \
+ qt:5 tar:xz
USE_KDE= auth attica bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm emoticons globalaccel guiaddons i18n \
iconthemes init itemmodels jobwidgets kdelibs4support kio \