aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/vuxml/vuln.xml62
-rw-r--r--www/squid/Makefile16
-rw-r--r--www/squid/distinfo8
-rw-r--r--www/squid25/Makefile16
-rw-r--r--www/squid25/distinfo8
-rw-r--r--www/squid26/Makefile16
-rw-r--r--www/squid26/distinfo8
-rw-r--r--www/squid27/Makefile16
-rw-r--r--www/squid27/distinfo8
-rw-r--r--www/squid30/Makefile16
-rw-r--r--www/squid30/distinfo8
-rw-r--r--www/squid31/Makefile16
-rw-r--r--www/squid31/distinfo8
13 files changed, 182 insertions, 24 deletions
diff --git a/security/vuxml/vuln.xml b/security/vuxml/vuln.xml
index df0ee9c21d0f..0dc4f762d740 100644
--- a/security/vuxml/vuln.xml
+++ b/security/vuxml/vuln.xml
@@ -32,6 +32,68 @@ EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-->
<vuxml xmlns="http://www.vuxml.org/apps/vuxml-1">
+ <vuln vid="5fe7e27a-64cb-11d9-9e1e-c296ac722cb3">
+ <topic>squid -- denial of service with forged WCCP messages</topic>
+ <affects>
+ <package>
+ <name>squid</name>
+ <range><lt>2.5.7_6</lt></range>
+ </package>
+ </affects>
+ <description>
+ <body xmlns="http://www.w3.org/1999/xhtml">
+ <p>The squid patches page notes:</p>
+ <blockquote cite="http://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE7-fakeauth_auth">
+ <p>WCCP_I_SEE_YOU messages contain a 'number of caches'
+ field which should be between 1 and 32. Values outside
+ that range may crash Squid if WCCP is enabled, and if an
+ attacker can spoof UDP packets with the WCCP router's IP
+ address.</p>
+ </blockquote>
+ <p>Note: the WCCP protocol is not enabled by default in
+ squid's FreeBSD port.</p>
+ </body>
+ </description>
+ <references>
+ <url>http://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE7-fakeauth_auth</url>
+ </references>
+ <dates>
+ <discovery>2005-01-07</discovery>
+ <entry>2005-01-12</entry>
+ </dates>
+ </vuln>
+
+ <vuln vid="184ab9e0-64cd-11d9-9e1e-c296ac722cb3">
+ <topic>squid -- buffer overflow vulnerability in gopherToHTML</topic>
+ <affects>
+ <package>
+ <name>squid</name>
+ <range><lt>2.5.7_6</lt></range>
+ </package>
+ </affects>
+ <description>
+ <body xmlns="http://www.w3.org/1999/xhtml">
+ <p>The squid patches page notes:</p>
+ <blockquote cite="http://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE7-gopher_html_parsing">
+ <p>A malicious gopher server may return a response with very
+ long lines that cause a buffer overflow in Squid.</p>
+ <p>Workaround: Since gopher is very obscure these days, do
+ not allow Squid to any gopher servers. Use an ACL rule
+ like:</p>
+ <pre>acl Gopher proto gopher
+http_access deny Gopher</pre>
+ </blockquote>
+ </body>
+ </description>
+ <references>
+ <url>http://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE7-gopher_html_parsing</url>
+ </references>
+ <dates>
+ <discovery>2005-01-11</discovery>
+ <entry>2005-01-12</entry>
+ </dates>
+ </vuln>
+
<vuln vid="131bd7c4-64a3-11d9-829a-000a95bc6fae">
<topic>libxine -- DVD subpicture decoder heap overflow</topic>
<affects>
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 6e8f2fb54dcb..a961d9dd5d62 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -74,7 +74,7 @@
PORTNAME= squid
PORTVERSION= 2.5.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -95,7 +95,11 @@ PATCHFILES= squid-2.5.STABLE7-half_closed_POST.patch \
squid-2.5.STABLE7-dothost.patch \
squid-2.5.STABLE7-httpd_accel_vport.patch \
squid-2.5.STABLE7-cachemgr_vmobjects.patch \
- squid-2.5.STABLE7-empty_acls.patch
+ squid-2.5.STABLE7-empty_acls.patch \
+ squid-2.5.STABLE7-close_other.patch \
+ squid-2.5.STABLE7-fakeauth_auth.patch \
+ squid-2.5.STABLE7-gopher_html_parsing.patch \
+ squid-2.5.STABLE7-wccp_denial_of_service.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -169,7 +173,7 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
libexec= cachemgr.cgi digest_pw_auth diskd dnsserver ip_user_check \
squid_ldap_auth squid_ldap_group msnt_auth ncsa_auth ntlm_auth \
pam_auth pinger smb_auth smb_auth.sh squid_unix_group \
- unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl yp_auth
+ unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--datadir=${PREFIX}/etc/squid \
@@ -181,7 +185,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
# Authentication methods and modules:
-basic_auth= NCSA PAM YP MSNT SMB winbind
+basic_auth= NCSA PAM MSNT SMB winbind
external_acl= ip_user unix_group wbinfo_group winbind_group
MAN8+= pam_auth.8 squid_unix_group.8
.if defined(WITH_SQUID_LDAP_AUTH)
@@ -192,6 +196,10 @@ MAN8+= squid_ldap_auth.8 squid_ldap_group.8
basic_auth+= LDAP
external_acl+= ldap_group
.endif
+.if !defined(NO_NIS)
+basic_auth+= YP
+libexec+= yp_auth
+.endif
CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-basic-auth-helpers="${basic_auth}" \
--enable-digest-auth-helpers="password" \
diff --git a/www/squid/distinfo b/www/squid/distinfo
index 98066fde202d..b0ddf91247f9 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -18,3 +18,11 @@ MD5 (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = fdde57025dbfb8caf915
SIZE (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = 6238
MD5 (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 77d4365ebd4216ecde5f08301d43a02b
SIZE (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 4432
+MD5 (squid2.5/squid-2.5.STABLE7-close_other.patch) = 70f04f805907bb6544ae5aaccb74f324
+SIZE (squid2.5/squid-2.5.STABLE7-close_other.patch) = 945
+MD5 (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 1b630af756317f97046adad302faedc4
+SIZE (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 7967
+MD5 (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 1c0ba661b91a17fbd01e5e42430deb86
+SIZE (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 714
+MD5 (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 0c77d92efda39797eb7d59c8d2e942d0
+SIZE (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 1928
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index 6e8f2fb54dcb..a961d9dd5d62 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -74,7 +74,7 @@
PORTNAME= squid
PORTVERSION= 2.5.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -95,7 +95,11 @@ PATCHFILES= squid-2.5.STABLE7-half_closed_POST.patch \
squid-2.5.STABLE7-dothost.patch \
squid-2.5.STABLE7-httpd_accel_vport.patch \
squid-2.5.STABLE7-cachemgr_vmobjects.patch \
- squid-2.5.STABLE7-empty_acls.patch
+ squid-2.5.STABLE7-empty_acls.patch \
+ squid-2.5.STABLE7-close_other.patch \
+ squid-2.5.STABLE7-fakeauth_auth.patch \
+ squid-2.5.STABLE7-gopher_html_parsing.patch \
+ squid-2.5.STABLE7-wccp_denial_of_service.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -169,7 +173,7 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
libexec= cachemgr.cgi digest_pw_auth diskd dnsserver ip_user_check \
squid_ldap_auth squid_ldap_group msnt_auth ncsa_auth ntlm_auth \
pam_auth pinger smb_auth smb_auth.sh squid_unix_group \
- unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl yp_auth
+ unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--datadir=${PREFIX}/etc/squid \
@@ -181,7 +185,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
# Authentication methods and modules:
-basic_auth= NCSA PAM YP MSNT SMB winbind
+basic_auth= NCSA PAM MSNT SMB winbind
external_acl= ip_user unix_group wbinfo_group winbind_group
MAN8+= pam_auth.8 squid_unix_group.8
.if defined(WITH_SQUID_LDAP_AUTH)
@@ -192,6 +196,10 @@ MAN8+= squid_ldap_auth.8 squid_ldap_group.8
basic_auth+= LDAP
external_acl+= ldap_group
.endif
+.if !defined(NO_NIS)
+basic_auth+= YP
+libexec+= yp_auth
+.endif
CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-basic-auth-helpers="${basic_auth}" \
--enable-digest-auth-helpers="password" \
diff --git a/www/squid25/distinfo b/www/squid25/distinfo
index 98066fde202d..b0ddf91247f9 100644
--- a/www/squid25/distinfo
+++ b/www/squid25/distinfo
@@ -18,3 +18,11 @@ MD5 (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = fdde57025dbfb8caf915
SIZE (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = 6238
MD5 (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 77d4365ebd4216ecde5f08301d43a02b
SIZE (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 4432
+MD5 (squid2.5/squid-2.5.STABLE7-close_other.patch) = 70f04f805907bb6544ae5aaccb74f324
+SIZE (squid2.5/squid-2.5.STABLE7-close_other.patch) = 945
+MD5 (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 1b630af756317f97046adad302faedc4
+SIZE (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 7967
+MD5 (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 1c0ba661b91a17fbd01e5e42430deb86
+SIZE (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 714
+MD5 (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 0c77d92efda39797eb7d59c8d2e942d0
+SIZE (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 1928
diff --git a/www/squid26/Makefile b/www/squid26/Makefile
index 6e8f2fb54dcb..a961d9dd5d62 100644
--- a/www/squid26/Makefile
+++ b/www/squid26/Makefile
@@ -74,7 +74,7 @@
PORTNAME= squid
PORTVERSION= 2.5.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -95,7 +95,11 @@ PATCHFILES= squid-2.5.STABLE7-half_closed_POST.patch \
squid-2.5.STABLE7-dothost.patch \
squid-2.5.STABLE7-httpd_accel_vport.patch \
squid-2.5.STABLE7-cachemgr_vmobjects.patch \
- squid-2.5.STABLE7-empty_acls.patch
+ squid-2.5.STABLE7-empty_acls.patch \
+ squid-2.5.STABLE7-close_other.patch \
+ squid-2.5.STABLE7-fakeauth_auth.patch \
+ squid-2.5.STABLE7-gopher_html_parsing.patch \
+ squid-2.5.STABLE7-wccp_denial_of_service.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -169,7 +173,7 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
libexec= cachemgr.cgi digest_pw_auth diskd dnsserver ip_user_check \
squid_ldap_auth squid_ldap_group msnt_auth ncsa_auth ntlm_auth \
pam_auth pinger smb_auth smb_auth.sh squid_unix_group \
- unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl yp_auth
+ unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--datadir=${PREFIX}/etc/squid \
@@ -181,7 +185,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
# Authentication methods and modules:
-basic_auth= NCSA PAM YP MSNT SMB winbind
+basic_auth= NCSA PAM MSNT SMB winbind
external_acl= ip_user unix_group wbinfo_group winbind_group
MAN8+= pam_auth.8 squid_unix_group.8
.if defined(WITH_SQUID_LDAP_AUTH)
@@ -192,6 +196,10 @@ MAN8+= squid_ldap_auth.8 squid_ldap_group.8
basic_auth+= LDAP
external_acl+= ldap_group
.endif
+.if !defined(NO_NIS)
+basic_auth+= YP
+libexec+= yp_auth
+.endif
CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-basic-auth-helpers="${basic_auth}" \
--enable-digest-auth-helpers="password" \
diff --git a/www/squid26/distinfo b/www/squid26/distinfo
index 98066fde202d..b0ddf91247f9 100644
--- a/www/squid26/distinfo
+++ b/www/squid26/distinfo
@@ -18,3 +18,11 @@ MD5 (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = fdde57025dbfb8caf915
SIZE (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = 6238
MD5 (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 77d4365ebd4216ecde5f08301d43a02b
SIZE (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 4432
+MD5 (squid2.5/squid-2.5.STABLE7-close_other.patch) = 70f04f805907bb6544ae5aaccb74f324
+SIZE (squid2.5/squid-2.5.STABLE7-close_other.patch) = 945
+MD5 (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 1b630af756317f97046adad302faedc4
+SIZE (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 7967
+MD5 (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 1c0ba661b91a17fbd01e5e42430deb86
+SIZE (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 714
+MD5 (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 0c77d92efda39797eb7d59c8d2e942d0
+SIZE (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 1928
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index 6e8f2fb54dcb..a961d9dd5d62 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -74,7 +74,7 @@
PORTNAME= squid
PORTVERSION= 2.5.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -95,7 +95,11 @@ PATCHFILES= squid-2.5.STABLE7-half_closed_POST.patch \
squid-2.5.STABLE7-dothost.patch \
squid-2.5.STABLE7-httpd_accel_vport.patch \
squid-2.5.STABLE7-cachemgr_vmobjects.patch \
- squid-2.5.STABLE7-empty_acls.patch
+ squid-2.5.STABLE7-empty_acls.patch \
+ squid-2.5.STABLE7-close_other.patch \
+ squid-2.5.STABLE7-fakeauth_auth.patch \
+ squid-2.5.STABLE7-gopher_html_parsing.patch \
+ squid-2.5.STABLE7-wccp_denial_of_service.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -169,7 +173,7 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
libexec= cachemgr.cgi digest_pw_auth diskd dnsserver ip_user_check \
squid_ldap_auth squid_ldap_group msnt_auth ncsa_auth ntlm_auth \
pam_auth pinger smb_auth smb_auth.sh squid_unix_group \
- unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl yp_auth
+ unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--datadir=${PREFIX}/etc/squid \
@@ -181,7 +185,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
# Authentication methods and modules:
-basic_auth= NCSA PAM YP MSNT SMB winbind
+basic_auth= NCSA PAM MSNT SMB winbind
external_acl= ip_user unix_group wbinfo_group winbind_group
MAN8+= pam_auth.8 squid_unix_group.8
.if defined(WITH_SQUID_LDAP_AUTH)
@@ -192,6 +196,10 @@ MAN8+= squid_ldap_auth.8 squid_ldap_group.8
basic_auth+= LDAP
external_acl+= ldap_group
.endif
+.if !defined(NO_NIS)
+basic_auth+= YP
+libexec+= yp_auth
+.endif
CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-basic-auth-helpers="${basic_auth}" \
--enable-digest-auth-helpers="password" \
diff --git a/www/squid27/distinfo b/www/squid27/distinfo
index 98066fde202d..b0ddf91247f9 100644
--- a/www/squid27/distinfo
+++ b/www/squid27/distinfo
@@ -18,3 +18,11 @@ MD5 (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = fdde57025dbfb8caf915
SIZE (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = 6238
MD5 (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 77d4365ebd4216ecde5f08301d43a02b
SIZE (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 4432
+MD5 (squid2.5/squid-2.5.STABLE7-close_other.patch) = 70f04f805907bb6544ae5aaccb74f324
+SIZE (squid2.5/squid-2.5.STABLE7-close_other.patch) = 945
+MD5 (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 1b630af756317f97046adad302faedc4
+SIZE (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 7967
+MD5 (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 1c0ba661b91a17fbd01e5e42430deb86
+SIZE (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 714
+MD5 (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 0c77d92efda39797eb7d59c8d2e942d0
+SIZE (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 1928
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 6e8f2fb54dcb..a961d9dd5d62 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -74,7 +74,7 @@
PORTNAME= squid
PORTVERSION= 2.5.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -95,7 +95,11 @@ PATCHFILES= squid-2.5.STABLE7-half_closed_POST.patch \
squid-2.5.STABLE7-dothost.patch \
squid-2.5.STABLE7-httpd_accel_vport.patch \
squid-2.5.STABLE7-cachemgr_vmobjects.patch \
- squid-2.5.STABLE7-empty_acls.patch
+ squid-2.5.STABLE7-empty_acls.patch \
+ squid-2.5.STABLE7-close_other.patch \
+ squid-2.5.STABLE7-fakeauth_auth.patch \
+ squid-2.5.STABLE7-gopher_html_parsing.patch \
+ squid-2.5.STABLE7-wccp_denial_of_service.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -169,7 +173,7 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
libexec= cachemgr.cgi digest_pw_auth diskd dnsserver ip_user_check \
squid_ldap_auth squid_ldap_group msnt_auth ncsa_auth ntlm_auth \
pam_auth pinger smb_auth smb_auth.sh squid_unix_group \
- unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl yp_auth
+ unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--datadir=${PREFIX}/etc/squid \
@@ -181,7 +185,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
# Authentication methods and modules:
-basic_auth= NCSA PAM YP MSNT SMB winbind
+basic_auth= NCSA PAM MSNT SMB winbind
external_acl= ip_user unix_group wbinfo_group winbind_group
MAN8+= pam_auth.8 squid_unix_group.8
.if defined(WITH_SQUID_LDAP_AUTH)
@@ -192,6 +196,10 @@ MAN8+= squid_ldap_auth.8 squid_ldap_group.8
basic_auth+= LDAP
external_acl+= ldap_group
.endif
+.if !defined(NO_NIS)
+basic_auth+= YP
+libexec+= yp_auth
+.endif
CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-basic-auth-helpers="${basic_auth}" \
--enable-digest-auth-helpers="password" \
diff --git a/www/squid30/distinfo b/www/squid30/distinfo
index 98066fde202d..b0ddf91247f9 100644
--- a/www/squid30/distinfo
+++ b/www/squid30/distinfo
@@ -18,3 +18,11 @@ MD5 (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = fdde57025dbfb8caf915
SIZE (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = 6238
MD5 (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 77d4365ebd4216ecde5f08301d43a02b
SIZE (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 4432
+MD5 (squid2.5/squid-2.5.STABLE7-close_other.patch) = 70f04f805907bb6544ae5aaccb74f324
+SIZE (squid2.5/squid-2.5.STABLE7-close_other.patch) = 945
+MD5 (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 1b630af756317f97046adad302faedc4
+SIZE (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 7967
+MD5 (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 1c0ba661b91a17fbd01e5e42430deb86
+SIZE (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 714
+MD5 (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 0c77d92efda39797eb7d59c8d2e942d0
+SIZE (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 1928
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 6e8f2fb54dcb..a961d9dd5d62 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -74,7 +74,7 @@
PORTNAME= squid
PORTVERSION= 2.5.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -95,7 +95,11 @@ PATCHFILES= squid-2.5.STABLE7-half_closed_POST.patch \
squid-2.5.STABLE7-dothost.patch \
squid-2.5.STABLE7-httpd_accel_vport.patch \
squid-2.5.STABLE7-cachemgr_vmobjects.patch \
- squid-2.5.STABLE7-empty_acls.patch
+ squid-2.5.STABLE7-empty_acls.patch \
+ squid-2.5.STABLE7-close_other.patch \
+ squid-2.5.STABLE7-fakeauth_auth.patch \
+ squid-2.5.STABLE7-gopher_html_parsing.patch \
+ squid-2.5.STABLE7-wccp_denial_of_service.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -169,7 +173,7 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
libexec= cachemgr.cgi digest_pw_auth diskd dnsserver ip_user_check \
squid_ldap_auth squid_ldap_group msnt_auth ncsa_auth ntlm_auth \
pam_auth pinger smb_auth smb_auth.sh squid_unix_group \
- unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl yp_auth
+ unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--datadir=${PREFIX}/etc/squid \
@@ -181,7 +185,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
# Authentication methods and modules:
-basic_auth= NCSA PAM YP MSNT SMB winbind
+basic_auth= NCSA PAM MSNT SMB winbind
external_acl= ip_user unix_group wbinfo_group winbind_group
MAN8+= pam_auth.8 squid_unix_group.8
.if defined(WITH_SQUID_LDAP_AUTH)
@@ -192,6 +196,10 @@ MAN8+= squid_ldap_auth.8 squid_ldap_group.8
basic_auth+= LDAP
external_acl+= ldap_group
.endif
+.if !defined(NO_NIS)
+basic_auth+= YP
+libexec+= yp_auth
+.endif
CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-basic-auth-helpers="${basic_auth}" \
--enable-digest-auth-helpers="password" \
diff --git a/www/squid31/distinfo b/www/squid31/distinfo
index 98066fde202d..b0ddf91247f9 100644
--- a/www/squid31/distinfo
+++ b/www/squid31/distinfo
@@ -18,3 +18,11 @@ MD5 (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = fdde57025dbfb8caf915
SIZE (squid2.5/squid-2.5.STABLE7-cachemgr_vmobjects.patch) = 6238
MD5 (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 77d4365ebd4216ecde5f08301d43a02b
SIZE (squid2.5/squid-2.5.STABLE7-empty_acls.patch) = 4432
+MD5 (squid2.5/squid-2.5.STABLE7-close_other.patch) = 70f04f805907bb6544ae5aaccb74f324
+SIZE (squid2.5/squid-2.5.STABLE7-close_other.patch) = 945
+MD5 (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 1b630af756317f97046adad302faedc4
+SIZE (squid2.5/squid-2.5.STABLE7-fakeauth_auth.patch) = 7967
+MD5 (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 1c0ba661b91a17fbd01e5e42430deb86
+SIZE (squid2.5/squid-2.5.STABLE7-gopher_html_parsing.patch) = 714
+MD5 (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 0c77d92efda39797eb7d59c8d2e942d0
+SIZE (squid2.5/squid-2.5.STABLE7-wccp_denial_of_service.patch) = 1928