aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/pcre/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/pcre/Makefile b/devel/pcre/Makefile
index 5b1a4caae798..52d619b0effd 100644
--- a/devel/pcre/Makefile
+++ b/devel/pcre/Makefile
@@ -55,8 +55,10 @@ post-patch:
@${REINPLACE_CMD} -E -e '/^install-data-am/,/^$$/ s,install-(dist_doc|dist_html|html)DATA,,g' \
${WRKSRC}/Makefile.in
.endif
- ${REINPLACE_CMD} -e 's/\(pkgconfigdir = \).*/\1$$\(DESTDIR\)$$\(prefix\)\/libdata\/pkgconfig/' \
+ @${REINPLACE_CMD} -e 's/\(pkgconfigdir = \).*/\1$$\(DESTDIR\)$$\(prefix\)\/libdata\/pkgconfig/' \
${WRKSRC}/Makefile.in
+# work around for a autoconf assumption, to fix c++ linking with clang
+ @${REINPLACE_CMD} -e 's|GREP "\\-L"|GREP "conftest\\.$$objext"|g' ${WRKSRC}/configure
post-install:
@${STRIP_CMD} ${PREFIX}/bin/pcregrep ${PREFIX}/bin/pcretest