aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-apptools/Makefile3
-rw-r--r--devel/py-apptools/pkg-descr11
2 files changed, 6 insertions, 8 deletions
diff --git a/devel/py-apptools/Makefile b/devel/py-apptools/Makefile
index abc8a0078226..761108b3a50b 100644
--- a/devel/py-apptools/Makefile
+++ b/devel/py-apptools/Makefile
@@ -18,8 +18,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}traits>=4.5.0:devel/py-traits@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configobj>=5.0.:devel/py-configobj@${PY_FLAVOR}
-USES= python:-2.7
+USES= python
USE_PYTHON= autoplist distutils
+
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/devel/py-apptools/pkg-descr b/devel/py-apptools/pkg-descr
index f6a62fcbe4fc..d0541c030c22 100644
--- a/devel/py-apptools/pkg-descr
+++ b/devel/py-apptools/pkg-descr
@@ -3,22 +3,19 @@ found useful in creating a number of applications.
- apptools.appscripting: Framework for scripting applications.
- apptools.help: Provides a plugin for displaying documents and examples.
-- apptools.io: Provides an abstraction for files and folders in a
- file system.
+- apptools.io: Provides an abstraction for files and folders in a file system.
- apptools.logger: Convenience functions for creating logging handlers
- apptools.naming: Manages naming contexts, supporting non-string data
types and scoped preferences
- apptools.permissions: Supports limiting access to parts of an application
unless the user is appropriately authorised (not full-blown security).
-- apptools.persistence: Supports pickling and restoring the state of an
- object.
+- apptools.persistence: Supports pickling and restoring the state of an object.
- apptools.preferences: Manages application preferences.
- apptools.selection: Manages the communication between providers and
listener of selected items in an application.
- apptools.scripting: A framework for automatic recording of Python scripts.
-- apptools.sweet_pickle: Handles class-level versioning, to support
- loading of saved data that exist over several generations of
- internal class structures.
+- apptools.sweet_pickle: Handles class-level versioning, to support loading of
+ saved data that exist over several generations of internal class structures.
- apptools.template: Supports creating templatizable object hierarchies.
- apptools.type_manager: Manages type extensions, including factories to
generate adapters, and hooks for methods and functions.