aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/gtkatlantic/Makefile8
-rw-r--r--games/warzone2100/Makefile3
-rw-r--r--graphics/gimp-resynthesizer/Makefile3
-rw-r--r--graphics/gkrellkam2/Makefile19
-rw-r--r--graphics/mandelbulber/Makefile2
-rw-r--r--graphics/meshviewer/Makefile2
-rw-r--r--graphics/qcomicbook/Makefile2
-rw-r--r--graphics/separate/Makefile2
-rw-r--r--graphics/shotwell/Makefile3
-rw-r--r--graphics/zathura-djvu/Makefile2
-rw-r--r--japanese/kanjipad/Makefile3
-rw-r--r--korean/fcitx-hangul/Makefile2
-rw-r--r--misc/gkrellm-gamma/Makefile7
-rw-r--r--misc/wmcalendar/Makefile7
-rw-r--r--multimedia/phonon-xine/Makefile7
-rw-r--r--net-mgmt/spectools/Makefile2
-rw-r--r--sysutils/syslog-ng2/Makefile1
-rw-r--r--x11-fm/pbi-thumbnailer/Makefile7
-rw-r--r--x11-wm/simple-ccsm/Makefile9
-rw-r--r--x11/xpra/Makefile1
20 files changed, 32 insertions, 60 deletions
diff --git a/games/gtkatlantic/Makefile b/games/gtkatlantic/Makefile
index 15630839c5e7..12249b081989 100644
--- a/games/gtkatlantic/Makefile
+++ b/games/gtkatlantic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtkatlantic
-# Date created: 2005-03-17
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports-stable/games/gtkatlantic/Makefile,v 1.1 2006/03/04 21:36:29 ahze Exp $
PORTNAME= gtkatlantic
PORTVERSION= 0.4.3
@@ -14,9 +10,9 @@ MASTER_SITES= http://download.tuxfamily.org/gtkatlantic/downloads/v0.4/
MAINTAINER= ports@FreeBSD.org
COMMENT= A game like Monopoly(tm)
+USES= gmake pkgconfig
USE_BZIP2= yes
USE_GNOME= gtk20
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index b45ee7181fc0..8bb0e935dd6e 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -26,11 +26,10 @@ LIB_DEPENDS= physfs:${PORTSDIR}/devel/physfs \
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
USE_XZ= yes
-USES= bison
+USES= bison gmake pkgconfig
GNU_CONFIGURE= yes
USE_OPENAL= al
USE_GL= yes
-USE_GMAKE= yes
USE_SDL= sdl
USE_QT4= corelib network script gui moc_build
QT_NONSTANDARD= yes
diff --git a/graphics/gimp-resynthesizer/Makefile b/graphics/gimp-resynthesizer/Makefile
index a44579752f08..48920b2d2f0b 100644
--- a/graphics/gimp-resynthesizer/Makefile
+++ b/graphics/gimp-resynthesizer/Makefile
@@ -20,9 +20,8 @@ GH_COMMIT= 28cade5
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lintl"
-USES= gettext
+USES= gettext gmake pkgconfig
USE_AUTOTOOLS= aclocal automake
-USE_GMAKE= yes
AUTOMAKE_ARGS= --add-missing
USE_GCC= any # uses nested functions (gcc ext.)
diff --git a/graphics/gkrellkam2/Makefile b/graphics/gkrellkam2/Makefile
index 9c696444cb94..954eced1ec0a 100644
--- a/graphics/gkrellkam2/Makefile
+++ b/graphics/gkrellkam2/Makefile
@@ -1,17 +1,12 @@
-# New ports collection makefile for: gkrellkam2
-# Date Created: 24 Nov 2002
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-# $Id: Makefile,v 1.1.1.1 2002/11/24 03:37:56 jylefort Exp $
-#
-PORTNAME= gkrellkam
-PORTVERSION= 2.0.0
+PORTNAME= gkrellkam
+PORTVERSION= 2.0.0
PORTREVISION= 12
-CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}2/${PORTVERSION}
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}2/${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GKrellM plugin that display thumbnails of periodically updated images
@@ -20,7 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GMAKE= yes
+USES= gmake pkgconfig
LATEST_LINK= gkrellkam2
MAN5= gkrellkam-list.5
diff --git a/graphics/mandelbulber/Makefile b/graphics/mandelbulber/Makefile
index b0426ea5b729..2fae7c7329a9 100644
--- a/graphics/mandelbulber/Makefile
+++ b/graphics/mandelbulber/Makefile
@@ -13,7 +13,7 @@ COMMENT= 3D Mandelbrot fractal renderer
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= glib20 gtk20
BUILD_WRKSRC= ${WRKSRC}/makefiles
MAKEFILE= makefile
diff --git a/graphics/meshviewer/Makefile b/graphics/meshviewer/Makefile
index 174e00d5b753..3e43c39ccc68 100644
--- a/graphics/meshviewer/Makefile
+++ b/graphics/meshviewer/Makefile
@@ -15,9 +15,9 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/mview-${PORTVERSION}
+USES= gmake pkgconfig
USE_GL= glu
USE_QT4= corelib gui opengl moc_build
-USE_GMAKE= yes
CXXFLAGS+= -I. -Imesh -Imathvector \
`pkg-config --cflags QtOpenGL glu`
LDFLAGS+= ${PTHREAD_LIBS} \
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index 709f901af909..f1eecf12dd2f 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
unrar:${PORTSDIR}/archivers/unrar
USE_QT4= corelib gui linguist_build moc_build qmake_build rcc_build \
uic_build xml
-USES= cmake
+USES= cmake pkgconfig
PLIST_FILES= \
${DESKTOPDIR:S,^${PREFIX}/,,}/${PORTNAME}.desktop \
diff --git a/graphics/separate/Makefile b/graphics/separate/Makefile
index 1357e7892728..f29f5da8ab1a 100644
--- a/graphics/separate/Makefile
+++ b/graphics/separate/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
gimp-2.0:${PORTSDIR}/graphics/gimp-app
USE_ZIP= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
BIN_TARGETS= separate separate_import icc_colorspace
L10N_TARGETS= cs es fr ja ko pl ru
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 074938c0e115..876b86898beb 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -26,10 +26,9 @@ LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
rest:${PORTSDIR}/devel/librest
USE_XZ= yes
-USES= shebangfix gettext desktop-file-utils
+USES= shebangfix gettext desktop-file-utils gmake pkgconfig
USE_GNOME= gnomehier gconf2 gtk20 librsvg2
USE_SQLITE= 3
-USE_GMAKE= yes
USE_GSTREAMER1= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --disable-icon-update
diff --git a/graphics/zathura-djvu/Makefile b/graphics/zathura-djvu/Makefile
index e37d4c67c30a..33ab0df7e6f6 100644
--- a/graphics/zathura-djvu/Makefile
+++ b/graphics/zathura-djvu/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= zathura:${PORTSDIR}/graphics/zathura
RUN_DEPENDS= zathura:${PORTSDIR}/graphics/zathura
USE_GNOME= glib20 gtk20
-USE_GMAKE= yes
+USES= gmake pkgconfig
PLIST_FILES= lib/zathura/djvu.so
PLIST_DIRSTRY= lib/zathura
diff --git a/japanese/kanjipad/Makefile b/japanese/kanjipad/Makefile
index 6204313af386..3e3178fa102c 100644
--- a/japanese/kanjipad/Makefile
+++ b/japanese/kanjipad/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= http://fishsoup.net/software/kanjipad/
MAINTAINER= ports@FreeBSD.org
COMMENT= Japanese Handwriting recognition
-USES= perl5
+USES= perl5 gmake pkgconfig
USE_GNOME= gtk20
-USE_GMAKE= yes
MAKE_ARGS= OPTIMIZE="${CFLAGS}" PREFIX="${PREFIX}" \
GTKINC="`pkg-config --cflags gtk+-2.0`"
diff --git a/korean/fcitx-hangul/Makefile b/korean/fcitx-hangul/Makefile
index 9d7c4f9556ec..f92756c4b1f3 100644
--- a/korean/fcitx-hangul/Makefile
+++ b/korean/fcitx-hangul/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= fcitx-config:${PORTSDIR}/chinese/fcitx \
hangul:${PORTSDIR}/korean/libhangul
USE_XZ= yes
-USES= cmake gettext
+USES= cmake gettext pkgconfig
USE_GNOME= intltool
INSTALLS_ICONS= yes
diff --git a/misc/gkrellm-gamma/Makefile b/misc/gkrellm-gamma/Makefile
index 4dc7414aa8b2..6930ee6502cd 100644
--- a/misc/gkrellm-gamma/Makefile
+++ b/misc/gkrellm-gamma/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellm-gamma
-# Date Created: Jun 26 2003
-# Whom: Pav Lucistnik <pav@oook.cz>
-#
+# Created by: Pav Lucistnik <pav@oook.cz>
# $FreeBSD$
-#
PORTNAME= gkrellm-gamma
PORTVERSION= 2.03
@@ -17,6 +13,7 @@ COMMENT= XFree86 gamma correction plugin for GKrellM
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
USE_XORG= x11 xxf86vm
PLIST_FILES= libexec/gkrellm2/plugins/gamma.so
MAKE_ENV= PLUGIN_DIR=${PREFIX}/libexec/gkrellm2/plugins
diff --git a/misc/wmcalendar/Makefile b/misc/wmcalendar/Makefile
index 011fa1be6327..3c28ec0c8d65 100644
--- a/misc/wmcalendar/Makefile
+++ b/misc/wmcalendar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmcalendar
-# Date created: 24 Apr 2003
-# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
-#
+# Created by: Alexey Dokuchaev <danfe@regency.nsu.ru>
# $FreeBSD$
-#
PORTNAME= wmcalendar
PORTVERSION= 0.5.2
@@ -18,6 +14,7 @@ LIB_DEPENDS= ical:${PORTSDIR}/devel/libical
WRKSRC= ${WRKDIR}/${DISTNAME}/Src
+USES= pkgconfig
USE_XORG= xpm
USE_GNOME= gtk20
MAKE_ARGS= CC="${CC}" \
diff --git a/multimedia/phonon-xine/Makefile b/multimedia/phonon-xine/Makefile
index a96f045661dd..14090d340b6a 100644
--- a/multimedia/phonon-xine/Makefile
+++ b/multimedia/phonon-xine/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: phonon
-# Date created: 2008-01-30
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
PORTNAME= phonon
@@ -23,7 +20,7 @@ CONFLICTS= phonon-4.3.0*
PHONON_BRANCH= stable
USE_BZIP2= yes
-USES= cmake
+USES= cmake pkgconfig
USE_KDE4= kdehier automoc4 kdeprefix
USE_QT4= gui dbus xml phonon \
qmake_build moc_build rcc_build uic_build
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 567c555bd021..2f3a76058c0f 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GMAKE= yes
+USES= gmake pkgconfig
PORTDOCS= README
diff --git a/sysutils/syslog-ng2/Makefile b/sysutils/syslog-ng2/Makefile
index 495d5e793fc1..6d4d14a55477 100644
--- a/sysutils/syslog-ng2/Makefile
+++ b/sysutils/syslog-ng2/Makefile
@@ -19,6 +19,7 @@ MAN5= syslog-ng.conf.5
MAN8= syslog-ng.8
USE_RC_SUBR= syslog-ng
+USES= pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20
SUB_FILES= pkg-message
diff --git a/x11-fm/pbi-thumbnailer/Makefile b/x11-fm/pbi-thumbnailer/Makefile
index e58bc7ec4021..b4cf0bc2fcc7 100644
--- a/x11-fm/pbi-thumbnailer/Makefile
+++ b/x11-fm/pbi-thumbnailer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pbi-thumbnailer
-# Date created: 08 June 2008
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pbi-thumbnailer
PORTVERSION= 0.9.2
@@ -14,6 +10,7 @@ MASTER_SITES= http://www.marcuscom.com/pbi-thumbnailer/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Generates icon thumbnails for PC-BSD installer files
+USES= pkgconfig
USE_BZIP2= yes
USE_GNOME= gtk20 gconf2
MAKE_ENV= GCONF_CONFIG_SOURCE=${GCONF_CONFIG_SOURCE}
diff --git a/x11-wm/simple-ccsm/Makefile b/x11-wm/simple-ccsm/Makefile
index 66abe830d406..4a64ec108a72 100644
--- a/x11-wm/simple-ccsm/Makefile
+++ b/x11-wm/simple-ccsm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: simple-ccsm
-# Date created: 2008-09-21
-# Whom: Robert Noland <rnoland@FreeBSD.org>
-#
+# Created by: Robert Noland <rnoland@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= simple-ccsm
PORTVERSION= 0.8.4
@@ -17,8 +13,7 @@ COMMENT= A Python/GTK based settings manager for CompizConfig
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compizconfig-python.pc:${PORTSDIR}/x11-wm/compizconfig-python
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GNOME= pygtk2
USE_PYTHON= -2.7
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index f606eeca00a8..6744f2b3c69d 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
MANCOMPRESSED= no
MAN1= xpra.1 xpra_launcher.1 parti.1
+USES= pkgconfig
USE_BZIP2= yes
USE_PYTHON= yes
USE_XORG= x11 xext xtst xfixes xcomposite xdamage