aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/ghdl/Makefile4
-rw-r--r--databases/adabase/Makefile2
-rw-r--r--math/sc-im/Makefile2
-rw-r--r--misc/talkfilters/Makefile2
-rw-r--r--security/libsparkcrypto/Makefile2
-rw-r--r--shells/sparforte/Makefile4
6 files changed, 14 insertions, 2 deletions
diff --git a/cad/ghdl/Makefile b/cad/ghdl/Makefile
index c574532cbf0f..c13d324f42ca 100644
--- a/cad/ghdl/Makefile
+++ b/cad/ghdl/Makefile
@@ -3,8 +3,8 @@
PORTNAME= ghdl
PORTVERSION= 0.33
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= cad
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -22,6 +22,8 @@ USES= ada gmake
USE_GITHUB= yes
GH_ACCOUNT= tgingold
+BROKEN_aarch64= fails to configure: Configuration aarch64-portbld-freebsd11 not supported
+
GNU_CONFIGURE= yes
GCCVER= 4.9.2
LLVMVER= 35
diff --git a/databases/adabase/Makefile b/databases/adabase/Makefile
index 141158905305..b3557dcfc5aa 100644
--- a/databases/adabase/Makefile
+++ b/databases/adabase/Makefile
@@ -19,6 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= jrmarino
GH_PROJECT= AdaBase
+BROKEN_aarch64= fails to install: digits value out of range, maximum is 15
+
OPTIONS_DEFINE= DEBUG
OPTIONS_MULTI= DBASE
OPTIONS_MULTI_DBASE= MYSQL SQLITE PGSQL
diff --git a/math/sc-im/Makefile b/math/sc-im/Makefile
index a6c298d1431f..7c9b84acaaf8 100644
--- a/math/sc-im/Makefile
+++ b/math/sc-im/Makefile
@@ -19,6 +19,8 @@ USE_GNOME= libxml2
LIB_DEPENDS= libxlsreader.so:math/libxls \
libzip.so:archivers/libzip
+BROKEN_aarch64= fails to compile: conflicting types for __wcwidth
+
WRKSRC_SUBDIR= src
CFLAGS+= -I${LOCALBASE}/include/libxml2
MAKE_ENV+= LDLIBS="${LIBS}"
diff --git a/misc/talkfilters/Makefile b/misc/talkfilters/Makefile
index 3d3e9351f8ed..4333a68f0be7 100644
--- a/misc/talkfilters/Makefile
+++ b/misc/talkfilters/Makefile
@@ -19,6 +19,8 @@ USES= libtool pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+BROKEN_aarch64= fails to install: error in backend: fixup value out of range
+
SUB_FILES= pkg-message
INFO= talkfilters
diff --git a/security/libsparkcrypto/Makefile b/security/libsparkcrypto/Makefile
index fca218f19845..6256cb261944 100644
--- a/security/libsparkcrypto/Makefile
+++ b/security/libsparkcrypto/Makefile
@@ -19,6 +19,8 @@ DOS2UNIX_FILES= Makefile build/libsparkcrypto.gpr \
SPARKARCH:= ${ARCH:S/amd64/x86_64/:S/i386/i686/}
ALL_TARGET= all build
+BROKEN_aarch64= fails to compile: unsupported architecture: aarch64
+
MAKE_ENV+= SPARKARCH=${SPARKARCH} \
SPARK_DIR=${WRKSRC}/src/spark \
MODE=release \
diff --git a/shells/sparforte/Makefile b/shells/sparforte/Makefile
index 77e9951872f5..46a6064d3e35 100644
--- a/shells/sparforte/Makefile
+++ b/shells/sparforte/Makefile
@@ -23,6 +23,8 @@ HAS_CONFIGURE= yes
MAKE_ARGS+= RPM_BUILD_ROOT=1
PORTDOCS= *
+BROKEN_aarch64= fails to compile: gnat1: error: unknown value aarch64 for -march
+
# Repurpose CXXFLAGS for gnatprep options
CXXFLAGS:= -DREADLINE=true \
-DBDB=true
@@ -148,7 +150,7 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/spar
post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
post-install-EXAMPLES-on: