aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/powerdns/Makefile24
-rw-r--r--dns/powerdns/distinfo4
-rw-r--r--dns/powerdns/files/patch-pdns_Makefile_in40
-rw-r--r--dns/powerdns/pkg-plist1
4 files changed, 36 insertions, 33 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 88d899a88be2..cd78f1610492 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -1,11 +1,10 @@
# $FreeBSD$
PORTNAME= powerdns
-PORTVERSION= 3.1
-PORTREVISION?= 2
+PORTVERSION= 3.2
+PORTREVISION?= 0
CATEGORIES= dns ipv6
-MASTER_SITES= http://downloads.powerdns.com/releases/ \
- http://mirrors.evolva.ro/powerdns.com/releases/
+MASTER_SITES= http://downloads.powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
MAINTAINER= tremere@cainites.net
@@ -13,9 +12,7 @@ COMMENT= An advanced DNS server with multiple backends including SQL
LICENSE= GPLv2
-BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam
LIB_DEPENDS= boost_serialization:${PORTSDIR}/devel/boost-libs
-# botan.0:${PORTSDIR}/security/botan
USE_LUA= 5.1
LUA_COMPS= lua
@@ -24,6 +21,7 @@ CONFLICTS= powerdns-devel-[2-3].[0-9]*
USE_GMAKE= YES
USE_SUBMAKE= YES
+USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
CXXFLAGS+= -I${LOCALBASE}/include
@@ -32,7 +30,6 @@ CONFIGURE_ARGS= --with-modules="" \
--with-dynmodules="pipe ${CONFIGURE_MODULES}" \
--sysconfdir="${PREFIX}/etc/pdns" \
--with-boost="${LOCALBASE}"
-# --enable-botan1.8
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
CURDIR2="${.CURDIR}" \
MKDIR="${MKDIR}" \
@@ -43,6 +40,8 @@ MAN8= pdns_control.8 pdns_server.8 zone2sql.8
SUB_FILES= pkg-message
OPTIONS_DEFINE= PGSQL PGSQL_LOCAL MYSQL MYSQL_LOCAL SQLITE SQLITE3 OPENDBX OPENLDAP OPENLDAP_LOCAL GEO DNSSEC
+OPTIONS_SINGLE=DNSSEC
+OPTIONS_SINGLE_DNSSEC= BOTAN CRYPTOPP
PGSQL_DESC= PostgreSQL backend
PGSQL_LOCAL_DESC= RUN_DEPEND on PostgreSQL server
@@ -55,8 +54,10 @@ OPENLDAP_DESC= OpenLDAP backend
OPENLDAP_LOCAL_DESC= RUN_DEPEND on OpenLDAP server
GEO_DESC= Geo backend
DNSSEC_DESC= Enable extra DNSSEC algorithms (13 & 14)
+BOTAN_DESC= Use Botan
+CRYPTOPP_DESC= Use Crypto++
-OPTIONS_DEFAULT= PGSQL
+OPTIONS_DEFAULT= PGSQL CRYPTOPP
.include <bsd.port.options.mk>
@@ -157,7 +158,12 @@ CXXFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= WITHOPENDBX="@comment "
.endif
-.if ${PORT_OPTIONS:MDNSSEC}
+.if ${PORT_OPTIONS:MBOTAN}
+LIB_DEPENDS+= botan.0:${PORTSDIR}/security/botan
+CONFIGURE_ARGS+= --enable-botan1.8
+.endif
+
+.if ${PORT_OPTIONS:MCRYPTOPP}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
CONFIGURE_ARGS+= --enable-cryptopp
.endif
diff --git a/dns/powerdns/distinfo b/dns/powerdns/distinfo
index 1342de235a9e..b5414eebad89 100644
--- a/dns/powerdns/distinfo
+++ b/dns/powerdns/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pdns-3.1.tar.gz) = 1400f7bd659207c0b1f4b8296092e559a7b7bf6a2434951970217d9af06922a1
-SIZE (pdns-3.1.tar.gz) = 1268532
+SHA256 (pdns-3.2.tar.gz) = d1895aba065446dc68e5d7cc792d5303626c71759f61a455531ed65d59c06572
+SIZE (pdns-3.2.tar.gz) = 1293593
diff --git a/dns/powerdns/files/patch-pdns_Makefile_in b/dns/powerdns/files/patch-pdns_Makefile_in
index 4daed84f5889..d480e3fb237b 100644
--- a/dns/powerdns/files/patch-pdns_Makefile_in
+++ b/dns/powerdns/files/patch-pdns_Makefile_in
@@ -1,23 +1,19 @@
--- pdns/Makefile.in.orig 2011-07-22 13:26:07.000000000 +0200
-+++ pdns/Makefile.in 2011-08-09 10:11:41.000000000 +0200
-@@ -51,16 +51,16 @@
- dnslog$(EXEEXT) nproxy$(EXEEXT) notify$(EXEEXT) \
- pdnssec$(EXEEXT) dnsbulktest$(EXEEXT)
- @BOTAN110_TRUE@am__append_1 = botan110signers.cc botansigners.cc
--@BOTAN110_TRUE@am__append_2 = -lbotan-1.10 -lgmp
-+@BOTAN110_TRUE@am__append_2 = -lbotan-1.10
- @BOTAN18_TRUE@am__append_3 = botan18signers.cc botansigners.cc
--@BOTAN18_TRUE@am__append_4 = -lbotan -lgmp
-+@BOTAN18_TRUE@am__append_4 = -lbotan
- @CRYPTOPP_TRUE@am__append_5 = cryptoppsigners.cc
- @CRYPTOPP_TRUE@am__append_6 = -lcryptopp
- @SQLITE3_TRUE@am__append_7 = ssqlite3.cc ssqlite3.hh
- @BOTAN110_TRUE@am__append_8 = botan110signers.cc botansigners.cc
--@BOTAN110_TRUE@am__append_9 = -lbotan-1.10 -lgmp
-+@BOTAN110_TRUE@am__append_9 = -lbotan-1.10
- @BOTAN18_TRUE@am__append_10 = botan18signers.cc botansigners.cc
--@BOTAN18_TRUE@am__append_11 = -lbotan -lgmp
-+@BOTAN18_TRUE@am__append_11 = -lbotan
- @CRYPTOPP_TRUE@am__append_12 = cryptoppsigners.cc
- @CRYPTOPP_TRUE@am__append_13 = -lcryptopp
- @SQLITE3_TRUE@am__append_14 = ssqlite3.cc ssqlite3.hh
++++ pdns/Makefile.in 2013-01-17 13:23:49.892508749 +0100
+@@ -55,14 +55,14 @@
+ @BOTAN110_TRUE@am__append_3 = botan110signers.cc botansigners.cc
+ @BOTAN110_TRUE@am__append_4 = $(BOTAN110_LIBS) -lgmp -lrt
+ @BOTAN18_TRUE@am__append_5 = botan18signers.cc botansigners.cc
+-@BOTAN18_TRUE@am__append_6 = $(BOTAN18_LIBS) -lgmp
++@BOTAN18_TRUE@am__append_6 = $(BOTAN18_LIBS)
+ @CRYPTOPP_TRUE@am__append_7 = cryptoppsigners.cc
+ @CRYPTOPP_TRUE@am__append_8 = -lcryptopp
+ @SQLITE3_TRUE@am__append_9 = ssqlite3.cc ssqlite3.hh
+ @BOTAN110_TRUE@am__append_10 = botan110signers.cc botansigners.cc
+ @BOTAN110_TRUE@am__append_11 = $(BOTAN110_LIBS) -lgmp -lrt
+ @BOTAN18_TRUE@am__append_12 = botan18signers.cc botansigners.cc
+-@BOTAN18_TRUE@am__append_13 = $(BOTAN18_LIBS) -lgmp
++@BOTAN18_TRUE@am__append_13 = $(BOTAN18_LIBS)
+ @CRYPTOPP_TRUE@am__append_14 = cryptoppsigners.cc
+ @CRYPTOPP_TRUE@am__append_15 = -lcryptopp
+ @SQLITE3_TRUE@am__append_16 = ssqlite3.cc ssqlite3.hh
diff --git a/dns/powerdns/pkg-plist b/dns/powerdns/pkg-plist
index 4010385c1030..2f05f1506d12 100644
--- a/dns/powerdns/pkg-plist
+++ b/dns/powerdns/pkg-plist
@@ -1,6 +1,7 @@
bin/dnsreplay
bin/pdns_control
bin/pdnssec
+bin/zone2json
bin/zone2ldap
bin/zone2sql
sbin/pdns_server