aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/zebra-devel/Makefile1
-rw-r--r--net/zebra-devel/files/patch-001_vty_memory_leak18
-rw-r--r--net/zebra-pj/Makefile1
-rw-r--r--net/zebra-pj/files/patch-001_vty_memory_leak18
-rw-r--r--net/zebra/Makefile1
-rw-r--r--net/zebra/files/patch-001_vty_memory_leak18
6 files changed, 57 insertions, 0 deletions
diff --git a/net/zebra-devel/Makefile b/net/zebra-devel/Makefile
index c3aaa4063ddd..b05feb461b64 100644
--- a/net/zebra-devel/Makefile
+++ b/net/zebra-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zebra
PORTVERSION= 0.89a
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.zebra.org/pub/zebra/
# you might need debugging, it's a developer release !
diff --git a/net/zebra-devel/files/patch-001_vty_memory_leak b/net/zebra-devel/files/patch-001_vty_memory_leak
new file mode 100644
index 000000000000..1800c6f3cad0
--- /dev/null
+++ b/net/zebra-devel/files/patch-001_vty_memory_leak
@@ -0,0 +1,18 @@
+--- vty.c.orig Tue Sep 26 23:03:12 2000
++++ vty.c Tue Dec 26 23:18:00 2000
+@@ -1850,10 +1849,13 @@
+ printf ("line: %s\n", buf);
+ #endif /* VTYSH_DEBUG */
+
++ vty_ensure (vty, nbytes);
++ memcpy (vty->buf, buf, nbytes);
++
+ /* Pass this line to parser. */
+- vty->buf = buf;
+ ret = vty_execute (vty);
+- vty->buf = NULL;
++
++ vty_clear_buf (vty);
+
+ /* Return result. */
+ #ifdef VTYSH_DEBUG
diff --git a/net/zebra-pj/Makefile b/net/zebra-pj/Makefile
index c3aaa4063ddd..b05feb461b64 100644
--- a/net/zebra-pj/Makefile
+++ b/net/zebra-pj/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zebra
PORTVERSION= 0.89a
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.zebra.org/pub/zebra/
# you might need debugging, it's a developer release !
diff --git a/net/zebra-pj/files/patch-001_vty_memory_leak b/net/zebra-pj/files/patch-001_vty_memory_leak
new file mode 100644
index 000000000000..1800c6f3cad0
--- /dev/null
+++ b/net/zebra-pj/files/patch-001_vty_memory_leak
@@ -0,0 +1,18 @@
+--- vty.c.orig Tue Sep 26 23:03:12 2000
++++ vty.c Tue Dec 26 23:18:00 2000
+@@ -1850,10 +1849,13 @@
+ printf ("line: %s\n", buf);
+ #endif /* VTYSH_DEBUG */
+
++ vty_ensure (vty, nbytes);
++ memcpy (vty->buf, buf, nbytes);
++
+ /* Pass this line to parser. */
+- vty->buf = buf;
+ ret = vty_execute (vty);
+- vty->buf = NULL;
++
++ vty_clear_buf (vty);
+
+ /* Return result. */
+ #ifdef VTYSH_DEBUG
diff --git a/net/zebra/Makefile b/net/zebra/Makefile
index c3aaa4063ddd..b05feb461b64 100644
--- a/net/zebra/Makefile
+++ b/net/zebra/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zebra
PORTVERSION= 0.89a
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.zebra.org/pub/zebra/
# you might need debugging, it's a developer release !
diff --git a/net/zebra/files/patch-001_vty_memory_leak b/net/zebra/files/patch-001_vty_memory_leak
new file mode 100644
index 000000000000..1800c6f3cad0
--- /dev/null
+++ b/net/zebra/files/patch-001_vty_memory_leak
@@ -0,0 +1,18 @@
+--- vty.c.orig Tue Sep 26 23:03:12 2000
++++ vty.c Tue Dec 26 23:18:00 2000
+@@ -1850,10 +1849,13 @@
+ printf ("line: %s\n", buf);
+ #endif /* VTYSH_DEBUG */
+
++ vty_ensure (vty, nbytes);
++ memcpy (vty->buf, buf, nbytes);
++
+ /* Pass this line to parser. */
+- vty->buf = buf;
+ ret = vty_execute (vty);
+- vty->buf = NULL;
++
++ vty_clear_buf (vty);
+
+ /* Return result. */
+ #ifdef VTYSH_DEBUG