aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/tine20/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/deskutils/tine20/Makefile b/deskutils/tine20/Makefile
index 74db37a90262..c39b1b985174 100644
--- a/deskutils/tine20/Makefile
+++ b/deskutils/tine20/Makefile
@@ -13,10 +13,9 @@ COMMENT= Professional Open Source Groupware and CRM
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_BZIP2= yes
-
+USES= tar:bzip2
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}
SUB_FILES= pkg-message
SUB_LIST= DISTNAME=${DISTNAME}
@@ -26,23 +25,16 @@ APC_DESC= Enable pecl-APC support
MEMCACHE_DESC= Enable pecl-memcache support
USE_MYSQL= yes
-USE_PHP= ctype dom gd iconv json mcrypt mysql pdo_mysql simplexml spl xml zip
+USE_PHP= ctype dom gd iconv json mcrypt mysql pdo_mysql simplexml \
+ spl xml zip
WANT_PHP_WEB= yes
APC_USE= php=apc
LDAP_USE= php=ldap
MEMCACHE_USE= php=memcache
-do-extract:
- @${RM} -rf ${WRKDIR}
- ${MKDIR} ${WRKDIR}/${PORTNAME}
- cd ${WRKDIR}/${PORTNAME} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} ${EXTRACT_AFTER_ARGS}
-
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
-post-install:
- ${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>