aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/liquidsoap/Makefile2
-rw-r--r--benchmarks/expedite/Makefile1
-rw-r--r--cad/geda/Makefile3
-rw-r--r--dns/gdnsd/Makefile1
-rw-r--r--emulators/gxmame/Makefile3
-rw-r--r--graphics/evas-engine-sdl/Makefile2
-rw-r--r--japanese/uim-tomoe-gtk/Makefile9
-rw-r--r--news/nzbget/Makefile2
8 files changed, 9 insertions, 14 deletions
diff --git a/audio/liquidsoap/Makefile b/audio/liquidsoap/Makefile
index 3f095e25a6e8..5b25060387ba 100644
--- a/audio/liquidsoap/Makefile
+++ b/audio/liquidsoap/Makefile
@@ -71,7 +71,7 @@ NO_OCAML_RUNDEPENDS= yes
USE_AUTOTOOLS= autoconf:env automake:env
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
-USES= gmake
+USES= gmake pkgconfig
CONFIGURE_ARGS= --disable-gui --localstatedir=/var
CFLAGS+= -I${LOCALBASE}/${OCAML_LIBDIR}
diff --git a/benchmarks/expedite/Makefile b/benchmarks/expedite/Makefile
index d17e31a2399f..38ef7faeeaaa 100644
--- a/benchmarks/expedite/Makefile
+++ b/benchmarks/expedite/Makefile
@@ -15,6 +15,7 @@ LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_EFL= evas
USE_EFL_EVAS_ENGINES= buffer
USE_LDCONFIG= yes
diff --git a/cad/geda/Makefile b/cad/geda/Makefile
index 5ce6100adb4f..d1aa0bf5b83d 100644
--- a/cad/geda/Makefile
+++ b/cad/geda/Makefile
@@ -20,11 +20,10 @@ RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk
OPTIONS_DEFINE= DOCS
-USES= pathfix gettext perl5
+USES= pathfix gettext perl5 gmake pkgconfig
USE_GNOME= desktopfileutils gtk20
USE_PERL5= run
USE_PYTHON= run
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-libstroke=${LOCALBASE}
USE_LDCONFIG= yes
diff --git a/dns/gdnsd/Makefile b/dns/gdnsd/Makefile
index d12cc0d94f39..1e57a89c5d32 100644
--- a/dns/gdnsd/Makefile
+++ b/dns/gdnsd/Makefile
@@ -19,6 +19,7 @@ OPTIONS_DEFINE= GEOIP
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_XZ= yes
+USES= pkgcofnig
MAN1= gdnsd_geoip_test.1
MAN3= gdnsd-plugin-api.3
diff --git a/emulators/gxmame/Makefile b/emulators/gxmame/Makefile
index 33643773b53f..d9cb9684a808 100644
--- a/emulators/gxmame/Makefile
+++ b/emulators/gxmame/Makefile
@@ -15,9 +15,8 @@ COMMENT= GXmame is a GTK frontend for xmame
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= xmame:${PORTSDIR}/emulators/xmame
-USES= pathfix
+USES= pathfix gmake pkgconfig
USE_GNOME= gtk20 intlhack gnomeprefix
-USE_GMAKE= yes
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/evas-engine-sdl/Makefile b/graphics/evas-engine-sdl/Makefile
index 272ee7eddf7e..6431a7826a1e 100644
--- a/graphics/evas-engine-sdl/Makefile
+++ b/graphics/evas-engine-sdl/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_EFL= evas librt_hack libtool_hack
USE_SDL= sdl
USE_LDCONFIG= yes
diff --git a/japanese/uim-tomoe-gtk/Makefile b/japanese/uim-tomoe-gtk/Makefile
index 5847e2cab3ef..1f50a30bc1cc 100644
--- a/japanese/uim-tomoe-gtk/Makefile
+++ b/japanese/uim-tomoe-gtk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ja-uim-tomoe-gtk
-# Date created: 9 Apr 2007
-# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
-#
+# Created by: Hajimu UMEMOTO <ume@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= uim-tomoe-gtk
PORTVERSION= 0.6.0
@@ -19,8 +15,7 @@ LIB_DEPENDS= tomoe.1:${PORTSDIR}/japanese/tomoe \
uim.8:${PORTSDIR}/textproc/uim
USE_GNOME= lthack gtk20
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
PLIST_FILES= bin/uim-tomoe-gtk \
diff --git a/news/nzbget/Makefile b/news/nzbget/Makefile
index 1d840fe90b45..e5f6a503d271 100644
--- a/news/nzbget/Makefile
+++ b/news/nzbget/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
sigc-2:${PORTSDIR}/devel/libsigc++20
+USES= gmake pkgconfig
USE_RC_SUBR= nzbget
GNU_CONFIGURE= yes
CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
@@ -21,7 +22,6 @@ MAKE_JOBS_UNSAFE=yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= ${PTHREAD_LIBS}
CFLAGS+= ${PTHREAD_CFLAGS}
-USE_GMAKE= yes
PAR_DESC= Support verifying/repairing with par2 files
OPTIONS_DEFINE= PAR