aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/libsndfile/Makefile1
-rw-r--r--converters/fribidi/Makefile1
-rw-r--r--devel/libIDL/Makefile1
-rw-r--r--devel/libevent/Makefile1
-rw-r--r--devel/pth/Makefile1
-rw-r--r--dns/libidn/Makefile1
-rw-r--r--graphics/jbig2dec/Makefile1
-rw-r--r--graphics/liblqr-1/Makefile1
-rw-r--r--graphics/webp/Makefile1
-rw-r--r--multimedia/libkate/Makefile1
-rw-r--r--security/libksba/Makefile1
-rw-r--r--security/libtasn1/Makefile1
-rw-r--r--textproc/aspell/Makefile1
13 files changed, 13 insertions, 0 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 6681e86175a3..171cb931bf82 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -16,6 +16,7 @@ COMMENT= Reading and writing files containing sampled sound (like WAV or AIFF)
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+WITH_FBSD10_FIX= yes
USE_GNOME= gnomehack pkgconfig
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/converters/fribidi/Makefile b/converters/fribidi/Makefile
index cddc460eec93..198274898e4c 100644
--- a/converters/fribidi/Makefile
+++ b/converters/fribidi/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= http://fribidi.org/download/
MAINTAINER= gnome@FreeBSD.org
COMMENT= A Free Implementation of the Unicode Bidirectional Algorithm
+WITH_FBSD10_FIX=yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
USE_LDCONFIG= yes
diff --git a/devel/libIDL/Makefile b/devel/libIDL/Makefile
index 832c9f3119b2..f7a636729222 100644
--- a/devel/libIDL/Makefile
+++ b/devel/libIDL/Makefile
@@ -16,6 +16,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A library for creating trees of CORBA IDL files
+WITH_FBSD10_FIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
diff --git a/devel/libevent/Makefile b/devel/libevent/Makefile
index 1a3bf95d1920..1712bac8e6a5 100644
--- a/devel/libevent/Makefile
+++ b/devel/libevent/Makefile
@@ -17,6 +17,7 @@ COMMENT= Provides an API to execute callback functions on certain events
LICENSE= BSD
+WITH_FBSD10_FIX= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index 5ed43b6bed95..27279b060828 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -17,6 +17,7 @@ COMMENT= GNU Portable Threads
MAKE_JOBS_UNSAFE= yes
+WITH_FBSD10_FIX= yes
USE_LDCONFIG= ${PREFIX}/lib/pth
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-optimize \
diff --git a/dns/libidn/Makefile b/dns/libidn/Makefile
index 75af052a6a8b..e7d1d6cb8ca8 100644
--- a/dns/libidn/Makefile
+++ b/dns/libidn/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gaod@hychen.org
COMMENT= Internationalized Domain Names command line tool
+WITH_FBSD10_FIX= yes
USE_GNOME= gnomehack pkgconfig
USE_ICONV= yes
USE_LDCONFIG= yes
diff --git a/graphics/jbig2dec/Makefile b/graphics/jbig2dec/Makefile
index ccdfcef54ec1..c64f30f3e72c 100644
--- a/graphics/jbig2dec/Makefile
+++ b/graphics/jbig2dec/Makefile
@@ -19,6 +19,7 @@ USE_XZ= yes:src
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
+WITH_FBSD10_FIX= yes
OPTIONS= PNG "Enable png support" On \
TESTS "Download and use test-images for post-build testing" Off
diff --git a/graphics/liblqr-1/Makefile b/graphics/liblqr-1/Makefile
index 9a3794bd489b..191f33f63042 100644
--- a/graphics/liblqr-1/Makefile
+++ b/graphics/liblqr-1/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= http://liblqr.wdfiles.com/local--files/en:download-page/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An easy to use C/C++ seam carving library
+WITH_FBSD10_FIX= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/graphics/webp/Makefile b/graphics/webp/Makefile
index 1761752dde92..31458934f5d3 100644
--- a/graphics/webp/Makefile
+++ b/graphics/webp/Makefile
@@ -17,6 +17,7 @@ COMMENT= Google WebP image format conversion tool
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png
+WITH_FBSD10_FIX= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
diff --git a/multimedia/libkate/Makefile b/multimedia/libkate/Makefile
index 9bba0bd27314..c100667a596f 100644
--- a/multimedia/libkate/Makefile
+++ b/multimedia/libkate/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= ogg.7:${PORTSDIR}/audio/libogg \
png.6:${PORTSDIR}/graphics/png
+WITH_FBSD10_FIX=yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
diff --git a/security/libksba/Makefile b/security/libksba/Makefile
index ec5b7a910e80..a42dbd5e85c4 100644
--- a/security/libksba/Makefile
+++ b/security/libksba/Makefile
@@ -23,6 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-static
USE_LDCONFIG= yes
USE_PERL5_BUILD=yes
+WITH_FBSD10_FIX=yes
INFO= ksba
diff --git a/security/libtasn1/Makefile b/security/libtasn1/Makefile
index bdc61e37fdef..63a032baab3a 100644
--- a/security/libtasn1/Makefile
+++ b/security/libtasn1/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= libtasn1
MAINTAINER= novel@FreeBSD.org
COMMENT= ASN.1 structure parser library
+WITH_FBSD10_FIX= yes
USE_LDCONFIG= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 7aae8fd2b923..3eb723063052 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -33,6 +33,7 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD= yes
USE_LDCONFIG= yes
+WITH_FBSD10_FIX= yes
SLAVEDIRS= textproc/aspell-without-dicten