aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--misc/amanda-server/Makefile32
-rw-r--r--misc/amanda-server/distinfo4
-rw-r--r--misc/amanda32-server/Makefile32
-rw-r--r--misc/amanda32-server/distinfo4
6 files changed, 22 insertions, 54 deletions
diff --git a/GIDs b/GIDs
index 4a48a92a9ea5..ea632afcf144 100644
--- a/GIDs
+++ b/GIDs
@@ -1,6 +1,6 @@
# $FreeBSD$
# Please keep this file sorted by GID!
-operator:*:5:
+operator:*:5:amanda
mail:*:6:postfix,clamav
smmsp:*:25:
bind:*:53:
diff --git a/UIDs b/UIDs
index 6029a1dad6e7..387fb7f426f9 100644
--- a/UIDs
+++ b/UIDs
@@ -80,7 +80,7 @@ dhcpd:*:136:136::0:0:ISC DHCP daemon:/nonexistent:/usr/sbin/nologin
mpd:*:137:137::0:0:MusicPD pseudo-user:/usr/local/var/mpd:/usr/sbin/nologin
wolfpack:*:138:138::0:0:Wolfpack Empire Server:/usr/local/share/wolfpack:/usr/sbin/nologin
shellinabox:*:139:139::0:0:Shell In A Box:/nonexistent:/usr/sbin/nologin
-amanda:*:140:140::0:0:Amanda Daemon:/nonexistent:/usr/sbin/nologin
+amanda:*:140:140::0:0:Amanda Daemon:/var/db/amanda:/usr/sbin/nologin
cricket:*:141:80::0:0:Cricket Monitoring User:/usr/local/cricket:/usr/sbin/nologin
ladvd:*:142:142::0:0:Ladvd User:/var/empty:/usr/sbin/nologin
dovecot:*:143:143::0:0:Dovecot User:/var/empty:/usr/sbin/nologin
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index ec7963bdbb54..f209ed2af0ce 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amanda
-PORTVERSION= 3.2.2
+PORTVERSION= 3.2.3
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -34,7 +34,7 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-dump-honor-nodump \
--prefix=${PREFIX} \
--disable-glibtest \
- --with-user=${USERS} --with-group=${GROUPS} \
+ --with-user=${USERS} --with-group=${AMANDA_GROUP} \
--with-bsdtcp-security --with-bsdudp-security \
--with-ssh-security
CONFIGURE_ENV= PERL=${LOCALBASE}/bin/perl-amanda
@@ -51,11 +51,11 @@ USERS= ${AMANDA_USER}
.else
USERS?= amanda
.endif
-.if defined(AMANDA_GROUP)
-GROUPS= ${AMANDA_GROUP}
-.else
-GROUPS?= amanda
+.if !defined(AMANDA_GROUP)
+AMANDA_GROUP= amanda
.endif
+GROUPS?= operator amanda
+
AMANDA_GNUTAR_LISTDIR?= ${PREFIX}/var/amanda/gnutar-lists
AMANDA_DATES?= ${PREFIX}/var/amanda/amandates
PLIST_SUB= SHLIBVER=${PORTVERSION} AMANDA_DATES=${AMANDA_DATES}
@@ -79,16 +79,6 @@ RUN_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
SUB_FILES+= pkg-install pkg-deinstall
SUB_LIST+= PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
-pre-everything::
-.if defined(AMANDA_TAPE)
- @${ECHO} "Use of \$AMANDA_TAPE is deprecated. Specify it in amanda.conf."
- exit 1
-.endif
-.if defined(AMANDA_CONFIG)
- @${ECHO} "Use of \$AMANDA_CONFIG is deprecated. Specify it in amanda.conf."
- exit 1
-.endif
-
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@@ -165,12 +155,6 @@ post-install:
# amanda-client part
.else
-pre-everything::
-.if defined(AMANDA_CONFIG)
- @${ECHO} "Use of \$AMANDA_CONFIG is deprecated. Specify it in amanda.conf."
- exit 1
-.endif
-
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@@ -215,9 +199,9 @@ MAN8= amanda.8 \
post-install:
${MKDIR} ${AMANDA_GNUTAR_LISTDIR}
- ${CHOWN} ${USERS}:${GROUPS} ${AMANDA_GNUTAR_LISTDIR}
+ ${CHOWN} ${USERS}:${AMANDA_GROUP} ${AMANDA_GNUTAR_LISTDIR}
${TOUCH} ${AMANDA_DATES}
- ${CHOWN} ${USERS}:${GROUPS} ${AMANDA_DATES}
+ ${CHOWN} ${USERS}:${AMANDA_GROUP} ${AMANDA_DATES}
${CAT} ${PKGMESSAGE}
.endif
diff --git a/misc/amanda-server/distinfo b/misc/amanda-server/distinfo
index 5db6f282e614..d098fe5653d9 100644
--- a/misc/amanda-server/distinfo
+++ b/misc/amanda-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (amanda-3.2.2.tar.gz) = 6bf8e3e39a55e877d8cbe75b927b985b9316654af26a3bd47022a2a2c99b3bac
-SIZE (amanda-3.2.2.tar.gz) = 4120254
+SHA256 (amanda-3.2.3.tar.gz) = 8ac37cc82add71ffd009fa4ea8763c633037277e15d51d28aefb8cb4c0b6a7fd
+SIZE (amanda-3.2.3.tar.gz) = 4125405
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index ec7963bdbb54..f209ed2af0ce 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amanda
-PORTVERSION= 3.2.2
+PORTVERSION= 3.2.3
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -34,7 +34,7 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-dump-honor-nodump \
--prefix=${PREFIX} \
--disable-glibtest \
- --with-user=${USERS} --with-group=${GROUPS} \
+ --with-user=${USERS} --with-group=${AMANDA_GROUP} \
--with-bsdtcp-security --with-bsdudp-security \
--with-ssh-security
CONFIGURE_ENV= PERL=${LOCALBASE}/bin/perl-amanda
@@ -51,11 +51,11 @@ USERS= ${AMANDA_USER}
.else
USERS?= amanda
.endif
-.if defined(AMANDA_GROUP)
-GROUPS= ${AMANDA_GROUP}
-.else
-GROUPS?= amanda
+.if !defined(AMANDA_GROUP)
+AMANDA_GROUP= amanda
.endif
+GROUPS?= operator amanda
+
AMANDA_GNUTAR_LISTDIR?= ${PREFIX}/var/amanda/gnutar-lists
AMANDA_DATES?= ${PREFIX}/var/amanda/amandates
PLIST_SUB= SHLIBVER=${PORTVERSION} AMANDA_DATES=${AMANDA_DATES}
@@ -79,16 +79,6 @@ RUN_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
SUB_FILES+= pkg-install pkg-deinstall
SUB_LIST+= PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
-pre-everything::
-.if defined(AMANDA_TAPE)
- @${ECHO} "Use of \$AMANDA_TAPE is deprecated. Specify it in amanda.conf."
- exit 1
-.endif
-.if defined(AMANDA_CONFIG)
- @${ECHO} "Use of \$AMANDA_CONFIG is deprecated. Specify it in amanda.conf."
- exit 1
-.endif
-
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@@ -165,12 +155,6 @@ post-install:
# amanda-client part
.else
-pre-everything::
-.if defined(AMANDA_CONFIG)
- @${ECHO} "Use of \$AMANDA_CONFIG is deprecated. Specify it in amanda.conf."
- exit 1
-.endif
-
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@@ -215,9 +199,9 @@ MAN8= amanda.8 \
post-install:
${MKDIR} ${AMANDA_GNUTAR_LISTDIR}
- ${CHOWN} ${USERS}:${GROUPS} ${AMANDA_GNUTAR_LISTDIR}
+ ${CHOWN} ${USERS}:${AMANDA_GROUP} ${AMANDA_GNUTAR_LISTDIR}
${TOUCH} ${AMANDA_DATES}
- ${CHOWN} ${USERS}:${GROUPS} ${AMANDA_DATES}
+ ${CHOWN} ${USERS}:${AMANDA_GROUP} ${AMANDA_DATES}
${CAT} ${PKGMESSAGE}
.endif
diff --git a/misc/amanda32-server/distinfo b/misc/amanda32-server/distinfo
index 5db6f282e614..d098fe5653d9 100644
--- a/misc/amanda32-server/distinfo
+++ b/misc/amanda32-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (amanda-3.2.2.tar.gz) = 6bf8e3e39a55e877d8cbe75b927b985b9316654af26a3bd47022a2a2c99b3bac
-SIZE (amanda-3.2.2.tar.gz) = 4120254
+SHA256 (amanda-3.2.3.tar.gz) = 8ac37cc82add71ffd009fa4ea8763c633037277e15d51d28aefb8cb4c0b6a7fd
+SIZE (amanda-3.2.3.tar.gz) = 4125405