aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/scummvm/Makefile7
-rw-r--r--emulators/scummvm/files/patch-sound::mixer.h11
-rw-r--r--games/scummvm/Makefile7
-rw-r--r--games/scummvm/files/patch-sound::mixer.h11
4 files changed, 8 insertions, 28 deletions
diff --git a/emulators/scummvm/Makefile b/emulators/scummvm/Makefile
index 3322175ccbea..8db7e5bf9b0a 100644
--- a/emulators/scummvm/Makefile
+++ b/emulators/scummvm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scummvm
PORTVERSION= 0.3.0b
+PORTREVISION= 1
CATEGORIES= games emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +16,8 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}-src
MAINTAINER= flynn@energyhq.homeip.net
COMMENT= Free implementation of LucasArts S.C.U.M.M. interpreter
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
+ mad.1:${PORTSDIR}/audio/mad
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-0.3.0
@@ -32,8 +34,7 @@ pre-patch:
${WRKSRC}/backends/sdl/build.rules
post-configure:
- @${REINPLACE_CMD} -e 's@-lmad@@g; \
- s@:= -g -O@+= ${CFLAGS}@' \
+ @${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' \
${WRKSRC}/Makefile
do-install:
diff --git a/emulators/scummvm/files/patch-sound::mixer.h b/emulators/scummvm/files/patch-sound::mixer.h
deleted file mode 100644
index 35b749684e18..000000000000
--- a/emulators/scummvm/files/patch-sound::mixer.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- sound/mixer.h.orig Wed Jan 1 13:21:10 2003
-+++ sound/mixer.h Wed Jan 1 13:21:41 2003
-@@ -25,6 +25,8 @@
-
- #include <stdio.h>
-
-+#undef USE_MAD
-+
- #ifdef USE_MAD
- #include <mad.h>
- #endif
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index 3322175ccbea..8db7e5bf9b0a 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scummvm
PORTVERSION= 0.3.0b
+PORTREVISION= 1
CATEGORIES= games emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +16,8 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}-src
MAINTAINER= flynn@energyhq.homeip.net
COMMENT= Free implementation of LucasArts S.C.U.M.M. interpreter
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
+ mad.1:${PORTSDIR}/audio/mad
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-0.3.0
@@ -32,8 +34,7 @@ pre-patch:
${WRKSRC}/backends/sdl/build.rules
post-configure:
- @${REINPLACE_CMD} -e 's@-lmad@@g; \
- s@:= -g -O@+= ${CFLAGS}@' \
+ @${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' \
${WRKSRC}/Makefile
do-install:
diff --git a/games/scummvm/files/patch-sound::mixer.h b/games/scummvm/files/patch-sound::mixer.h
deleted file mode 100644
index 35b749684e18..000000000000
--- a/games/scummvm/files/patch-sound::mixer.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- sound/mixer.h.orig Wed Jan 1 13:21:10 2003
-+++ sound/mixer.h Wed Jan 1 13:21:41 2003
-@@ -25,6 +25,8 @@
-
- #include <stdio.h>
-
-+#undef USE_MAD
-+
- #ifdef USE_MAD
- #include <mad.h>
- #endif