aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/p5-Net-MSN/Makefile21
-rw-r--r--net-im/p5-Net-MSN/distinfo2
-rw-r--r--net-im/p5-Net-MSN/pkg-descr4
-rw-r--r--net-im/p5-Net-MSN/pkg-plist11
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-MSN/Makefile21
-rw-r--r--net/p5-Net-MSN/distinfo2
-rw-r--r--net/p5-Net-MSN/pkg-descr4
-rw-r--r--net/p5-Net-MSN/pkg-plist11
9 files changed, 77 insertions, 0 deletions
diff --git a/net-im/p5-Net-MSN/Makefile b/net-im/p5-Net-MSN/Makefile
new file mode 100644
index 000000000000..fa382ca78714
--- /dev/null
+++ b/net-im/p5-Net-MSN/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Net-MSN
+# Date created: 22 June 2004
+# Whom: snowchyld
+# $FreeBSD$
+
+PORTNAME= Net-MSN
+PORTVERSION= 1.022
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= p5-net-msn-freebsd-ports@snowchyld.org
+COMMENT= Net::MSN interface
+
+BUILD_DEPENDS= ${SITE_PERL}/Hash/Merge.pm:${PORTSDIR}/textproc/p5-Hash-Merge
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-MSN/distinfo b/net-im/p5-Net-MSN/distinfo
new file mode 100644
index 000000000000..df5226ecbd78
--- /dev/null
+++ b/net-im/p5-Net-MSN/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-MSN-1.022.tar.gz) = e2a2716b9197e573eaffd39a9d8250ce
+SIZE (Net-MSN-1.022.tar.gz) = 12639
diff --git a/net-im/p5-Net-MSN/pkg-descr b/net-im/p5-Net-MSN/pkg-descr
new file mode 100644
index 000000000000..f06bd90bb1e2
--- /dev/null
+++ b/net-im/p5-Net-MSN/pkg-descr
@@ -0,0 +1,4 @@
+Net::MSN interface to the MSN protocol
+
+- snowchyld
+<p5-net-msn-freebsd-ports@snowchyld.org>
diff --git a/net-im/p5-Net-MSN/pkg-plist b/net-im/p5-Net-MSN/pkg-plist
new file mode 100644
index 000000000000..cb6c58978e0e
--- /dev/null
+++ b/net-im/p5-Net-MSN/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Net/MSN/Base.pm
+%%SITE_PERL%%/Net/MSN/Debug.pm
+%%SITE_PERL%%/Net/MSN/PassPort.pm
+%%SITE_PERL%%/Net/MSN/SB.pm
+%%SITE_PERL%%/Net/MSN.pm
+%%SITE_PERL%%/Net/client.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MSN/.packlist
+@dirrm %%SITE_PERL%%/Net/MSN
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MSN
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MSN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net/MSN 2>/dev/null || true
diff --git a/net/Makefile b/net/Makefile
index c057a8ad5363..f776d9a50771 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -445,6 +445,7 @@
SUBDIR += p5-Net-ICQ2000
SUBDIR += p5-Net-Ident
SUBDIR += p5-Net-Jabber
+ SUBDIR += p5-Net-MSN
SUBDIR += p5-Net-MovableType
SUBDIR += p5-Net-ParseWhois
SUBDIR += p5-Net-Patricia
diff --git a/net/p5-Net-MSN/Makefile b/net/p5-Net-MSN/Makefile
new file mode 100644
index 000000000000..fa382ca78714
--- /dev/null
+++ b/net/p5-Net-MSN/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Net-MSN
+# Date created: 22 June 2004
+# Whom: snowchyld
+# $FreeBSD$
+
+PORTNAME= Net-MSN
+PORTVERSION= 1.022
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= p5-net-msn-freebsd-ports@snowchyld.org
+COMMENT= Net::MSN interface
+
+BUILD_DEPENDS= ${SITE_PERL}/Hash/Merge.pm:${PORTSDIR}/textproc/p5-Hash-Merge
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-MSN/distinfo b/net/p5-Net-MSN/distinfo
new file mode 100644
index 000000000000..df5226ecbd78
--- /dev/null
+++ b/net/p5-Net-MSN/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-MSN-1.022.tar.gz) = e2a2716b9197e573eaffd39a9d8250ce
+SIZE (Net-MSN-1.022.tar.gz) = 12639
diff --git a/net/p5-Net-MSN/pkg-descr b/net/p5-Net-MSN/pkg-descr
new file mode 100644
index 000000000000..f06bd90bb1e2
--- /dev/null
+++ b/net/p5-Net-MSN/pkg-descr
@@ -0,0 +1,4 @@
+Net::MSN interface to the MSN protocol
+
+- snowchyld
+<p5-net-msn-freebsd-ports@snowchyld.org>
diff --git a/net/p5-Net-MSN/pkg-plist b/net/p5-Net-MSN/pkg-plist
new file mode 100644
index 000000000000..cb6c58978e0e
--- /dev/null
+++ b/net/p5-Net-MSN/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Net/MSN/Base.pm
+%%SITE_PERL%%/Net/MSN/Debug.pm
+%%SITE_PERL%%/Net/MSN/PassPort.pm
+%%SITE_PERL%%/Net/MSN/SB.pm
+%%SITE_PERL%%/Net/MSN.pm
+%%SITE_PERL%%/Net/client.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MSN/.packlist
+@dirrm %%SITE_PERL%%/Net/MSN
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MSN
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MSN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net/MSN 2>/dev/null || true